Subject: [Mipshop] RE: [Mobopts] Re: [Mip6] Delay Analysis for Handoffs with Mobile IPv6Route Optimization

From: "Atiquzzaman, Mohammed" <[email-masked]>
Date: Sun, 15 Jan 2006 12:14:40 -0600

We also studied the handoff delay between various MIPv6 variants and
SIGMA (a transport layer handoff scheme) and presented the result at
Globecom 2005. In most cases, SIGMA achieved a lower handoff latency
than the MIPv6 variants by exploting multihoming.

Shaojian Fu, Mohammed Atiquzzaman, Handover latency comparison of SIGMA,
FMIPv6, HMIPv6, and FHMIPv6, IEEE GlobeCom, St. Louis, MO, November
28-December 02, 2005
http://www.cs.ou.edu/~netlab/Pub/L2effect-TraSH-globecom05-camera.pdf 

Mohammed Atiquzzaman                      Tel:   (405) 325 8077
Professor, School of Computer Science     Fax:   (405) 325 4044,
University of Oklahoma                           
200 Felgar St., Room EL-160               Email: [email-masked]
Norman, OK 73019-6151                            [email-masked]
www.cs.ou.edu/~atiq 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christian Vogt
> Sent: Sunday, January 15, 2006 7:40 AM
> To: [email-masked]
> Cc: Mip6; Mipshop; Mobopts
> Subject: [Mobopts] Re: [Mip6] Delay Analysis for Handoffs 
> with Mobile IPv6Route Optimization
> 
> > We analysed these properties for the case of FMIPv6 (which should be
> > transferable in major parts, e.g., fmip needs fback, you need BU to
> > arrive ...) and found no significant improvement by 
> predicitions (see
> > bib-reference attached).
> 
> Thomas,
> 
> thanks for bringing this up.
> 
> While your results [1] on FMIPv6 and HMIPv6 shed light on the
> performance of proactivity in combination with local mobility
> optimizations and are as such undoubtedly very important, I do not
> necessarily consent with your statement that those results can be
> conveyed to the end-to-end mobility management that we have been
> analyzing [2].
> 
> During an end-to-end Mobile IPv6 handoff, communications are 
> delayed for
> at least a global RTT between the MN and the CN (assuming that
> end-to-end optimizations such as EBU and CBA are deployed).  This
> minimum delay can basically be eliminated in two ways:
> 
> - Proactivity, i.e., send a BU from the old location and move 
> to the new
> location only when packets can expected to have arrived there.
> 
> - Local mobility optimizations such as FMIPv6 and HMIPv6, which either
> eliminate global signaling (HMIPv6), or move it off the critical
> blackout period (FMIPv6).
> 
> Your work [1] deals with the second option, our's [2] deals 
> with the first.
> 
> To be more explicit, let's assume we use FMIPv6.  All global signaling
> is then deferred until the MN has already resumed communications, from
> the new link, through the AR-to-AR tunnel.  This is true for both
> proactive and reactive FMIPv6 modes.  What *FMIPv6 proactivity* saves
> you is just an FBU's propagation time from the new AR to the old AR.
> Compare this to the global RTT that *end-to-end proacitvity* 
> potentially
> saves you.
> 
> Referring to the problems with predictive handoff procedures that you
> mention:  You are correct, and section 7.1 in our analysis duely
> discusses this.  As far as unreliability in predictions goes:
> Unfortunately, you are right, but that's a different 
> construction site. ;)
> 
> Regards,
> - Christian
> 
> [1] http://www.informatik.haw-hamburg.de/~schmidt/papers/telesys05.pdf
> [2]
> http://doc.tm.uka.de/2006/vogt-2006-delay-analysis-for-reactiv
> e-and-proactive-handoffs.pdf
> 
> -- 
> Christian Vogt, Institute of Telematics, University of Karlsruhe
> www.tm.uka.de/~chvogt/pubkey/
> 
> 
> 
> Thomas C Schmidt wrote:
> > Dear Christian,
> > 
> > thanks for bringing your technical report to our attention!
> > 
> > For a comment: it is our experience that the optimistic 
> concept of zero
> > handover delay due to predictive procedures does not 
> survive reality.
> > 
> > This is mainly due to
> > 
> >   - the independence of anticipation, signaling and handoff in
> >     occurrence and timescale.
> > 
> >   - predictions turning out as rather unreliable.
> > 
> > We analysed these properties for the case of FMIPv6 (which should be
> > transferable in major parts, e.g., fmip needs fback, you need BU to
> > arrive ...) and found no significant improvement by 
> predicitions (see
> > bib-reference attached).
> > 
> > Song et al. ([11] in our references) made empirical studies on
> > predicitions including the campus geometry, statistical correlation
> > analysis of user date ... and arrived at dissapointing 72 %.
> > 
> > It's a nice vision - but sometimes real-world isn't as nice ;)
> > 
> > Best regards,
> > 
> > thomas
> > 
> > Christian Vogt wrote:
> > 
> >> I would like to call your attention on work that we have 
> done on IPv6
> >> handoff procedures:
> >>
> >>   "A Comprehensive Delay Analysis
> >>    for Reactive and Proactive Handoffs
> >>    with Mobile IPv6 Route Optimization"
> >>
> >> 
> http://doc.tm.uka.de/2006/vogt-2006-delay-analysis-for-reactiv
> e-and-proactive-handoffs.pdf
> >>
> >>
> >>   Abstract:  Optimizations to reduce handoff delays
> >>   inherent in Mobile IPv6 Route Optimization as well
> >>   as IPv6 router discovery, address configuration,
> >>   and movement detection have so far been mostly
> >>   considered on an individual basis.  This document
> >>   evaluates three integrated solutions for improved
> >>   handoff experience in surroundings with different
> >>   preconditions:  reactive handoffs with unmodified
> >>   routers, reactive handoffs with router support, and
> >>   movement anticipation and proactive handoff manage-
> >>   ment.
> >>
> >> Your feedback will be welcome!
> >>
> >> Regards,
> >> - Christian
> >>
> > 
> > 
> --------------------------------------------------------------
> ----------
> > 
> > @article{sw-pvrah-05,
> >   author = {Thomas C. Schmidt and Matthias W{\"a}hlisch},
> >   title = {{P}redictive versus {R}eactive -- {A}nalysis of 
> {H}andover {P}erformance and {I}ts {I}mplications on {IP}v6 
> and {M}ulticast {M}obility},
> >   journal = {Telecommunication Systems},
> >   volume = {30},
> >   number = {1--3},
> >   pages = {123--142},
> >   month = {November},
> >   year = {2005},
> >   publisher = {Springer},
> >   address = {Berlin Heidelberg},
> >   url = {http://dx.doi.org/10.1007/s11235-005-4321-4},
> >   abstract = {Handovers in mobile packet networks commonly 
> produce packet loss, delay and jitter, thereby significantly 
> degrading network performance. Mobile IPv6 handover 
> performance is strongly topology dependent and results in 
> inferior service quality in wide area scenarios. To approach 
> seamless mobility in IPv6 networks predictive, reactive and 
> proxy schemes have been proposed for improvement. In this 
> article we analyse and compare handover performance and 
> frequencies for the corresponding protocols, as they are an 
> immediate measure on service quality. Using analytical 
> methods as well as stochastic simulations, we calculate the 
> performance decreases originating from different handover 
> schemes, the expected number of handovers as functions of 
> mobility and proxy ratios, as well as the mean correctness of 
> predictions. In detail we treat the more delicate case of 
> these rates in mobile multicast communication.
> >  It is obtained that performance benefits, expected from 
> simple analysis of predictive schemes, do not hold in 
> practice. Reactive and predictive handovers rather admit 
> comparable performance. Hierarchical proxy environments -- 
> foremost in regions of high mobility -- can significantly 
> reduce the processing of inter--network changes. Reliability 
> of handover predictions is found on average at about 50 \%.},
> >   theme = {mipv6|mmcast},
> >   file = 
> {http://www.informatik.haw-hamburg.de/~schmidt/papers/telesys05.pdf}
> > }
> 
> 
> 
> 
> 
> _______________________________________________
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Christian Vogt <[email-masked]>
Date: Mon, 16 Jan 2006 08:10:40 +0100

Mohammed,

it's very good that you point to related work that you did.

Still, I refer to the discussion that Thomas and I had yesterday on the 
differences between network-assisted mobility (which is what you have 
experimented with) and end-to-end mobility (which is what our analysis 
is about).

To be brief:  Our work is truly orthogonal.

Further, I should mention that our analysis assumes the use of DNA 
mechanisms (DNA protocol, CPL, FastRA) to eliminate router-discovery and 
movement-detection delays during reactive handoffs, Optimistic DAD to 
get rid of the address-configuration latency, and Media Independent 
Handover Services (including Information Services) to facilitate 
proactive handoffs.

Hope this makes things more clear.

Regards,
- Christian

-- 
Christian Vogt, Institute of Telematics, Universitaet Karlsruhe (TH)
www.tm.uka.de/~chvogt/pubkey/