Subject: RE: [Mipshop] Gauging interest in official WG adoption ofinternetdrafts

From: "Narayanan, Vidya" <[email-masked]>
Date: Mon, 27 Mar 2006 08:09:50 -0800

Hi Junghoon,
As Julien, Lakshminath and I pointed out, the issue Sam has is with
using an EAP-derived AMSK for application keying. The AAA-based key
derivation itself is well-aligned with RFC4004 and there is no issue
with this. We will be removing the appendix on HMK derivation - it was
always planned to be a separate I-D and that needs to wait until the
AMSK dust settles down. 

Thanks,
Vidya 

> -----Original Message-----
> From: Julien Bournelle [mailto:[email-masked]] 
> Sent: Monday, March 27, 2006 4:47 AM
> To: Junghoon Jee
> Cc: Narayanan, Vidya; 'Yoshihiro Ohba'; Dondeti, Lakshminath; 
> [email-masked]
> Subject: Re: [Mipshop] Gauging interest in official WG 
> adoption ofinternetdrafts
> 
> Hi all,
> 
> On Mon, Mar 27, 2006 at 04:55:37PM +0900, Junghoon Jee wrote:
> > Hi Vidya and Yoshihiro,
> > 
> > > If more people actually think there is an issue here, I'd 
> be happy 
> > > to run it by Sam and Russ. However, I strongly believe that this 
> > > step is not required at this time, since we have precedence with 
> > > approved standards track documents along very similar lines.
> > 
> > I have the same issue with Yoshihiro from my attendance to 
> the HOAKEY 
> > BoF.
> > I also feel the need for getting Sam's opinion here.
> 
>  I'd like to get the exact issue on this document. Is it the 
> HMK  derivation based on AMSK (describe in appendix and not 
> require) or the  mechanism based on AAA to get the shared key 
> between MN and AR ?
> 
>  thanks,
> 
>  Julien B.
> 
> > 
> > Thanks,
> > -Junghoon
> > 
> > 
> > > Thanks,
> > > Vidya
> > > 
> > > > -----Original Message-----
> > > > From: Yoshihiro Ohba [mailto:[email-masked]]
> > > > Sent: Saturday, March 25, 2006 6:22 PM
> > > > To: Dondeti, Lakshminath
> > > > Cc: [email-masked]
> > > > Subject: Re: [Mipshop] Gauging interest in official WG 
> adoption of
> > 
> > > > internetdrafts
> > > > 
> > > > As far as I understand, Sam's concern is not only on 
> application 
> > > > keying using AMSK but also AAA-assisted application keying
> > > in general.
> > > > So I am not sure if your suggested remedy really addresses the 
> > > > concern.  I'd suggest asking Sam's opinon before moving forward.
> > > > 
> > > > Best regards,
> > > > Yoshihiro Ohba
> > > > 
> > > > On Sat, Mar 25, 2006 at 05:36:46PM -0800, Lakshminath Dondeti
> > wrote:
> > > > > Disclaimer: I work with one of the authors (Vidya) of the 
> > > > > handover-keys-aaa I-D, although didn't contribute to the
> > > > draft in anyway.
> > > > > 
> > > > > I just read the parts of the I-D that seem to be
> > > > contentious and note
> > > > > that the reference to AMSKs is merely an example and the
> > > HMK can be
> > > > > established through other means, say by preprovisioning.
> > > > > 
> > > > > That said, I think it is best to remove Appendix A (I am not
> > sure
> > > > > about A.1, that probably should stay and resolved 
> later) as it 
> > > > > reproduces a key hierarchy and key derivation process
> > > that is still
> > > > > under active discussion.
> > > > > 
> > > > > regards,
> > > > > Lakshminath
> > > > > 
> > > > > At 04:25 PM 3/25/2006, Yoshihiro Ohba wrote:
> > > > > >I have a reservation on
> > > > draft-vidya-mipshop-handover-keys-aaa-01.txt.
> > > > > >
> > > > > >The draft describes a AAA-assisted key management 
> protocol to 
> > > > > >generate handover keys for protecting signaling between MN
> > > > and AR.  I
> > > > > >am viewing the proposal as an application keying for 
> FMIPv6 and
> > 
> > > > > >possibly other protocols.  However, in the IETF65 hoakey
> > > BOF, Sam
> > > > > >Hartman, a Security AD, raised concern on application
> > > > keying.  As a
> > > > > >consequence, the hoakey BOF chairs made a decision 
> to exclude 
> > > > > >application keying from the BOF charter, expecting
> > > > application keying
> > > > > >to be discussed in a separate BOF.
> > > > > >
> > > > > >Thus, it might be wiser to hold this draft until there
> > > is a clear
> > > > > >consensus on how to deal with application keying in the IETF.
> > > > > >
> > > > > >Best regards,
> > > > > >Yoshihiro Ohba
> > > > > >
> > > > > >
> > > > > >On Tue, Mar 21, 2006 at 11:49:36PM -0800, gabriel
> > > montenegro wrote:
> > > > > >> Folks,
> > > > > >>
> > > > > >> In today's meeting we talked about 4 potential items up for
> > > > > >adoption as official working
> > > > > >> groups. Talking with folks after the meeting, we've decided
> > to
> > > > > >add two more to the list
> > > > > >> of items we'll ask the WG whether we should adopt. This is
> > the
> > > > > >follow-up email to today's
> > > > > >> discussion, to make sure we ask this on the mailing list.
> > > > > >>
> > > > > >> So the question to the WG is: Should we adopt the following
> > > > > >documents as official WG
> > > > > >> items (based on the individual drafts as noted below)?:
> > > > > >>
> > > > > >> 1. draft-ietf-mipshop-fmipv6-rev-XX.txt
> > > > > >> based on draft-koodli-mipshop-rfc4068bis-00.txt
> > > > > >>
> > > > > >> 2. draft-ietf-mipshop-handover-keys-aaa-XX.txt
> > > > > >> based on  draft-vidya-mipshop-handover-keys-aaa-01.txt
> > > > > >>
> > > > > >> 3. draft-ietf-mipshop-handover-key-send-XX.txt
> > > > > >> based on draft-kempf-mobopts-handover-key-01.txt (currently
> > > > > >> expired)
> > > > > >>
> > > > > >> 4. draft-ietf-mipshop-fh80216e-XX.txt
> > > > > >> based on draft-jang-mipshop-fh80216e-02.txt
> > > > > >>
> > > > > >> 5. draft-ietf-mipshop-3gfh-XX.txt based on 
> > > > > >> draft-yokota-mipshop-3gfh-02.txt
> > > > > >>
> > > > > >> 6. draft-ietf-mipshop-cga-cba-XX.txt based on 
> > > > > >> draft-arkko-mipshop-cga-cba-03.txt
> > > > > >>
> > > > > >> Please send comments one way or another through April 4,
> > 2006.
> > > > > >>
> > > > > >> Thanks,
> > > > > >>
> > > > > >> chairs
> > > > > >>
> > > > > >>
> > > > > >> __________________________________________________
> > > > > >> Do You Yahoo!?
> > > > > >> Tired of spam?  Yahoo! Mail has the best spam
> > > protection around
> > > > > >> http://mail.yahoo.com
> > > > > >>
> > > > > >> _______________________________________________
> > > > > >> Mipshop mailing list
> > > > > >> [email-masked]
> > > > > >> https://www1.ietf.org/mailman/listinfo/mipshop
> > > > > >>
> > > > > >
> > > > > >_______________________________________________
> > > > > >Mipshop mailing list
> > > > > >[email-masked]
> > > > > >https://www1.ietf.org/mailman/listinfo/mipshop
> > > > > 
> > > > > 
> > > > 
> > > > _______________________________________________
> > > > Mipshop mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/mipshop
> > > > 
> > > 
> > > _______________________________________________
> > > Mipshop mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/mipshop
> > 
> > 
> > _______________________________________________
> > Mipshop mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mipshop
> 
> --
> julien.bournelle at int-evry.fr
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Mon, 27 Mar 2006 09:53:55 -0800

Since the bulk of the draft describes a protocol for AAA-based handover key 
provisioning, I don't think there should be any linkage with the EAP AMSK 
issue if an appendectomy is performed. However, that does not mean that the 
SEC ADs won't have an issue with the draft when the WG requests that it be 
published. If the method for deriving the key is left unspecified, or a 
default method of static configuration is suggested, it may not be 
acceptable. Therefore, I think it would be worthwhile asking the SEC ADs 
about the draft.

            jak

----- Original Message ----- 
From: "Narayanan, Vidya" <[email-masked]>
To: "Julien Bournelle" <[email-masked]>; "Junghoon Jee" 
<[email-masked]>
Cc: "Dondeti, Lakshminath" <[email-masked]>; <[email-masked]>
Sent: Monday, March 27, 2006 8:09 AM
Subject: RE: [Mipshop] Gauging interest in official WG 
adoptionofinternetdrafts

Hi Junghoon,

Thanks,
Vidya