Subject: RE: [Mipshop] RE: I-D ACTION:draft-rahman-mipshop-mih-transport-00.txt

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 15 Jun 2006 10:48:46 -0400

Hi Tom,

Thank you for your comments.  Let me first try to answer your question
#2.

=================================
QUESTION:
As MN and MIH proxy runs layer 2 protocol, there may need a EAP session 
between them.
Do you think so?

ANSWER:
Our thinking was that between the MN and MIH proxy you would run
whatever the normal link layer security protocol was.  For example, for
an 802.11 (WLAN) you would run the 802.11i security protocols (which of
course includes EAP session).  We will clarify in the next update of the
draft.
=================================

As for your question #1, here is our feedback

=================================
QUESTION:
In section 6.5, you defined a MIH proxy method.
I think there may need a security association between MIH proxy and MM.

ANSWER:
We agree.  It should actually be also the same security mechanism that
is also used between the MN and MM when there is no MIH proxy.  We
assumed that it will be an IPSec based authentication and encryption.
Do you agree?
=================================

Please write back with your feedback.

Akbar

-----Original Message-----
From: Tom Wan [mailto:[email-masked]] 
Sent: Thursday, June 15, 2006 4:53 AM
To: Rahman, Akbar; [email-masked]
Subject: Re: [Mipshop] RE: I-D
ACTION:draft-rahman-mipshop-mih-transport-00.txt

Hi, Rahman:
I read your draft.I have two questions:

1 In section 6.5, you defined a MIH proxy method.
I think there may need a security association between MIH proxy and MM.

2 As MN and MIH proxy runs layer 2 protocol, there may need a EAP
session 
between them.
Do you think so?

BR
Tom

----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 14, 2006 4:51 AM
Subject: [Mipshop] RE: I-D
ACTION:draft-rahman-mipshop-mih-transport-00.txt

FYI: As I noticed that the MIPSHOP group had not been copied.  Any
comments would be much appreciated.

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, June 13, 2006 3:50 PM
To: [email-masked]
Subject: I-D ACTION:draft-rahman-mipshop-mih-transport-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

Title : Transport of Media Independent Handover
Messages Over IP
Author(s) : A. Rahman, et al.
Filename : draft-rahman-mipshop-mih-transport-00.txt
Pages : 20
Date : 2006-6-13

This document describes a mechanism for using UDP/IP for the
transport of Media Independent Handover (MIH) messages between
network nodes. MIH messages carry technology specific link layer
information and commands that can be used to optimize handover
procedures across different access technologies such as cellular and
WLAN. MIH will complement Layer 3 mobility protocols such as Mobile
IP.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-rahman-mipshop-mih-transport-0
0.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of
the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the
username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
"get draft-rahman-mipshop-mih-transport-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
[email-masked].
In the body type:
"FILE
/internet-drafts/draft-rahman-mipshop-mih-transport-00.txt".

NOTE: The mail server at ietf.org can return the document in
MIME-encoded form by using the "mpack" utility.  To use this
feature, insert the command "ENCODING mime" before the "FILE"
command.  To decode the response(s), you will need "munpack" or
a MIME-compliant mail reader.  Different MIME-compliant mail
readers
exhibit different behavior, especially when dealing with
"multipart" MIME messages (i.e. documents which have been split
up into multiple messages), so check your local documentation on
how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

Akbar Rahman
Principal Engineer, Systems
InterDigital Canada Ltee
1000 Sherbrooke Street West
10th Floor
Montreal, Quebec H3A 3G4
Tel.: +1 514.904.6270
Fax: +1 514.904.6344
Email: [email-masked]
http://www.InterDigital.com

 This e-mail is intended only for the use of the individual or entity to

which it is addressed, and may contain information that is privileged, 
confidential and/or otherwise protected from disclosure to anyone other
than 
its intended recipient.  Unintended transmission shall not constitute
waiver 
of any privilege or confidentiality obligation. If you received this 
communication in error, please do not review, copy or distribute it,
notify 
me immediately by email, and delete the original message and any 
attachments. Unless expressly stated in this e-mail, nothing in this
message 
or any attachment should be construed as a digital or electronic
signature.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Tom Wan <[email-masked]>
Date: Fri, 16 Jun 2006 09:05:17 +0800

Hi Akbar:

About the security between MN and MM, I think that maybe TLS is more proper, 
because you use UDP to transport MIH signaling.
How about your opinion?I am not familar with TLS, so maybe my opinion is not 
proper.

Tom
----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: "Tom Wan" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, June 15, 2006 10:48 PM
Subject: RE: [Mipshop] RE: I-D 

Hi Tom,

ANSWER:

ANSWER:

Akbar

-----Original Message-----
From: Tom Wan [mailto:[email-masked]]
Sent: Thursday, June 15, 2006 4:53 AM
To: Rahman, Akbar; [email-masked]
Subject: Re: [Mipshop] RE: I-D

Hi, Rahman:

BR
Tom

----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 14, 2006 4:51 AM
Subject: [Mipshop] RE: I-D

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, June 13, 2006 3:50 PM
To: [email-masked]
Subject: I-D ACTION:draft-rahman-mipshop-mih-transport-00.txt

Send a message to:
[email-masked].
In the body type:
"FILE

Akbar Rahman