Subject: RE: [Mipshop] Review of draft-vidya-handover-keys-aaa-02.txt

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 6 Jun 2006 11:24:25 -0700

Hi James,
Sounds good. I'll incorporate your comments and submit a revised draft.
Hopefully, that will provide the clarity you are looking for. 

Thanks,
Vidya 

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: Tuesday, June 06, 2006 8:34 AM
> To: Narayanan, Vidya; [email-masked]
> Subject: Re: [Mipshop] Review of draft-vidya-handover-keys-aaa-02.txt
> 
> > I am not sure why you think implementation before 
> standardization may 
> > be needed here. Perhaps if we clarfied your complexity 
> comment, this 
> > won't be your feeling? In this protocol itself, I don't see what an 
> > implementation can buy - the protocol should be fully analyzable on 
> > paper. If you feel there are parts of the protocol that aren't 
> > allowing this, then those must be clarified. I don't think 
> we need to 
> > delay the standardization process for implementation here.
> >
> 
> jak>> So you are claiming that the protocol can operate with no AAA 
> jak>> network
> access protocol at all, like in a hotspot situation? If so, 
> I'd like to see that claiim written up and put into the document.
> 
> Typically, implementation and protocol analysis serve 
> different purposes
> - if we think that the protocol cannot be analyzed, that is a problem.
> I'm not saying that implementation is not helpful - but, if 
> we agree that we don't need to delay standardization on 
> account of implementation, that would be good.
> 
> jak>> I'm recommending that someone do an implementation. That's all. 
> jak>> I'd
> like to have some confidence that the protocol actually 
> works, and the only way I know to do that is to actually have 
> an implementation that works. How that impacts the 
> standardization effort is up to the WG chairs and their 
> management of the process. As I said in the original post, 
> there is no requirement that the WG show an implementation to 
> the IESG for implementation of IETF protocols except for 
> routing protocols, though the release form that the WG chairs 
> fill out and send to the IESG prior to submitting the draft 
> does have a question about implementation.
> 
> > jak>> So what is the key bound to so that the AR can reattach
> > it if the
> > jak>> MN
> > should want to reestablish a binding with another CoA? The MN 
> > identity, right? Which is the NAI? This needs to be 
> explained in more 
> > detail. At least, it wasn't clear to me how this would work.
> >
> 
> Yes, it is bound to the NAI - the NAI is always carried in 
> the HKReq message and hence, the CoA can be bound when the 
> subsequent HKReq is sent. We will clarify this better.
> 
> jak>> OK. You might consider phrasing it as a "conceptual 
> data structure".
> 
>             jak 
> 
> 
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: gabriel montenegro <[email-masked]>
Date: Tue, 6 Jun 2006 11:28:59 -0700 (PDT)

Vidya,

Please share with the group the secdir review you got (perhaps I just missed it?).

-gabriel

----- Original Message ----
From: "Narayanan, Vidya" <[email-masked]>
To: James Kempf <[email-masked]>; [email-masked]
Sent: Tuesday, June 6, 2006 11:24:25 AM
Subject: RE: [Mipshop] Review of draft-vidya-handover-keys-aaa-02.txt

Hi James,

Thanks,
Vidya

---

From: "Alper Yegin" <[email-masked]>
Date: Fri, 16 Jun 2006 14:49:08 -0700

IETF security community always had issues with leveraging the AAA
infrastructure as a trusted third party, and designing authentication and
key agreement protocols around it, especially full blown brand new solutions
from scratch -- exactly the way this I-D is proposing. Has anything changed
there, or have we not checked with that community yet?

Alper

________________________________________
From: gabriel montenegro [mailto:[email-masked]] 
Sent: Tuesday, June 06, 2006 11:29 AM
To: Narayanan, Vidya; James Kempf; [email-masked]
Subject: Re: [Mipshop] Review of draft-vidya-handover-keys-aaa-02.txt

Vidya,

Please share with the group the secdir review you got (perhaps I just missed
it?).

-gabriel

----- Original Message ----
From: "Narayanan, Vidya" <[email-masked]>
To: James Kempf <[email-masked]>; [email-masked]
Sent: Tuesday, June 6, 2006 11:24:25 AM
Subject: RE: [Mipshop] Review of draft-vidya-handover-keys-aaa-02.txt
Hi James,

Thanks,
Vidya