Subject: RE: DH exchange (Re: [Mipshop] Review of draft-haddad-mipship-hmipv6-security-04)

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 31 Jul 2006 14:50:26 -0700

> -----Original Message-----
> From: Wassim Haddad [mailto:[email-masked]] 
> Sent: Monday, July 31, 2006 2:46 PM
> To: Vijay Devarapalli
> Cc: Suresh Krishnan; [email-masked]; Lakshminath Dondeti
> Subject: Re: DH exchange (Re: [Mipshop] Review of 
> draft-haddad-mipship-hmipv6-security-04)
> 
> On Mon, 31 Jul 2006, Vijay Devarapalli wrote:
> 
> > Wassim Haddad wrote:
> > > On Mon, 31 Jul 2006, Vijay Devarapalli wrote:
> > >
> > >> Wassim Haddad wrote:
> > >>> On Mon, 31 Jul 2006, Vijay Devarapalli wrote:
> > >>>
> > >>>> Suresh Krishnan wrote:
> > >>>>>> MN->MAP:   X = g^a, LCoA, RCoA
> > >>>>>> MAP->MN:   Y = g^b, h(Ks)
> > >>>>>>
> > >>>>>> Ksm = g^ab
> > >>>>>>
> > >>>>>> Attack:
> > >>>>>>
> > >>>>>> MN->MAP:             X = g^a, LCoA, RCoA
> > >>>>>> Attacker->MAP:     Z = g^c, LCoA, RCoA
> > >>>>>> MAP->MN :            Y = g^b, h(Ks)
> > >>>>>> Attacker->MN:      W = g^d, h(Ks)
> > >>>>>>
> > >>>>>> MN and Attacker compute Ksm1 = g^ad  (MN thinks the 
> attacker is the MAP)
> > >>>>>> Attacker and MAP compute Ksm2 = g^bc (MAP thinks the 
> attacker is the MN)
> > >>>>> This is the part I where we disagree. For this to be 
> true one of these
> > >>>>> two conditions have to be true.
> > >>>>>
> > >>>>> a) The attacker is an Access Router who can pull 
> packet X and Y off the
> > >>>>> wire. Otherwise the Packet X will reach the MAP and 
> packet Y will reach
> > >>>>> the MN, right?
> > >>>>> b) The attacker is on-path (not a router), manages to 
> see the MNs
> > >>>>> message X going though the wire and somehow creates a 
> new message Z and
> > >>>>> sends it to reach the MAP before X. Likewise it sees 
> message Y, and
> > >>>>> sends message W to reach the MN before Y.
> > >>>>>
> > >>>>> According to me
> > >>>>> a) is very unlikely, and even if it is likely is the 
> same issue as the
> > >>>>> AR compromise.
> > >>>>> b) is impossible.
> > >>>> FWIW, I don't think you can assume b). in general, by 
> assuming a)
> > >>>> and b), you seem to be lowering the bar for designing security
> > >>>> protocols.
> > >>> => can you explain why?
> > >> the assumption b) is about ordering of the packets. Suresh
> > >> claimed that the message Z cannot reach the MAP before X.
> > >> I don't think you can assume this.
> > >
> > > => can you please elaborate more? There is a clear 
> assumption in the draft
> > > about the security between routers in the HMIPv6 tree.
> >
> > the routers just forward packets from whoever it is. what is
> > preventing the message Z from reaching the MAP before message
> > X?
> 
> => Obviously am missing somthing here (am on holiday or supposed to
> be!! so I have not read the previous emails yet). Again the 
> assumption is
> taht all links are secure within the MAP tree. Please explain 
> how under
> this assumption the attack can occur.

see Suresh's email about message X making it before message
X becuase it was sent earlier.

Vijay

> 
> > >>> P.S: this seems to be the beginning of a discussion 
> which may require at
> > >>> some stage a comparaison with the security of the RO 
> mode in MIPv6...
> > >> I guess you want to compare MN-AR-MAP to MN-HA-CN. correct?
> > >> the trust assumed between MN-HA and between MN-AR is different.
> > >> from what I see the mechanisms are different too.
> > >
> > > => I prefer to compare the the existence of a malicious 
> node between the
> > > HA and the CN able to read the HoT message and to send 
> its own CoTI message.
> >
> > the security model for the return routability mechanism is
> > explained in RFC 4225. nobody claimed the return routability
> > mechanism is perfect. it is susceptible to attackers on the
> > HA-CN path. you shouldn't use that to justify other work.
> 
> => have nothing to add here!
> 
> Wassim H.
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 31 Jul 2006 18:17:15 -0400

Hi Vijay,

Vijay Devarapalli wrote:
<too much quoted text>
> X becuase it was sent earlier.

Not exactly. Of course I understand messages may be delivered out of 
order. But my email option b) was about an attacker who is on path, 
reads X off the wire, modifies it and creates X' and then sends out X' 
to reach the MAP before X AND ALSO reads the return message from the MAP 
Y, modifies it and creates Y' sends it out to the MN to reach before Y. 
This cannot happen due to regular routing irregularities. Do we agree?

> Vijay

Cheers
Suresh

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 31 Jul 2006 15:29:24 -0700

> This cannot happen due to regular routing irregularities. Do we agree?

nope. this can happen because of the "routing irregularities".

Vijay