Subject: RE: [Mipshop] GIST for 802.21

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 1 Aug 2006 14:32:20 -0400

Hi James,

The requirement for 802.21 is that you should be able to carry 802.21
frames between two end points on the Internet over some new/existing IP
protocol.  What I am trying to understand with the GIST proposal is
whether GIST is an appropriate transport for 802.21 or not.

As I mentioned previously, what confuses me is that the latest GIST
draft specifically "excludes end-to-end higher-layer application
signaling".  The point of confusion is that transport of 802.21 messages
can actually be regarded as end to end higher layer application
signaling!

Akbar

-----Original Message-----
From: James Kempf [mailto:[email-masked]] 
Sent: Monday, July 31, 2006 5:53 PM
To: Rahman, Akbar; [email-masked]
Cc: [email-masked]
Subject: Re: [Mipshop] GIST for 802.21

If the signaling between the end host and network is done using a L2 
protocol, like 802.1x, then GIST could be used between the local network
and 
the backend server, kind of like Radius is for AAA.

     jak

----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 31, 2006 11:26 AM
Subject: RE: [Mipshop] GIST for 802.21

Hi John,

I had some good conversations with Robert and am getting a better
understanding of GIST.  I still have one fundamental question though.
The latest GIST draft (draft-ietf-nsis-ntlp-10) describes GIST as
follows:

 - This specification concentrates mainly on path-coupled signaling,
   which involves network elements which are located on the path taken
   by a particular data flow, possibly including but not limited to the
   flow endpoints.  Indeed, there are almost always more than two
   participants in a path-coupled signaling session, although there is
   no need for every node on the path to participate.  Path-coupled
   signaling thus excludes end-to-end higher-layer application
   signaling.

 - In the context of path-coupled signaling, examples of state
   management include network resource reservation, firewall
   configuration, and state used in active networking; examples of state
   monitoring are the discovery of instantaneous path properties, such
   as available bandwidth or cumulative queuing delay.  Each of these
   different uses of signaling is referred to as a signaling
   application.

What confuses me is that MIH (802.21) is an end-to-end higher layer
application protocol.  So from the above definition it seems that it is
specifically excluded from using GIST (i.e. read the last sentence of
the first paragraph).  Any insight that you could shed on this issue
would be very helpful to me.

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 11, 2006 11:17 PM
To: [email-masked]
Subject: [Mipshop] GIST for 802.21

Hi all,

As chair of NSIS, I'd be happy to help with any discussion of how GIST
could be used with 802.21.  As Robert ran through in the meeting today,
there are 5+ independent implementations of GIST, including several open
source implementations (I can send links, if there is interest) & we
have had 2 interop events.

We have been working on NAT traversal issues, and are looking at
documenting these issues (currently there is an individual submission on
this issue), as we have an Applicability Statement on use of NSIS
protocols in a mobile environment (multihoming is also covered in the
document, to some extent).

My guess is that MIPSHOP would be the home of this work (irrespective of
what transport protocol is used) but I'm happy provide additional
information on what we have been doing, as GIST / NSIS may not have been
on everyone's radar.

thanks,
John (NSIS chair)

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

Akbar Rahman
Principal Engineer, Systems
InterDigital Canada Ltee
1000 Sherbrooke Street West
10th Floor
Montreal, Quebec H3A 3G4
Tel.: +1 514.904.6270
Fax: +1 514.904.6344
Email: [email-masked]
http://www.InterDigital.com

 This e-mail is intended only for the use of the individual or entity to

which it is addressed, and may contain information that is privileged, 
confidential and/or otherwise protected from disclosure to anyone other
than 
its intended recipient.  Unintended transmission shall not constitute
waiver 
of any privilege or confidentiality obligation. If you received this 
communication in error, please do not review, copy or distribute it,
notify 
me immediately by email, and delete the original message and any 
attachments. Unless expressly stated in this e-mail, nothing in this
message 
or any attachment should be construed as a digital or electronic
signature.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 1 Aug 2006 11:53:28 -0700 (PDT)

Hi Akbar,
  According to:
http://user.informatik.uni-goettingen.de/~nsis/internet-drafts/draft-fu-cxtp-gist-00.txt
GIST can be used between any two entities if an MA (GIST messaging association) is established. Normally an MA is established after a path-coupled discovery procedure to determine the signaling node but it could also be established by static configuration or by other means.
  Hope this helps.

--behcet

----- Original Message ----
From: "Rahman, Akbar" <[email-masked]>
To: James Kempf <[email-masked]>; [email-masked]
Cc: [email-masked]
Sent: Tuesday, August 1, 2006 1:32:20 PM
Subject: RE: [Mipshop] GIST for 802.21

Hi James,

Akbar

-----Original Message-----
From: James Kempf [mailto:[email-masked]] 
Sent: Monday, July 31, 2006 5:53 PM
To: Rahman, Akbar; [email-masked]
Cc: [email-masked]
Subject: Re: [Mipshop] GIST for 802.21

     jak

----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 31, 2006 11:26 AM
Subject: RE: [Mipshop] GIST for 802.21

Hi John,

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 11, 2006 11:17 PM
To: [email-masked]
Subject: [Mipshop] GIST for 802.21

Hi all,

thanks,
John (NSIS chair)

Akbar Rahman

---

From: "James Kempf" <[email-masked]>
Date: Tue, 1 Aug 2006 16:06:59 -0700

There are some applications of 802.21 that need to occur before the terminal 
has an IP address. These would function as I described.

As for your point, I don't think it excludes host to network signaling. That 
would seem to preclude having the host signal to firewalls and such, which I 
think is in scope, or was last time I checked.

John, can you enlighten us?

          jak

----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: "James Kempf" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 01, 2006 11:32 AM
Subject: RE: [Mipshop] GIST for 802.21

Hi James,

Akbar

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Monday, July 31, 2006 5:53 PM
To: Rahman, Akbar; [email-masked]
Cc: [email-masked]
Subject: Re: [Mipshop] GIST for 802.21

     jak

----- Original Message ----- 
From: "Rahman, Akbar" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 31, 2006 11:26 AM
Subject: RE: [Mipshop] GIST for 802.21

Hi John,

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 11, 2006 11:17 PM
To: [email-masked]
Subject: [Mipshop] GIST for 802.21

Hi all,

thanks,
John (NSIS chair)

Akbar Rahman

---

From: <[email-masked]>
Date: Tue, 1 Aug 2006 16:05:43 -0700

Hi Akbar,

Perhaps there is no real issue here. If there is such an exclusion in
GIST it is better to discuss what the exclusion is tring to achieve. 

The MIH payload is not generated by a higher layer. Think of it as being
generated by a sublayer of L3, or by the MAC, or by management.

Best Regards,
Michael

-----Original Message-----
From: ext Rahman, Akbar [mailto:[email-masked]] 
Sent: Tuesday, August 01, 2006 11:32 AM
To: James Kempf; Loughney John (Nokia-NRC/Helsinki)
Cc: [email-masked]
Subject: RE: [Mipshop] GIST for 802.21

Hi James,

Akbar

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Monday, July 31, 2006 5:53 PM
To: Rahman, Akbar; [email-masked]
Cc: [email-masked]
Subject: Re: [Mipshop] GIST for 802.21

If the signaling between the end host and network is done using a L2
protocol, like 802.1x, then GIST could be used between the local network
and the backend server, kind of like Radius is for AAA.

     jak

----- Original Message -----
From: "Rahman, Akbar" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 31, 2006 11:26 AM
Subject: RE: [Mipshop] GIST for 802.21

Hi John,

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 11, 2006 11:17 PM
To: [email-masked]
Subject: [Mipshop] GIST for 802.21

Hi all,

thanks,
John (NSIS chair)

Akbar Rahman

---

From: <[email-masked]>
Date: Wed, 2 Aug 2006 07:42:08 +0300

BTW - if we define the signaling for MIH as between the MN and MIH, then
this is end-to-end, as MIH signaling is not MN <-> MN, correct?  

John 

>From: ext James Kempf [mailto:[email-masked]] 
>Sent: 02 August, 2006 02:07
>To: Rahman, Akbar; Loughney John (Nokia-NRC/Helsinki)
>Cc: [email-masked]
>There are some applications of 802.21 that need to occur 
>before the terminal has an IP address. These would function as 
>I described.
>
>As for your point, I don't think it excludes host to network 
>signaling. That would seem to preclude having the host signal 
>to firewalls and such, which I think is in scope, or was last 
>time I checked.
>

---

From: <[email-masked]>
Date: Wed, 2 Aug 2006 08:27:07 +0300

Hi all, 

Quick comment on this section of the GIST draft, as I think there is a
misunderstanding here:

>   signaling thus excludes end-to-end higher-layer application

For MIH, you should interpret this to mean that there is a MIH signaling
application that covers end-to-end application signaling, while GIST
provides the transport.

In terms of MIH, I think that the MIH signaling could/should run
something
like this:

MN <-> AP/AR <-> MIH entity

GIST could be run over the MN-AR and between the AR-MIH; however, there
are
cases that James has brought-up where the AR would be acting like a
proxy,
so GIST could be run between the AR-MIH.  The MIH signaling would be run
between the MN-MIH, if I understand things correctly.

In summary, the above paragraph in GIST is just saying that GIST does
transport,
and some other protocol above it does the specific application
signaling,
which, in the 802.21 case would be the MIH signaling.

Does this clear things up?

John

---

From: <[email-masked]>
Date: Wed, 2 Aug 2006 08:28:47 +0300

James,

>If the signaling between the end host and network is done 
>using a L2 protocol, like 802.1x, then GIST could be used 
>between the local network and the backend server, kind of like 
>Radius is for AAA.

This is correct. In this case the AR or NAS is acting like a proxy,
essentially.  However, I think that GIST could be run from the end-host
as well, but there are probably different deployment considerations.

John

---

From: "Junghoon Jee" <[email-masked]>
Date: Wed, 2 Aug 2006 15:34:48 +0900

Hello John,
Please find inline comments. 

> Sent: Wednesday, August 02, 2006 2:27 PM
> To: [email-masked]; 
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Quick comment on this section of the GIST draft, as I think 
> there is a misunderstanding here:
> 
> GIST says:
> 
> For MIH, you should interpret this to mean that there is a 
> MIH signaling application that covers end-to-end application 
> signaling, while GIST provides the transport.
> 
> In terms of MIH, I think that the MIH signaling could/should 
> run something like this:
> 

The IEEE 802.21/D01.00 spec. defines the MIH communication model. 
Here is a short cut which might help.

MN (MIH) <---R1----> Serving PoS (MIH) <-----R4-----> Non-PoS (MIH)

MIH function in any network entity becomes a MIH PoS (Point of
Service), when it communicates directly 
with a MN which also has MIH function. Serving PoS can be regarded as
an AP or AR. 
Because we are discussing about the higher layer transport for the MIH
protocol, in many cases, 
an AR acts the role of the Serving PoS by having the MIH function.

Back to the original question about the capability of GIST regarding
end-to-end higher-layer application signaling:
In general, from my understanding, the end-to-end implies the logical
end-to-end communication among user's equipments.
However, from the typical MIH communication model, the communication
among peer MIH functional entities always happen between mobile
terminal and network entity
or among network entities.
Therefore, I can hardly grasp the validity of the question itself.

> GIST could be run over the MN-AR and between the AR-MIH; 

>From the explanation about the GIST by John, I can not find any clear
issue/obstacle about the possibility in utilizing the GIST for the
transporting the MIH protocol
under considering the MIH communication model. 
I might give more detailed feedback about the considerable points in
adopting GIST for MIH transport after further exploring the GIST
world.

Best Regards,
-Junghoon

> however, there are cases that James has brought-up where the 
> AR would be acting like a proxy, so GIST could be run between 
> the AR-MIH.  The MIH signaling would be run between the 
> MN-MIH, if I understand things correctly.

> In summary, the above paragraph in GIST is just saying that 
> GIST does transport, and some other protocol above it does 
> the specific application signaling, which, in the 802.21 case 
> would be the MIH signaling.
>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 2 Aug 2006 04:56:35 -0700

Yes, I think GIST is an appropriate choice for transport.

        jak

----- Original Message ----- 
From: "Junghoon Jee" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 01, 2006 11:34 PM
Subject: RE: [Mipshop] GIST for 802.21

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 02 Aug 2006 14:57:52 -0400

> between the MN-MIH, if I understand things correctly.

This 'proxy' model corresponds to the model described in Section 4.2
of draft-hepworth-mipshop-mih-problem-statement-02.txt.  Just to
clarify that this specific model is outside the scope of 802.21 (the
term 'proxy' is somehow used in 802.21/D01 but it will be removed in
the next version).  IETF can add support for this model given that all
802.21 requirements are met (perhaps more consideration on security
requirements might be needed).

Yoshihiro Ohba

---

From: <[email-masked]>
Date: Thu, 3 Aug 2006 08:43:46 +0300

Junghoon,

>From the explanation about the GIST by John, I can not find 
>any clear issue/obstacle about the possibility in utilizing 
>the GIST for the transporting the MIH protocol under 
>considering the MIH communication model. 
>I might give more detailed feedback about the considerable 
>points in adopting GIST for MIH transport after further 
>exploring the GIST world.

Great - let us know.  Also, as an FYI - GIST is in IETF last call,
if anyone wants to send comments, please do so. Either post them
to the NSIS list or send them to Robert / myself.

thanks,
John

---

From: "Alper Yegin" <[email-masked]>
Date: Thu, 3 Aug 2006 23:10:59 +0300

Question: which one(s) of the MIH protocols are we considering GIST for?
(ES, CS, IS)?

Alper

> Sent: Thursday, August 03, 2006 8:44 AM
> To: [email-masked]; [email-masked];