Subject: RE: [Mipshop] RE: Concerning mobility services transport PS

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 14 Sep 2006 12:01:34 +0100

james,

I'm not sure exactly what aspect of the draft your are 
concerned about.

In terms of the main body of the document (the first 10
pages of content, say), it's true that it includes a description
of the framework within which a particular problem sits.
So it's not a problem statement for the overall medium
independent handover problem space; it's a problem statement
for how to transport signalling messages for such handovers.

To be specific, as I understand it, the WG is chartered
(in the near term) to work on precisely that subset of the
overall problem. As soon as one writes something that describes
a subset of a larger problem, it gets pretty hard to avoid
architectural aspects in the description. (As a point of
comparison, working out where to put the description of the
architecture within which netlmm sits has been similarly
problematic.)

Is this just a question of being clearer about the scope/goals
of the document?

In terms of the appendices, it's true that there is a fair
amount of .21-related material in there. But other appendices
are not .21-related. AFAIK the intention of the appendices
is to provide a stable reference point for the context within
which the solution is intended to be used; that's partly to
get some kind of organisational buy-in from .21, and partly
also to provide the same information to outsiders, since the
.21 documents are not publicly available (and the .21 requirements
document probably never will be). I don't see the appendices
as actually harmful.

cheers,

Robert H.

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: 13 September 2006 21:03
> To: Faccin, Stefano M; Telemaco Melia; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Mipshop] RE: Concerning mobility services transport PS
> 
> 
> I just started looking at this document, but it really 
> doesn't seem to me to 
> be a problem statement. It is more like an architecture 
> document, combined 
> with a description of 802.21's approach to a solution. I 
> don't really get a 
> sense of "what's the problem and why can't existing protocols 
> handle it"? 
> It's more like "mobile services provide this, here's an 
> architecture for 
> them, and here's what 802.21 is doing to implement that 
> architecture". A 
> real problem statement might be useful, but I question 
> whether it is needed 
> since 802.21 already seems to have decided there's a problem 
> and they are 
> working on the solution that conforms to a particular 
> architecture, which 
> this document describes. Perhaps confining the problem 
> statement to "what 
> problem exactly does 802.21 need solved by IETF" without all 
> the additional 
> material about 802.21 architecture, with reference to their 
> documents where 
> appropriate, would simplify the document. I don't think IETF 
> really needs to 
> duplicate 802.21 architecture and solution documents.
> 
>             jak
> 
> 
> ----- Original Message ----- 
> From: "Faccin, Stefano M" <[email-masked]>
> To: "Telemaco Melia" <[email-masked]>; 
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, September 12, 2006 10:38 AM
> Subject: [Mipshop] RE: Concerning mobility services transport PS
> 
> 
> Dear MIPSHOPers,
> As discussed at the meeting in Montreal, we would like to get this
> document discussed, adopted and into a WG last call ASAP. 
> Therefore, I'd
> like to solicit your input in the next two weeks. Based on 
> the level and
> type of input, we will decide how to proceed.
> Thanks to the authors for getting together as requested to write a PS
> draft, and thanks in advance to all of you for helping in progressing
> this work.
> 
> Stefano
> 
> -----Original Message-----
> From: Telemaco Melia [mailto:[email-masked]]
> Sent: Tuesday, September 12, 2006 10:26 AM
> To: [email-masked]
> Cc: Faccin, Stefano M; [email-masked]
> Subject: Concerning mobility services transport PS
> 
> Hello,
> 
> A new ID on mobility services and MIH related issues is available.
> As long as it is not announced on the mailing list you can find it at
> the following link:
> ftp://195.37.70.21/pub/internet-drafts/draft-melia-mipshop-mob
ility-serv
ices-ps-00.txt

regards,
telemaco

-- 

Telemaco Melia          [email-masked]
Research Staff Member Tel: +49 (0) 6221 4342- 142
Network Laboratories    Fax: +49 (0) 6221 4342- 155
NEC Europe Ltd.         Web: http://netlab.nec.de
Kurfrsten-Anlage 36
D-69115 Heidelberg
Germany

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Thu, 14 Sep 2006 11:10:41 -0700

Robert,

The problem is there is too much material in this document that has nothing 
to do with a simple problem statement. Problem statement documents are 
typically short, rarely over 10 pages. This one runs to 40 pages. That's as 
much as a detailed protocol spec.

If you want to publish this document, then make it an architectural and 
requirements/goals document. If you want to do a problem statement, then 
come up with a 4-8 page document that focusses specifically on the problem 
of running 802.21 signaling over IP transport.

            jak

----- Original Message ----- 
From: "Hancock, Robert" <[email-masked]>
To: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Thursday, September 14, 2006 4:01 AM
Subject: RE: [Mipshop] RE: Concerning mobility services transport PS

james,

cheers,

Robert H.

ility-serv
ices-ps-00.txt

regards,
telemaco

--