Subject: [Mipshop] Comments on drafts of hmip sa and hmipv6 security

From: "DENG, HUI -HCHBJ" <[email-masked]>
Date: Mon, 30 Oct 2006 13:30:08 +0800

Hello, 

After reading two drafts:
1) draft-yegin-hmip-sa-00.txt
2) draft-haddad-mipshop-hmipv6-security-06.txt
I would like to say sth here:

Since both two drafts talk about SA establishment between MN and MAP,
let's go to the definition of Security Association (SA) in RFC 2828.

<snip>
security association
      (I) A relationship established between two or more entities to
      enable them to protect data they exchange. The relationship is
      used to negotiate characteristics of protection mechanisms, but
      does not include the mechanisms themselves. (See: association.)

      (C) A security association describes how entities will use
      security services. The relationship is represented by a set of
      information that is shared between the entities and is agreed upon
      and considered a contract between them.

      (O) IPsec usage: A simplex (uni-directional) logical connection
      created for security purposes and implemented with either AH or
      ESP (but not both). The security services offered by a security
      association depend on the protocol selected, the IPsec mode
      (transport or tunnel), the endpoints, and the election of optional
      services within the protocol. A security association is identified
      by a triple consisting of (a) a destination IP address, (b) a
      protocol (AH or ESP) identifier, and (c) a Security Parameter
      Index.
<snip>

draft-haddad-mipshop-hmipv6-security-06.txt does not mention
the cipher suite of the SA,

draft-yegin-hmip-sa-00.txt defined HMIP-SPI and increase by 1
per authentication, so how to get the common initial SPI which could
not be out of the scope of this draft.

Furthermore draft-yegin-hmip-sa-00.txt, whether we need dervie
hmip-key from MSK will be the question. isn't USRK better than MSK?

Regarding to security guarantee of HMIP, and if EAP is considered,
a full eap authentication procedure is not necessary each handover,
a handover key could be used to enhance this performance, 
which has been described in our draft:
draft-deng-mipshop-hmip-hhokey-00.txt

Thanks for your comments,

-Hui
Disclaimer:
The contents of this e-mail, and its attachments, if any, are confidential and may be protected
by law against any unauthorized use.  If you have received this e-mail by mistake or have
reason to believe that you are not the intended recipient, please notify the sender by reply
e-mail as soon as possible and delete it from your computer system immediately thereafter.
If you are not the intended recipient, you must not copy this e-mail or attachment or disclose
the contents to any other person.  While we have made every effort to keep our network virus free,
we take no responsibility for any computer virus which might be transferred by way of this e-mail.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "Alper Yegin" <[email-masked]>
Date: Mon, 30 Oct 2006 09:48:02 +0200

Hello Hui,

Thanks for reading the I-D and providing feedback.

> not be out of the scope of this draft.

It is already defined in Section 2.

   HMIP-SPI value MUST be set to 1 upon initial EAP authentication with
   the authenticator, increased by 1 for each subsequent EAP re-
   authentication with the same authenticator, and set back to 1 after
   wrapping around.

> hmip-key from MSK will be the question. isn't USRK better than MSK?

The advantage of using MSK is, it is already available to the access
networks. All the necessary protocol extensions can be limited to the access
network that hosts the mobiles, NAS, and the MAP. Unless there are technical
problems with using MSK, this approach is more readily deployable than
relying on yet-to-be defined USRK and its delivery across the Internet.

> draft-deng-mipshop-hmip-hhokey-00.txt

Do you see any specific reason for doing it otherwise with the
draft-yegin-hmip-sa-00.txt?

Thanks again.

Alper

---

From: liangjing <[email-masked]>
Date: Mon, 30 Oct 2006 19:42:06 +0800

Hello, Hui
I have a question about your statement.
2006/10/30, DENG, HUI -HCHBJ <[email-masked]>:
> +ADw-snip+AD4-
> +ADw-snip+AD4-

Besides the MSK problem, could you help to clarify why the HMIP-key
derivation
does not contain any considerations on key freshness.

    HMIP-key = HMAC-SHA1(MSK, "HMIPv6 key derivation" | MN-ID  | MAP-IPaddr)

> transferred by way of this e-mail.
Thank you
Jing