Subject: [Mipshop] I-D ACTION:draft-ietf-mipshop-mos-dhcp-options-01.txt

From: [email-masked]
Date: Mon, 2 Jun 2008 11:15:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Mobility for IP: Performance, Signaling and Handoff Optimization Working Group of the IETF.

	Title		: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Options for Mobility Server (MoS) discovery
	Author(s)	: G. Bajko, S. Das
	Filename	: draft-ietf-mipshop-mos-dhcp-options-01.txt
	Pages		: 15
	Date		: 2008-6-2
	
This document defines a number of Dynamic Host Configuration 
   Protocol (DHCP-for-IPv4 and DHCP-for-IPv6) options that contain a 
   list of domain names or IP addresses that can be mapped to servers 
   providing IEEE 802.21 type of Mobility Services. These Mobility 
   Services are used to assist an MN in handover preparation (network 
   discovery) and handover decision (network selection). The services 
   addressed by this document are the Media Independent Handover 
   Services defined in [IEEE802.21].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mipshop-mos-dhcp-options-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Mipshop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mipshop

---

From: Subir Das <[email-masked]>
Date: Mon, 02 Jun 2008 19:15:53 -0400

Vijay,
Thanks for your comments. We will reflect them and I agree we need
another version.

-Subir

Vijay Devarapalli wrote:
> Hi Gabor, Subir,
>
> Thanks for making the change to use just one DHCP option instead of
> three options. 
>
> A few more comments on the draft.
>
> There is one line on page 3 that is extremely long. Idnits is
> complaining.
>
> In the sub-option format
>
>    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
>   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>   |       Sub-option Code         |           length              | 
>   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>   |      enc      |        FQDN or IP Address                     | 
>   .                                                               .
>   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
> Do we really need a 16-bit "Sub-option Code"? I think an 8-bit field
> would be sufficient. Moreover, this would allow the IPv4 address to fall
> on the 4 byte boundary. This would make the alignment requirement
> simple. The same thing applies for the IPv6 Relay Agent Sub-Option in
> section 3.2.1. An 8-bit field would be sufficient for the "sub-opt-code"
> field.
>
> In the following sub-option format
>
>   The sub-option for this encoding has the following format: 
>    
>          Code  Len   enc   DNS name of MoS server 
>        +-----+-----+-----+-----+-----+-----+-----+-----+-- 
>        | 1/7 |  n  |  0  |  s1 |  s2 |  s3 |  s4 | s5  |  ... 
>        +-----+-----+-----+-----+-----+-----+-----+-----+-- 
>
> I guess you wanted to say "1..7". What is "1/7"?
>
> In section 3.2.1, should we give a name for the sub-option? Currently it
> is called "IPv6 Relay Agent Sub-option". That is vague. Perhaps we
> should call it "IPv6 MoS Relay Agent Sub-option". (?)
>
> The IANA considerations section still says three DHCPv4 options. Anyway,
> I suggest re-writing the IANA considerations section as follows (it
> needs a lot of fixes).
>
> 6. IANA Considerations
>
>    This document defines one new DHCPv4 option as described in 
>    section 2. 
>
>       MoS Option for DHCPv4                   TBD
>  
>    This document creates a new registry for the Sub-Option field in the
>    MoS DHCPv4 option called the "MoS Service Type".
>
>       IS                       1
>       ES                       2
>       IS and ES                3
>       CS                       4
>       IS and CS                5
>       ES and CS                6
>       IS, CS and ES            7
>
>   The values '0', '8' to '255' are reserved and MUST NOT be used. New
>   values can be allocated by Standards Action or IESG approval.
>
>   This document also defines three new DHCPv6 options as described in 
>   sections 3.1 and 3.2
>
>      IPv6-MoSINF (MoS Identifier Option)            TBD
>      IPv6-MoS (MoS Option)                           TBD
>      IPv6-MoS-RELAY (IPv6 Relay Agent MoS Option)   TBD
>
>    This document creates a new registry for the Suboptions in the 
>    IPv6 Relay Agent MoS Option called the "MoS Service Type".
>
>         IS                       1
>         ES                       2
>         IS and ES                3
>         CS                       4
>         IS and CS                5
>         ES and CS                6
>         IS, CS and ES            7
>
>   The values '0', '8' to '255' are reserved and MUST NOT be used. New
>   values can be allocated by Standards Action or IESG approval.
>
> BTW, where is IPv6-MoS defined? I couldn't find it in the document.
>
> I am afraid we need one more revision before we can go for a WG last
> call on this document. 
>
> Vijay
>
>   
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of 
>> [email-masked]
>> Sent: Monday, June 02, 2008 11:15 AM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: [Mipshop] I-D 
>> ACTION:draft-ietf-mipshop-mos-dhcp-options-01.txt
>>
>> This draft is a work item of the Mobility for IP: 
>> Performance, Signaling and Handoff Optimization Working Group 
>> of the IETF.
>>
>> 	Title		: Dynamic Host Configuration Protocol 
>> (DHCPv4 and DHCPv6) Options for Mobility Server (MoS) discovery

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 2 Jun 2008 17:46:44 -0400

Hi Gabor, Subir,

In the sub-option format

   

6. IANA Considerations

 

      IS                       1
      ES                       2
      IS and ES                3
      CS                       4
      IS and CS                5
      ES and CS                6
      IS, CS and ES            7

        IS                       1
        ES                       2
        IS and ES                3
        CS                       4
        IS and CS                5
        ES and CS                6
        IS, CS and ES            7

Vijay