Subject: Re: [Mipshop] WG Last Call on draft-ietf-mipshop-mos-dns-discovery

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 9 Jun 2008 16:56:48 -0400

Hello all,

We haven't received any comments on this document in response to the WG
last call. We really need some support before we can send this document
to the IESG. If folks have reviewed the document and didn't have
comments, please send an email saying you support advancing the
document.

Vijay

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Vijay Devarapalli
> Sent: Wednesday, May 21, 2008 4:49 PM
> To: [email-masked]
> Subject: [Mipshop] WG Last Call on 
> draft-ietf-mipshop-mos-dns-discovery
> 
> Hello,
> 
> This is a two week working group last call for
> draft-ietf-mipshop-mos-dns-discovery-01.txt. You can find the document
> at the following URL.
> 
>
http://www.ietf.org/internet-drafts/draft-ietf-mipshop-mos-dns-discovery
-01.txt
> 
> The last call expires on June 5 2008.
> 
> Please post any issues or comments on this document to the MIPSHOP WG
> mailing list. In case you have reviewed the document and found no
> issues, please send an email saying you support advancing 
> this document.
> 
> The intended status for this document is Proposed Standard.
> 
> Vijay
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mipshop
> 
_______________________________________________
Mipshop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mipshop

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 10 Jun 2008 18:27:08 -0400

Thanks Yoshi. Just responding to one comment below 

> "
>    New entries to the registry MAY be added by IANA on a "First Come 
>    First Served" basis. 
> "
> 
> YO: Shouldn't the registry be "Specification Required" or "Standards
> Action"?

Standards Action or Specification Required means we have publish a new
RFC (or revise the existing one) every time we need a new value. For
this particular registry, I think FCFS is appropriate. You can just send
an email to IANA and reserve a new value.

Vijay

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 11 Jun 2008 14:50:09 -0400

Hi Yoshi,

The IANA page will list all the values. Implementors have to refer to
the IANA page anyway, since IANA is the one that maintains the
comprehensive list of values for any registry. 

We could add a sentence to the IANA considerations section of this
document asking implementors to refer to the corresponding IANA page for
the complete list of mappings from service field values to transport
protocols.

Vijay

> From: Yoshihiro Ohba [mailto:[email-masked]] 
> Sent: Wednesday, June 11, 2008 11:38 AM
> To: Vijay Devarapalli
> Cc: [email-masked]
> Subject: Re: [Mipshop] WG Last Call on 
> Hi Vijay,
> If FCFS-based, how can implementors know the semantics and usage of
> the new value?  Also, Specification Required does not mean that RFC is
> the only acceptable specification, according to BCP 26:
> 
>       Specification Required - Values and their meaning must be
>            documented in an RFC or other permanent and 
> readily available
>            reference, in sufficient detail so that interoperability
>            between independent implementations is possible.
> 
> Regards,
> Yoshihiro Ohba
> 
> 
> On Tue, Jun 10, 2008 at 06:27:08PM -0400, Vijay Devarapalli wrote:

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 11 Jun 2008 19:28:07 -0400

Hi Yoshi,

If there is ever a new service (right now, we only know IS, ES and CS),
we can revise the RFC. Infact, I think it is dangerous to allow defining
new services through FCFS. 

Vijay

> Sent: Wednesday, June 11, 2008 12:35 PM
> To: Vijay Devarapalli
> Cc: [email-masked]
> I would agree with you that FCFS is sufficient for adding new
> transports for ES, CS and IS, but it is also possible that new
> mobility service may be defined.
> 
> Note that MIH protocol can define up to 16 services.
> 
> To make my point clear, let's assume that the following new values
> are registered with IANA based on FCFS:
> 
>    XS+M2U                       TCP
>    XS+M2U                       UDP 
> 
> When implementors refer to IANA page and find the these values, they
> can know from IANA page that *some* mobility service can be carried
> over TCP or UDP but how can they know what mobility service "XS" is?
> 
> I have also realized that entries for "Service Management" service is
> missing.
> 
> Regards,
> Yoshihiro Ohba
> 
> On Wed, Jun 11, 2008 at 02:50:09PM -0400, Vijay Devarapalli wrote:
> > Hi Yoshi,
> >