Subject: Re: [Mipshop] AAA-based Handover Keys

From: "Koodli, Rajeev" <[email-masked]>
Date: Wed, 13 Aug 2008 14:49:19 -0400

Hello Hannes,

See: http://www.3gpp2.org/Public_html/IETF/IETF_Dependencies.cfm

The Fast Handovers for PMIPv6 is being used for eHRPD - LTE Interworking
and Network Evolution (3GPP2 documents X.P0057 and X.P0054
respectively).

Regards,

-Rajeev

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Wednesday, August 13, 2008 12:44 AM
> To: ext Vijay Devarapalli; [email-masked]
> Subject: Re: [Mipshop] AAA-based Handover Keys
> 
> Vijay, is there any chance that FMIPv6 will ever see some deployment?
> 
> Ciao
> Hannes
> 
> >-----Original Message-----
> >From: [email-masked]
> >[mailto:[email-masked]] On Behalf Of ext Vijay Devarapalli
> >Sent: 30 July, 2008 20:49
> >To: [email-masked]
> >Subject: [Mipshop] AAA-based Handover Keys
> >
> >Hello Folks,
> >
> >We didn't get a chance to discuss the next steps on AAA-based
> >handover keys. We ran out of time. Here are some observations.
> >
> >For progressing FMIPv6 to Proposed Standard, we have
> >standardized one mechanism based on SeND. I don't expect this
> >mechanism to be implemented by anyone. This could change if
> >SeND does get deployed, but that might take some time.
> >
> >There are some solutions available for AAA-based handover keys.
> >
> >- There is one draft from Alper that talks about deriving the
> >MN-AR key assuming that there is some sort of shared key
> >between the mobile node and the access router.
> >- The second one is from Vidya that defines a new protocol
> >with message exchange between the mobile node, the access
> >router and the handover keying server (presumably on the AAA)
> >for deriving a MN-AR key for use with FMIPv6.
> >- The third one is to punt part of the problem to HOKEY. We
> >assume that there is an USRK available for FMIPv6 and we just
> >describe how to derive the MN-AR key from this USRK.
> >
> >We could pick one and standardize it. But the issue is that I
> >don't think there would be any customers (SDO or non-SDO) for
> >the solution we develop in the MIPSHOP WG. The expectation is
> >that SDOs would use some access-specific signaling to secure
> >MN-AR FMIPv6 messages. I also think that we don't have
> >sufficient information today to pick a solution.
> >
> >So the proposal is to write up an Informational document that
> >says there are a number of ways to leverage the AAA
> >infrastructure to derive MN-AR key for FMIPv6. We don't
> >actually define a solution. Just point to some of the possible
> >solutions. We won't be standardizing any of the solution
> >documents. In addition, we can mention in the document that if
> >there is sufficient interest in one of the solutions or if
> >some solution actually gets deployed in the future, we can
> >pick that and standardize it.
> >
> >The slides that I was going to present are at
> >http://www.ietf.org/proceedings/08jul/slides/mipshop-3.pdf
> >
> >Comments?
> >
> >Vijay
> >_______________________________________________
> >Mipshop mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/mipshop
> >
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mipshop
_______________________________________________
Mipshop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mipshop

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 13 Aug 2008 21:57:00 +0300

Thanks for the pointer.

So, what security mechanisms are they going to use? AAA based, SeND 
based or ???.

Koodli, Rajeev wrote:
>>> solutions. We won't be standardizing any of the solutiondocuments. In addition, we can mention in the document that if