Subject: [Mipshop] Revision of Transient Binding draft, removal of A-flag

From: Marco Liebsch <[email-masked]>
Date: Mon, 25 May 2009 16:07:06 +0200

Folks,

we revised version 2 of the transient BCE draft according to the comments
we received. In addition to many useful editorial changes and new text for
further clarification, we discussed thoroughly one issue that has been 
addressed
by Pierrick and Telemaco which is about the appropriate entity to select 
the use
of an optional activation state (Transient-A) after a late path switch.

The comment from Pierrick was about leaving the selection to use such 
activation
state to the LMA for the following reason:
Only the LMA has knowledge about both technologies, the pMAG's and the
nMAG's one. Hence, the LMA is the right entity to decide if there is benefit
in using the activation state.

We discussed this even further and found that the use of an activation 
state
Transient-A could be kept transparent to the nMAG, so we thought about
removing the A-flag from the Transient Binding option.

Both changes have the following effect: Clear roles for nMAG and LMA:
nMAG can select the late path switch (L), whereas the decision on the
optional activation state is always done by the LMA. This means even less
complexity and a straight procedure to perform the handover.

We believe that the changes reflect the discussion on the mailing list 
well and
lead to a simplified document. Confirmation by the WG and comments are
appreciated, in particular if you have concerns with these changes.

marco

---

From: Rajeev Koodli <[email-masked]>
Date: Mon, 25 May 2009 16:05:25 -0700

Hi Marco,

I have a question related to the revision of this ID in general: at
the last meeting, we agreed on adding an Applicability Statement
section to the document. Specifically, folks (George Tsirtsis, myself
included) noted that existing HAs do something like this already,
which should be part of such a section. Would you be adding this in
the next version? If I missed it, please let me know.

Thanks,

-Rajeev

On Mon, May 25, 2009 at 7:07 AM, Marco Liebsch <[email-masked]> wrote:
> by Pierrick and Telemaco which is about the appropriate entity to select the
> use
> We discussed this even further and found that the use of an activation state
> We believe that the changes reflect the discussion on the mailing list well
> and
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mipshop
>

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 25 May 2009 23:34:25 -0500

Hi Rajeev,

We are talking here about the setting of the A-Flag. 
It is not clear from your posting if you are referring to the same thing
or something else too?
Could you please clarify.

Regards,
Ahmad
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Rajeev Koodli
> Sent: Monday, May 25, 2009 6:05 PM
> To: Marco Liebsch
> Cc: [email-masked]; Pierre Imai; MELIA TELEMACO
> Subject: Re: [Mipshop] Revision of Transient Binding draft, 
> removal of A-flag
> 
> Hi Marco,
> 
> I have a question related to the revision of this ID in 
> general: at the last meeting, we agreed on adding an 
> Applicability Statement section to the document. 
> Specifically, folks (George Tsirtsis, myself
> included) noted that existing HAs do something like this 
> already, which should be part of such a section. Would you be 
> adding this in the next version? If I missed it, please let me know.
> 
> Thanks,
> 
> -Rajeev
> 
> 
> > we revised version 2 of the transient BCE draft according to the 
> > comments we received. In addition to many useful editorial 
> changes and 
> > new text for further clarification, we discussed thoroughly 
> one issue 
> > that has been addressed by Pierrick and Telemaco which is about the 
> > appropriate entity to select the use of an optional 
> activation state 
> > (Transient-A) after a late path switch.
> >
> > activation state to the LMA for the following reason:
> > nMAG's one. Hence, the LMA is the right entity to decide if 
> there is 
> > benefit in using the activation state.
> >
> > state Transient-A could be kept transparent to the nMAG, so 
> we thought 
> > about removing the A-flag from the Transient Binding option.
> >
> > optional activation state is always done by the LMA. This 
> means even 
> > less complexity and a straight procedure to perform the handover.
> >
> > well and lead to a simplified document. Confirmation by the WG and 
> > comments are appreciated, in particular if you have concerns with 
> > these changes.
> >
> >
> > marco
> >
> >

---

From: Rajeev Koodli <[email-masked]>
Date: Mon, 25 May 2009 21:39:29 -0700

Hi Ahmad,

may be it was not clear.. I am referring to the revision of the ID in
general, not to the A-flag.

Regards,

-Rajeev

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 26 May 2009 00:27:45 -0500

Hi Rajeev,

Since you quoted George below; I believe George was referring to the
case when the HA is allowed to accept late UL traffic from the Old MAG.
Immediately, after the meeting, I had a quick chat with George and he
clearly said that his comment was for that case and also clearly said
that the case when allowing UL traffic from the new-MAG is different and
he is not aware of any HA which handles that with static configuration.

So, it seems that you are the only one who still believe that the whole
draft can be handled with static configuration and some magic HA(s) are
currently addressing this securely. I posted a couple of times the
security issue with the L-Flag. I humbly request that review that threat
and if you still have issues, we certainly can discuss. Or, you could
explain to us how some of the current HA(s) handles the whole draft in a
secure manner via static configuration.

Regards,
Ahmad

> From: Rajeev Koodli [mailto:[email-masked]] 
> Sent: Monday, May 25, 2009 11:39 PM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: Marco Liebsch; [email-masked]; Pierre Imai; MELIA TELEMACO
> may be it was not clear.. I am referring to the revision of 
> the ID in general, not to the A-flag.
> 
> Regards,
> 
> -Rajeev
> 
> 
> > It is not clear from your posting if you are referring to the same 
> > thing or something else too?
> >> Subject: Re: [Mipshop] Revision of Transient Binding 
> draft, removal 
> >> of A-flag
> >>
> >> Hi Marco,
> >>
> >> general: at the last meeting, we agreed on adding an Applicability 
> >> Statement section to the document.
> >> On Mon, May 25, 2009 at 7:07 AM, Marco Liebsch 
> <[email-masked]> 
> >> wrote:
> >> > Folks,
> >> >

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Tue, 26 May 2009 13:05:24 -0400

Hi Ahmad,
 
could you please point me to the thread you are referring to?
 
Yes, I do (still) believe that the problem of accepting packets at a HA can be solved in an implementation-dependent way. I will take a look at your thread (that you are referring to), and propose text for the Applicability Statement. 
 
Thanks,
 
-Rajeev

________________________________

From: [email-masked] on behalf of Ahmad Muhanna
Sent: Mon 5/25/2009 10:27 PM
To: Rajeev Koodli
Cc: Marco Liebsch; [email-masked]; Pierre Imai; MELIA TELEMACO
Subject: Re: [Mipshop] Revision of Transient Binding draft, removal of A-flag

Hi Rajeev,

Regards,
Ahmad

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 26 May 2009 13:44:40 -0400

Ahmad,

The general consensus in the room was that you need to clarify what can
be done with implementation techniques on the LMA. You can then point
out the limitations of those implementation techniques. This would in
general serve as the motivation for protocol extensions. 

We have had people asking questions on these for the past three IETFs at
least. So it would good to have some text in the draft on this.

Vijay

> [mailto:[email-masked]] On Behalf Of Ahmad Muhanna
> Sent: Monday, May 25, 2009 10:28 PM
> To: Rajeev Koodli
> already,

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 26 May 2009 13:23:47 -0500

Vijay,

There was some discussion that some of what the draft is trying to do
can be addressed at the HA with some configurations. That what the
authors are trying to do as suggested by Marco with respect to the
A-flag. On the other hand, I disagree that all the functionalities of
the draft can be done using the same argument. We discussed this many
time and posted a detailed analysis several times.

Regards,
Ahmad

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Tuesday, May 26, 2009 12:45 PM
> To: Muhanna, Ahmad (RICH1:2H10); Rajeev Koodli
> Subject: RE: [Mipshop] Revision of Transient Binding draft, 
> removal of A-flag
> 
> Ahmad,
> 
> The general consensus in the room was that you need to 
> clarify what can be done with implementation techniques on 
> the LMA. You can then point out the limitations of those 
> implementation techniques. This would in general serve as the 
> motivation for protocol extensions. 
> 
> We have had people asking questions on these for the past 
> three IETFs at least. So it would good to have some text in 
> the draft on this.
> 
> Vijay
> 
> removal of 
> > A-flag
> > that the case when allowing UL traffic from the new-MAG is 
> different 
> > and he is not aware of any HA which handles that with static 
> > configuration.
> > 
> > So, it seems that you are the only one who still believe that the 
> > whole draft can be handled with static configuration and some magic
> > HA(s) are
> > security issue with the L-Flag. I humbly request that review that 
> > threat and if you still have issues, we certainly can 
> discuss. Or, you 
> > could explain to us how some of the current HA(s) handles the whole 
> > draft in a secure manner via static configuration.
> > 
> > Regards,
> > Ahmad
> >  
> > 
> > > may be it was not clear.. I am referring to the revision 
> of the ID 
> > > in general, not to the A-flag.
> > > 
> > > Regards,
> > > 
> > > -Rajeev
> > > 
> > > 
> > > On Mon, May 25, 2009 at 9:34 PM, Ahmad Muhanna 
> <[email-masked]> 
> > > wrote:
> > > > Hi Rajeev,
> > > >

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 26 May 2009 13:28:19 -0500

Hi Rajeev,

Please find the thread at the link below:
http://www.ietf.org/mail-archive/web/mipshop/current/msg04365.html

Regards,
Ahmad

> [mailto:[email-masked]] On Behalf Of Koodli, Rajeev
> Sent: Tuesday, May 26, 2009 12:05 PM
> To: [email-masked]
> Yes, I do (still) believe that the problem of accepting 
> packets at a HA can be solved in an implementation-dependent 
> way. I will take a look at your thread (that you are 
> referring to), and propose text for the Applicability Statement. 
>  
> Thanks,
>  
> -Rajeev
>  
> 
> Since you quoted George below; I believe George was referring 
> to the case when the HA is allowed to accept late UL traffic 
> from the Old MAG.
> Immediately, after the meeting, I had a quick chat with 
> George and he clearly said that his comment was for that case 
> and also clearly said that the case when allowing UL traffic 
> from the new-MAG is different and he is not aware of any HA 
> which handles that with static configuration.
> 
> So, it seems that you are the only one who still believe that 
> the whole draft can be handled with static configuration and 
> some magic HA(s) are currently addressing this securely. I 
> posted a couple of times the security issue with the L-Flag. 
> I humbly request that review that threat and if you still 
> have issues, we certainly can discuss. Or, you could explain 
> to us how some of the current HA(s) handles the whole draft 
> in a secure manner via static configuration.
> 
> Regards,
> Ahmad
> 
>

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 26 May 2009 14:29:50 -0400

I know at least Ryuji and Rajeev have raised issues on this in the past.
A possible way forward would be for Ryuji and Rajeev to supply a brief
outline of the text that they would like to see in the draft. Then the
authors of the draft can come up with actual text that can go into the
draft. 

> the draft can be done using the same argument. 

I agree with your disagreement as well. :)

> We discussed this many

Right. But it would be good to capture a brief description of this
"analysis" in the draft, so that these questions don't come up again
during WG last call, IETF last call and IESG review.

Vijay

> > > case when the HA is allowed to accept late UL traffic 
> from the Old 
> > > MAG.
> > George and he

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 26 May 2009 13:42:48 -0500

Hi Vijay,

Sure. I (personally) believe we are on the same page. I believe Marco
and Oliver also have the same views; but they may confirm too. In
addition, we will look into capturing the reasoning why not all cases
can be addressed locally at the LMA. 

Regards,
Ahmad

> Sent: Tuesday, May 26, 2009 1:30 PM
> To: Muhanna, Ahmad (RICH1:2H10); Rajeev Koodli; Ryuji Wakikawa
> A possible way forward would be for Ryuji and Rajeev to 
> supply a brief outline of the text that they would like to 
> see in the draft. Then the authors of the draft can come up 
> with actual text that can go into the draft. 
> 
> Right. But it would be good to capture a brief description of 
> this "analysis" in the draft, so that these questions don't 
> come up again during WG last call, IETF last call and IESG review.
> 
> Vijay
> 
> > 
> > Regards,
> > Ahmad
> >  
> > 
> > > Subject: RE: [Mipshop] Revision of Transient Binding 
> draft, removal 
> > > of A-flag
> > > 
> > > Ahmad,
> > > 
> clarify what 
> > > can be done with implementation techniques on the LMA. 
> You can then 
> > > point out the limitations of those implementation 
> techniques. This 
> > > would in general serve as the motivation for protocol extensions.
> > > 
> > > We have had people asking questions on these for the past three 
> > > IETFs at least. So it would good to have some text in the 
> draft on 
> > > this.
> > > 
> > > Vijay
> > > 
> > > > > >> > We discussed this even further and found that 
> the use of an
> > > > > >> activation

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 27 May 2009 09:24:38 +0200

Regarding the request from last meeting to mention implementation
specific solutions, the spec mentions timer-based state changes,
such as termination of a transient BCE, at different places in the
draft, but also refers to the benefit of using signaling. I think this
should meet the request. Let's see if there is really more to add.

marco

Ahmad Muhanna schrieb:
>>> There was some discussion that some of what the draft is 
>>>       
>> trying to do 
>>     
>>> A-flag. On the other hand, I disagree that all the 
>>>       
>> functionalities of 
>>     
>>>>> Since you quoted George below; I believe George was
>>>>>           
>>>> referring to the
>>>>         
>>>>> clearly said that his comment was for that case and also
>>>>>           
>>>> clearly said
>>>>         
>>>>> So, it seems that you are the only one who still 
>>>>>           
>> believe that the 
>>     
>>>>> whole draft can be handled with static configuration and
>>>>>           
>>> some magic
>>>       
>>>>> HA(s) are
>>>>> currently addressing this securely. I posted a couple of
>>>>>           
>>> times the
>>>       
>>>>> security issue with the L-Flag. I humbly request that 
>>>>>           
>> review that 
>>     
>>>>> could explain to us how some of the current HA(s) handles
>>>>>           
>>> the whole
>>>       
>>>>>> Cc: Marco Liebsch; [email-masked]; Pierre Imai; 
>>>>>>             
>> MELIA TELEMACO
>>     
>>>>>>> It is not clear from your posting if you are referring to
>>>>>>>               
>>>>> the same
>>>>>           
>>>>>>>> [mailto:[email-masked]] On Behalf Of 
>>>>>>>>                 
>> Rajeev Koodli
>>     
>>>>> Applicability
>>>>>>>> which should be part of such a section. Would you be
>>>>>>>>                 
>>>>>> adding this in
>>>>>>             
>>>>>>>>> we revised version 2 of the transient BCE draft
>>>>>>>>>                   
>>>>> according to the
>>>>>           
>>>>>>>>> comments we received. In addition to many useful 
>>>>>>>>>                   
>> editorial
>>     
>>>>>>>> changes and
>>>>>>>>                 
>>>>>>>>> new text for further clarification, we discussed 
>>>>>>>>>                   
>> thoroughly
>>     
>>>>>>>> one issue
>>>>>>>>                 
>>>>>>>>> that has been addressed by Pierrick and Telemaco which
>>>>>>>>>                   
>>>>>> is about the
>>>>>>             
>>>>>>>>> The comment from Pierrick was about leaving the selection
>>>>>>>>>                   
>>>>>>>> to use such
>>>>>>>>                 
>>>>>>>>> Only the LMA has knowledge about both technologies, the
>>>>>>>>>                   
>>>>>>>> pMAG's and the
>>>>>>>>                 
>>>>>>>>> nMAG's one. Hence, the LMA is the right entity 
>>>>>>>>>                   
>> to decide if
>>     
>>>>>>>> there is
>>>>>>>>                 
>>>>>>>>> state Transient-A could be kept transparent to 
>>>>>>>>>                   
>> the nMAG, so
>>     
>>>>>>>> we thought
>>>>>>>>                 
>>>>>>>>> about removing the A-flag from the Transient
>>>>>>>>>                   
>>> Binding option.
>>>       
>>>>>>>>> Both changes have the following effect: Clear roles for
>>>>>>>>>                   
>>>>>>>> nMAG and LMA:
>>>>>>>>                 
>>>>>>>>> nMAG can select the late path switch (L), whereas the
>>>>>>>>>                   
>>>>>>>> decision on the
>>>>>>>>                 
>>>>>>>>> less complexity and a straight procedure to perform
>>>>>>>>>                   
>>>>> the handover.
>>>>>           
>>>>>>>>> We believe that the changes reflect the discussion on the
>>>>>>>>>                   
>>>>>>>> mailing list
>>>>>>>>                 
>>>>>>>>> well and lead to a simplified document. Confirmation by
>>>>>>>>>                   
>>>>>> the WG and
>>>>>>             
>>>>>>>>> comments are appreciated, in particular if you have
>>>>>>>>>                   
>>>>>> concerns with
>>>>>>             
>>>>>>>>> these changes.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> marco
>>>>>>>>>
>>>>>>>>>

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 27 May 2009 09:37:00 +0200

As this seems to be the biggest issue, well, should not be a problem to 
add more.
Coming back to the original content of the mail, thought that technical
improvements to meet technically interested folks' comments is more
relevant. We'll work on it.

Thanks,
marco

Vijay Devarapalli schrieb:
>>>>>>>> We discussed this even further and found that the use of an
>>>>>>>>                 
>>>>>>> activation
>>>>>>>