Subject: [MLS] IETF 103 Hackathon

From: Raphael Robert <[email-masked]>
Date: Mon, 22 Oct 2018 18:36:05 +0200

Hey all,

The IETF 103 Hackathon is approaching and I'd like to invite anyone who is interested in hacking early MLS implementations to participate!

A list of current implementations as well as some initial test vectors can be found here: https://github.com/mlswg/mls-implementations

It would be interesting to hear who else will participate and if there are more implementations out there. The goal I propose is to see if we can get some interop between different implementations on the (serialised) handshake message level.

Raphael

---

From: Richard Barnes <[email-masked]>
Date: Mon, 22 Oct 2018 12:53:20 -0400

Thanks, Raphael!  I will be there, and looking forward to getting interop.

To be concrete about the interop target: In between now and the hackathon,
I'm going to work on getting mlspp updated to support the just-published
-02 draft.

It seems like we can probably build a ladder of test cases and work up:
- Generate and parse UserInitKeys from one stack to another
- Create a two-member group by sending Welcome and Add messages from one
stack to another
- Send updates within the two-member group
- etc.

What ciphersuite(s) are you targeting?  IIRC, mlspp only does the P-256 one
right now, but could probably be made to do Curve25519.

On Mon, Oct 22, 2018 at 12:37 PM Raphael Robert <[email-masked]> wrote:

> Hey all,
>
> The IETF 103 Hackathon is approaching and I'd like to invite anyone who is
> interested in hacking early MLS implementations to participate!
>
> A list of current implementations as well as some initial test vectors can
> be found here: https://github.com/mlswg/mls-implementations
>
> It would be interesting to hear who else will participate and if there are
> more implementations out there. The goal I propose is to see if we can get
> some interop between different implementations on the (serialised)
> handshake message level.
>
> Raphael
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls
>

---

From: Raphael Robert <[email-masked]>
Date: Mon, 22 Oct 2018 19:10:34 +0200

Good approach! For now the test vectors are just for tree math, but I’ll add more as soon as I can. We can probably build stories (Alice adds Bob, Bob updates, Bob adds Charlie and removes Alice, etc.) and publish test vectors for each step.

For now melissa can only do Curve25519. I’d like to propose we take that ciphersuite as the first one for relevant test vectors.

For real-time communication and to coordinate details around interop, there is a dedicated Wire channel open to anyone: https://app.wire.com/join/?key=3tL-NJOoCKZlDXNU1H2c&code=kZOc0ujnDQ9Tq98tLfSt <https://app.wire.com/join/?key=3tL-NJOoCKZlDXNU1H2c&code=kZOc0ujnDQ9Tq98tLfSt>

> On 22 Oct 2018, at 18:53, Richard Barnes <[email-masked]> wrote:
> 
> To be concrete about the interop target: In between now and the hackathon, I'm going to work on getting mlspp updated to support the just-published -02 draft.
> 
> - Create a two-member group by sending Welcome and Add messages from one stack to another
> What ciphersuite(s) are you targeting?  IIRC, mlspp only does the P-256 one right now, but could probably be made to do Curve25519.
> 
> 
> On Mon, Oct 22, 2018 at 12:37 PM Raphael Robert <[email-masked] <mailto:[email-masked]>> wrote:
> Hey all,
> 
> A list of current implementations as well as some initial test vectors can be found here: https://github.com/mlswg/mls-implementations <https://github.com/mlswg/mls-implementations>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mls <https://www.ietf.org/mailman/listinfo/mls>