Subject: [MLS] [interim_transcript_hash]

From: Pascal Junod <[email-masked]>
Date: Thu, 10 Oct 2019 16:02:16 +0200

Hi !

Just wondering whether there is a reason why the interim_transcript_hash
value (necessary to build Welcome messages) value is not contained into the
GroupContext structure.

Best,

Pascal

---

From: Richard Barnes <[email-masked]>
Date: Fri, 11 Oct 2019 09:53:59 -0400

Because if you did that, then you would have a circular dependency:

interim_transcript_hash
<= MLSPlaintext.confirmation
<= confirmation_key
<= GroupContext (via DeriveSecret)
<= interim_transcript_hash

This was a problem in earlier versions!

On Thu, Oct 10, 2019 at 10:02 Pascal Junod <pascalj=
[email-masked]> wrote:

> value (necessary to build Welcome messages) value is not contained into
> the GroupContext structure.
>
> Best,
>
> Pascal
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls
>

---

From: Benjamin Beurdouche <[email-masked]>
Date: Fri, 11 Oct 2019 16:05:49 +0200

Hi Pascal,

Note that it is a technicality due to a set of successive change that lead to
the current design, our proofs don’t rely on such complicated GroupContext
and interim transcript but only on the hash of the transcript itself.

I promised I would spend the time on fixing this but I haven’t find it yet.
I’ll do a PR to fix it within the next few weeks.

B.

> On Oct 11, 2019, at 3:53 PM, Richard Barnes <[email-masked]> wrote:
> 
> On Thu, Oct 10, 2019 at 10:02 Pascal Junod <pascalj=[email-masked] <mailto:[email-masked]>> wrote:
> Hi !
> 
> Just wondering whether there is a reason why the interim_transcript_hash value (necessary to build Welcome messages) value is not contained into the GroupContext structure. 
> 
> Best, 
> 
> Pascal
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mls <https://www.ietf.org/mailman/listinfo/mls>

---

From: Benjamin Beurdouche <[email-masked]>
Date: Fri, 11 Oct 2019 16:06:45 +0200

> I promised I would spend the time on fixing this but I haven’t find it yet.

*found, sorry : )