Subject: [MLS] [ratchet tree update example]

From: Pascal Junod <[email-masked]>
Date: Mon, 7 Oct 2019 13:09:14 +0200

Hello,

I have a quick question about the example discussed through the "Ratchet
Tree Updates" and "Synchronizing Views of the Tree" sections.

Currently, an encryption of ps[2] under public keys of nodes C and D is
described. In my opinion, it should be a single ciphertext encrypted with
public key F, whose corresponding private key is known by both C and D. Or
did I misunderstood something?

Best,

Pascal

---

From: Benjamin Beurdouche <[email-masked]>
Date: Mon, 7 Oct 2019 22:17:01 +0200

Hi Pascal,

I think you are right, it should indeed be a single ciphertext of ps[2] under pkF.
It might be that a previous example had a blanked F, which is not the case here.

I’ll double check in the morning and fix it. :)
Thanks !

B.

> On Oct 7, 2019, at 1:09 PM, Pascal Junod <pascalj=[email-masked]> wrote:
> 
> Hello, 
> 
> I have a quick question about the example discussed through the "Ratchet Tree Updates" and "Synchronizing Views of the Tree" sections. 
> 
> Currently, an encryption of ps[2] under public keys of nodes C and D is described. In my opinion, it should be a single ciphertext encrypted with public key F, whose corresponding private key is known by both C and D. Or did I misunderstood something?
> 
> Best, 
> 
> Pascal
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls

---

From: Pascal Junod <[email-masked]>
Date: Tue, 8 Oct 2019 09:33:12 +0200

Thank you for the quick feedback! I just pushed a PR fixing the spec
document.

On Mon, Oct 7, 2019 at 10:17 PM Benjamin Beurdouche <
[email-masked]> wrote:

> On Oct 7, 2019, at 1:09 PM, Pascal Junod <
> pascalj=[email-masked]> wrote:
>
> Hello,
>
> public key F, whose corresponding private key is known by both C and D.
> Or did I misunderstood something?
>
> Best,
>
> Pascal
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mls&d=DwICAg&c=ncDTmphkJTvjIDPh0hpF_w&r=Ifbwlzxh3jRRAPiBazmj6w&m=Urq9OlsiBHujJ-r9Sa8W0KV4HplKu2CZ0WZ88Jy0Y-g&s=elJcaMuyOOyES0TrmQmvKlDEp7VP9-AFFxw5IWYqqJg&e=
>