Subject: Re: [MLS] Calls to resolve MLS PRs

From: Sean Turner <[email-masked]>
Date: Tue, 4 Feb 2020 11:21:14 +0100

As a reminder, the recurring virtual interim is tomorrow. The information is the same as last week.

spt

> On Jan 28, 2020, at 23:52, Nick Sullivan <nick=[email-masked]> wrote:
> 
> As a reminder, the recurring virtual interim is tomorrow. Here's the meeting information:
> 
> Meeting link: https://ietf.webex.com/ietf/j.php?MTID=m2e0d1a76482036fdb38c7d1f5fdd3cc6
> Meeting number: 647 391 156
> Password: ve2i8niw
> 
> https://github.com/mlswg/wg-materials/tree/master/virtual-interim-recurring
> 
> Nick & Sean
> 
> On Wed, Jan 22, 2020 at 11:04 AM Nick Sullivan <[email-masked]> wrote:
> It looks like Wednesday at 1400-1500 GMT is the least bad time.
> 
> These calls will be recurring virtual interims, and as such are covered by the note well. As a reminder, decisions made at interim meetings are not final and must be confirmed on the list.
> 
> Here's the proposed schedule (subject to AD approval):
> Time: 1400-1500 GMT on Wednesdays
> Agenda: the set of active PRs for the active documents on Github (https://github.com/mlswg).
> 
> Links to the conference calls are forthcoming.
> 
> Nick & Sean
> 
> On Mon, Jan 13, 2020 at 8:51 AM Richard Barnes <[email-masked]> wrote:
> Also: Note that despite this poll listing specific dates, the intent is to set up a weekly recurring meeting.  In fact, these dates will definitely not be the dates when the calls happen, because IETF requires one week notice.
> 
> On Sun, Jan 12, 2020 at 6:05 PM Richard Barnes <[email-masked]> wrote:
> I would like to have some weekly calls to make faster progress on our outstanding PRs.  Here's a Doodle to find a good time:
> 
> https://doodle.com/poll/bg2q65phrvfip5zb
> 
> I believe these will need to be official Virtual Interims per IETF process.  Chairs, I assume you can do whatever announcements are necessary once we pick a time.
> 
> --Richard
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls

---

From: Sean Turner <[email-masked]>
Date: Wed, 5 Feb 2020 16:07:02 +0100

Thanks to Richard, Britta, Raphael, and Brandon for dialing in. We reviewed the following PRs:

- https://github.com/mlswg/mls-protocol/pull/279
- https://github.com/mlswg/mls-protocol/pull/285
- https://github.com/mlswg/mls-protocol/pull/286
- https://github.com/mlswg/mls-protocol/pull/294
- https://github.com/mlswg/mls-protocol/pull/295

More info once the minutes pop out (thanks Richard).

spt

> On Feb 4, 2020, at 11:21, Sean Turner <[email-masked]> wrote:
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 5 Feb 2020 12:13:43 -0500

Here are my notes from today:

* Attendees:
    * Richard Barnes
    * Sean Turner
    * Brendan McMillion
    * Britta Hale
    * Raphael Robert
* #287 [ Path-hash ]
    * Brendan will add OPEN ISSUE
    * RLB will check with Benjamin that he’s OK with merging with the OPEN
ISSUE there
* #279 [ Ciphersuites ]
    * Raphael will address the requirements that sig scheme is fixed
    * Sean will send text about recommending conservatism
    * Raphael will reserve private space
* #285 [ Ignored proposals ]
    * Brendan to change SHOULDs to MUSTs
* #286 [ Committer update ]
    * Brendan to change Update to ClientInitKey
* #294 [ DirectPath does not cover leaf ]
    * Brendan to make minor changes noted in PR
* #295 [ Path -> PathSecret ]
    * OK to merge
* AOB:
    * Raphael: Mechanism to send targeted messages within a group
        * Not broadcast, send to subgroup
        * E.g., read receipts want to go just to sender
    * RLB: Some issues that could use discussion / PRs

On Wed, Feb 5, 2020 at 10:07 AM Sean Turner <[email-masked]> wrote:

> >> Meeting link:
> https://ietf.webex.com/ietf/j.php?MTID=m2e0d1a76482036fdb38c7d1f5fdd3cc6
> >> These calls will be recurring virtual interims, and as such are covered
> by the note well. As a reminder, decisions made at interim meetings are not
> final and must be confirmed on the list.
> >>
> >> Also: Note that despite this poll listing specific dates, the intent is
> to set up a weekly recurring meeting.  In fact, these dates will definitely
> not be the dates when the calls happen, because IETF requires one week
> notice.
> >>
> >> I would like to have some weekly calls to make faster progress on our
> outstanding PRs.  Here's a Doodle to find a good time:
> >>
> >> I believe these will need to be official Virtual Interims per IETF
> process.  Chairs, I assume you can do whatever announcements are necessary
> once we pick a time.
> >>
> >> --Richard

---

From: Sean Turner <[email-masked]>
Date: Tue, 11 Feb 2020 16:53:20 -0500

As a reminder there is another virtual interim. This is the call information:

spt

> On Feb 4, 2020, at 05:21, Sean Turner <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 18 Feb 2020 19:56:49 -0500

Apologies for the late reminder, but there is yet another virtual interim scheduled for tomorrow. The call information is the same as last week:

spt

> On Feb 11, 2020, at 16:53, Sean Turner <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 25 Feb 2020 12:20:24 -0500

Please note that there is another meeting tomorrow. Same time, place, and details:

spt

> On Feb 18, 2020, at 19:56, Sean Turner <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Wed, 26 Feb 2020 11:27:45 -0500

Thanks to Brendan, Britta, and Ray for calling in today.

You’ll see some emails about the two topics we discussed shortly.

spt

> On Feb 25, 2020, at 12:20, Sean Turner <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Wed, 26 Feb 2020 12:24:50 -0500

Minutes for 2/19 (thanks Richard) and 2/26 meetings available now at github:

https://github.com/mlswg/wg-materials/blob/master/virtual-interim-recurring/02-19-2020.md

https://github.com/mlswg/wg-materials/blob/master/virtual-interim-recurring/02-26-2020.md

spt

> On Feb 26, 2020, at 11:27, Sean Turner <[email-masked]> wrote:
>