Subject: [MLS] confirming server assist way forward

From: Sean Turner <[email-masked]>
Date: Thu, 6 Feb 2020 17:08:04 +0100

Hi!

tl;dr: confirming new individual draft to describe server assist.

During the F2F Interim in January, the WG had a lengthy discussion about server assist. We wrestled with the tussle between privacy and the desire to support very large groups, which just about everybody, if not everybody, believes requires some type of server assist because adding a new member to a large group requires sending megabytes of data in the Welcome message and this can be too much for some devices. Normally, the AS and DS is split and maybe these functions are collapsed in IRL, but Benjamin suggested that we split the functionality up a bit more to talk more fine-grained about the guarantees we want. The functional split suggested was as follows [0]:

- AS: Authentication Service (Signature Keys)
- DS: Delivery Service
-- CS: Credential Retrieval Service (CIKs)
-- IDS: Message Reception Service (Input)
--- IDS is responsible for message ordering.
-- ODS: Message Delivery Service (Output)
--- IDS and ODS may be combined.
- SDS: Storage Delivery Service (Welcome+Backup)
-- SDS is optional.

Likewise, they suggested that we switch from a model where there is one queue per group, to one queue per recipient.

The consensus at the interim was that it is important to support server assist and that it was equally important to provide truth in advertising, i.e., those that implement the functionality need to understand the security guarantees that are available.

There was also consensus to produce an individual draft that describes server assist. After this draft is published, the WG can review it and decide whether it should be accepted as a workable starting point and potential WG item.

The chairs need to confirm the interim’s consensus on list, so please let the WG know by 2359 UTC 20 February whether you disagree with the way forward and why.

FYI: Benjamin and Raphael volunteered to write this draft.

Cheers,

Nick and Sean

[0] https://github.com/mlswg/wg-materials/blob/master/interim-2020-01/04-architecture.pdf
[1] https://github.com/mlswg/wg-materials/blob/master/interim-2020-01/minutes.md

---

From: Benjamin Beurdouche <[email-masked]>
Date: Fri, 7 Feb 2020 15:04:39 +0100

Obviously I support this effort.

I just want to remind the WG that the intent of that document is to describe
what we think are the main constraints and establish where the
places where not only security but also privacy can be affected by a 
server-assist feature. We will illustrate these places and recommend
possible solutions. Again, the goal is not to mandate solutions.

If all goes well, this effort will confort the fact that the server-assist features
do not affect the core security guarantees we expect from the protocol.

B.

> On 6 Feb 2020, at 17:08, Sean Turner <[email-masked]> wrote:
> 
> Hi!
> 
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls

---

From: Raphael Robert <[email-masked]>
Date: Fri, 7 Feb 2020 17:17:13 +0100

I also support this effort. Like Benjamin said, the goal is not to propose a mandatory concept but rather work o something that could be useful in a number of scenarios and that can be extended if need be.

Raphael

> On 7 Feb 2020, at 15:04, Benjamin Beurdouche <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 25 Feb 2020 12:28:35 -0500

Hi!

I am going to go ahead and confirm that WG’s consensus for the plan outlined below.  I also confirmed with Raphael and Benjamin that they are still willing to start the individual draft (in fact I think they already have a repo). The WG will then consider whether it is a good starting point. Hoping that we can review the draft at IETF 107.

NOTE: 2020-03-09 UTC 23:59 is the submission deadline for IETF 107.

Cheers,

spt

> On Feb 6, 2020, at 11:08, Sean Turner <[email-masked]> wrote:
> 
> Hi!
>