Subject: Re: [MLS] Virtual Interim minutes

From: Sean Turner <[email-masked]>
Date: Tue, 11 Feb 2020 21:11:38 -0500

MLSWG,

Revised minutes from the first virtual interim posted at the link below. If you find an issue, submit a PR to Github:
https://github.com/mlswg/wg-materials/blob/master/virtual-interim-recurring/01-29-2020.md
In one week, I will post the final minutes to the IETF site.

Draft minutes for the second virtual interim posted at the link below. If you find an issue, submit a PR to Github:
https://github.com/mlswg/wg-materials/blob/master/virtual-interim-recurring/02-05-2020.md

spt

> On Jan 29, 2020, at 16:38, Nick Sullivan <nick=[email-masked]> wrote:
> 
> MLSWG,
> 
> Draft minutes from the productive first virtual interim posted below. If you find an issue, submit a PR to Github:
> https://github.com/mlswg/wg-materials/blob/master/virtual-interim-recurring/01-29-2020.md
> 
> Nick & Sean
> 
> >>>
> Attendees:
> Joel Alwen, Richard Barnes, Raphael Robert, Britta Hale, Brendan McMillion, Nick Sullivan
> 
> #247 - Welcome confirmation and key derivation
> * Fixes bugs RLB found in the last draft while implementing
> * OK to merge after rebase / conflict resolution
> 
> #246 - Bugfixes in ClientInitKey, Commit, and Welcome
> * Derives the Welcome encryption key instead of generating fresh
> * ... under the general theory about not requiring freshness when not necessary
> * OK to merge after rebase / conflict resolution
> 
> #283 - Use the same ratchet for Handshake and Application keys
> * There's no point to FS for Proposals because clients have to cache the plaintext anyway
> * Given that, the "flat derivation" approach should be fine
> * We should have separate keys per sender to it easier to avoid nonce collisions
> * RLB and RR to decide whether we should derive nonces on a hash ratchet or just use a counter
> 
> #287 - Switch to signing strategy using one signature per leaf.
> * There was agreement among those on the call to proceed with this strategy (tree-hash-covers-parent-hash)
> * ... given the deniability concerns and unclear benefit of the alternative (parent-hash-covers-tree-hash)
> * If further considerations come to light from analysis, we can revisit later
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls

---

From: Sean Turner <[email-masked]>
Date: Wed, 12 Feb 2020 20:59:20 -0500

MLSWG,

Draft minutes* available for the 3rd virtual interim at the link below. As before, if you find an issue please submit a PR to Github:
https://github.com/mlswg/wg-materials/blob/master/virtual-interim-recurring/02-12-2020.md

spt

* Thanks to rlb.

> On Feb 11, 2020, at 21:11, Sean Turner <[email-masked]> wrote:
> 
> MLSWG,
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 18 Feb 2020 19:58:18 -0500

I have upload the 1st 3 interim virtual meeting minutes to the IETF datatrack.

spt

> On Feb 12, 2020, at 20:59, Sean Turner <[email-masked]> wrote:
> 
> MLSWG,
>