Subject: [mmox] XML way loosely typed?

From: Catherine Pfeffer <[email-masked]>
Date: Wed, 25 Feb 2009 13:51:53 +0100

Tom wrote:
> Apologies if I missed the answer if it was in an earlier message...
>
> The "XML way" message appears to be loosly typed. How could a parser
create an object from that
> XML data and know the difference between an integer and a float, or a UUID
and a string?

>From the associated schema.

The schema is the place where you usually declare the data types in the XML
world.

-- 
Cathy

---

From: [email-masked]
Date: Wed, 25 Feb 2009 09:53:00 -0800 (PST)

thanks, it wasnt clear to me that this example was dependant on a schema.

--Tom

________________________________
From: Catherine Pfeffer <[email-masked]>
To: [email-masked]
Sent: Wednesday, February 25, 2009 4:51:53 AM
Subject: [mmox] XML way loosely typed?

Tom wrote:
> The "XML way" message appears to be loosly typed. How could a parser create an object from that
> XML data and know the difference between an integer and a float, or a UUID and a string? 

>From the associated schema.

The schema is the place where you usually declare the data types in the XML world.

-- 
Cathy