Subject: Re: [mmox] mmox Digest, Vol 1, Issue 73

From: "[email-masked]" <[email-masked]>
Date: Sun, 22 Feb 2009 11:49:51 GMT

>I word my statements to provide the meaning in intend. when i say  
"there are no protocols being considered by this group that would  
REQUIRE the abandonment of the transport of permissions metadata," i  
say it because there are, in fact, no protocols being considered by  
this group that would REQUIRE the abandonment of the transport of  
permissions metadata. What LL blog post are you talking about? Perhaps  you have me confused with someone else (enh. it's an easy mistake.)

Transport of permissions metadata is not the same thing as implementing those permissions on another grid. Do you get credit for having transported the metadata if the other grid doesn't implement it? Will you not have as a marker of trustworthyness of a grid its willingness to accept *and implement* metadata for permissions?

No, Infinity. I don't have you confused with some other Linden. The blog post is here:
http://blog.secondlife.com/2008/07/08/ibm-linden-lab-interoperability-announcement/

In it, we find *the only thing LL has ever said formally about its intentions on permissions*. It says:

"Linden Lab will not design a system that lets people openly violate the permissions of SL goods and take them to other worlds. We recognize that intellectual property is the engine that drives Second Life, and we are completely committed to preserving the qualities that make Second Life the unique, innovative and dynamic place that it is today."

It's corporate-speak. And while it says LL "will not design a system that lets people openly violate the permissions" (hey, thanks!) it does *not* say "LL will design a system that prevents people from violating the permissions". Difference! You're committed? Great! Now could we hear the engineering plan for preserving that, er, dynamism involved in IP?

I think it's a valid question to ask. After all, LL allowed its code to be reverse-engineered in 2006 despite a rule in the TOS that this was not allowed.

>But yes, we won't be working on a protocol that mandates them UNLESS  there is unanimous consent that all implementers want to transport  
permissions metadata via OGP (or whatever we wind up calling it) and  
there is unanimous consent that the second life model for permissions  
metadata is appropriate for all implementors.

This strikes me as odd and inflexible. Who says there has to be unanimous consent? Isn't the Internet supposed to be a place where you can pick or chose? Are you saying that if the SL clone OpenSim decides 
it will refuse to transport permissions metadata that you'll drop this demand, and cease attempts to secure permissions metadata merely because one of eight or 250 or how many virtual worlds there are vetos it? Why? Is this another one of those 0/1 or 100 percent or nothing perfection types of technical demands superimposed on to governance affairs that ought not to work in such an inflexible matter?

In the world of the "Internet copy machin" and the SL copy bot environment, creators are happy if they get 67 percent protection, not 100  percent, and they don't wish to abandon the 67 percent by declaring 100 percent is impossible.

>TLS  is _the_ standard used to protect your credit card numbers and it's  perfectly legitimate within the context of a TLS protected message stream to NOT USE ANY ENCRYPTION WHATSOEVER!!!!!!

I'd like to hear a second opinion on this. When I see someone emotionally all-capping and exclamation-pointing a proposition, I don't see science, I see religion.

>In short... just because a standard says you can shoot yourself in the foot... honestly... you don't have to. When you have a protocol where not all options make sense for all participants, you generally see people develop policies with names  like "interoperability profiles" or "interop policy." These policies detail which options are allowed and which are forbidden, and under what conditions.

But if you decide in advance that just because one player among all the virtual worlds says that they don't feel like transporting metadata for permissions you won't adopt it as a value, then it sounds like there isn't any flexibility whatsoever. Just because one platform dumped IP, the rest couldn't insist on upholding its implementation even as a choice.

>So why make broken protocols?
TLS_RSA_WITH_NULL_MD5 is not evidence of brokenness, it is evidence of 
flexibility. There are many situations where encryption is not needed  
but origin integrity is. In some of these situations, the use of  
encryption is actually counter-productive.

I wouldn't know. That sounds like a political opinion. I'd like to hear more about this. I wonder why origin integrity gets to be invoked, but receiving integrity matters not. While it may feel like what is transferred among worlds is just a stream of numbers to you, to users, the code feels like real tables, houses, water, sky, etc. And the attitude toward them is different, and if they are created then the artists might like more care than NULL put over it.

>you MAY use a ciphersuite with a NULL cipher.

This sounds like something I'd never want a hotel manager to be telling me.

>And so it is with permissions meta-data. It is highly likely we will  
produce one or more protocols that do not even mention it. 

Yes, that's what I'm concerned about.

>and this is why it is not a failure to define a protocol without permissions meta-data. just because one protocol doesn't define it doesn't mean another one won't. and just because a suite of protocols doesn't define it, doesn't mean it won't be used in some implementations of the protocol.

Sounds like now permissions have become a mere module to tack on as an afterthought. When that is how it is conceived, rather than embedded into the system as a forthright recognition of the importance of economies to virtual worlds, then it seems like we are in an eternal sandbox.

>so.. you want world of warcraft, penguin cafe, qwaq, there.com, sony  
home, eve online, osgrid, etc. to all use the second life permissions  
system instead of the one they made for their user base because you  
may one day want to use those worlds?
good luck.

So...I'm supposed to wheel into Azeroth in my Scion and set up a picnic table and a barbecue and throw some steaks on the grill and then invite the orcs for a picnic? Perhaps we can cuddle on the blanket? 

I'm hardly the only participant in this list who is just not getting this notion of melding versimilitude worlds with fantasy realms. I haven't heard any user base in WoW agitating for SL avatars  to invade their war game, and the WoW players of SL aren't clamouring to be able to make armour in SL and port it into WoW...oops, they can't do that because there is *no user generated content* in WoW unless you consider player strategies in meta-games like DKP, etc. as UGC (which I do, but its non-inventoriable content). One can imagine that perhaps some light client or "window" into a quest in WoW could be interesting or useful while someone was simultaneously in SL, kind of camming in, but the intensity of the WoW quest would preclude wishing to go camming into other worlds and spaces. You don't need interoperability. You have Windows. You tab the window down? And go in the other game. Takes a second. Worlds for Windows, by Microsoft.

So it's false to invoke a) non-UGC games like WoW and b) worlds where protection is achieved, like There.com, through the central committee. What's operative here are the SL clone worlds or worlds emerging that might have a similar principle of UGC. So then, I don't get this strange reticence to embrace and promote the essential, best core of SL, which is the ability of people to easily make, share, and sell content with a very easy and understood and widely accepted c/m/t permissions system. Again, I can only repeat the question: why is it good enough for SL but not good enough for the Metaverse at large? If it is not good for the Metaverse, why is it still in SL? Some temporary Leninist NEP, is it, until another revenue source is developed (like domain names or licenses to hook up to the asset server?) 

>again. this is not the forum for this discussion. this is a forum for 
people who are implementing virtual worlds software. and honestly,  
your participation here is puzzling to me as you have publicly equated 
the IETF with a BDSM cult.

Let me tell you two words: Facebook TOS.
http://uk.reuters.com/article/technologyNewsMolt/idUKTRE51H6V820090218

People who implement virtual worlds software, like people who implement social media software, can no longer expect to do this in isolation, and without accountability to, those who they are making it *for*. The reason the call it virtual *world* is because *it's a world with people in it*. The reason they call it social media is because it's *social*. So you cannot develop in isolation from the stakeholders in these worlds and spaces. They are not mere customers you can hold at arm's length while you sell a product as a vendor; interoperability begins at home, between the platform provider and the users.

Your "puzzlement" is typical of what I call the Geeks' Forced Migration Policy, as it implies: "If you don't like it, leave." Like America, "Love it or leave it". That's silly. Governance of software is not like an opensource project where you disagree and make a fork. That culture inhibits the free consensus that is needed for further development of the 3D Internet.

Yes, I have compared the rigid, arcane, extensive, oppressive rules and rituals and hive-mind humming of IETF as "like" BDSM culture in this regard: it puts you in the wrong at every turn. You can never understand *enough* about it. Journalists who try to report on it end up "scarred". They are always incorrect, and always needing yet more indoctrination. The atmosphere is not one of liberal democratic discourse, where one can agree or disagree or criticize or support, it's one in which there is only the double-plus-good promotion of the positive proposal and the "yes" vote and never a "no" vote. Whatever "necessity" there is about having this kind of culture to develop code or technical standards and I'm not sure in fact it's a necessity even there) it is not a necessity and is even an obstacle in the development of socialware, which ought to be the third thing after hardware and software in which the customer feedback, the laymen's concerns, are constantly incorporated as a matter of course, and not just tacked on at the end of the process. 

>huh? where do you get this? 

I read what you wrote. And my question stands: why uphold c/m/t in your own world if you do not wish to support it elsewhere?

>but again... this is not a forum managed by Linden Lab and it is not a forum devoted to Linden Lab's policies. if you have a problem with Linden's policies, please use the appropriate channel. IETF != Linden Lab.

If Linden Lab's policies are universalized by becoming a standard, they are the business of the Metaverse at large and not merely a customer service problem for your own grid. Sorry, but I reject the Linden "channelling" approach to dismiss issues on a public forum of this nature.

____________________________________________________________
Get important data to help make informed decisions.
http://thirdpartyoffers.juno.com/TGL2141/fc/BLSrjpTHIsWCzPr4ZKRD95AACAfPAcApfbx6uav0fIglcT0buMBAZvJIa68/

---

From: Dan Olivares <[email-masked]>
Date: Mon, 23 Feb 2009 14:57:51 -0500

A few arguments that need discussing in the last letter;

"Linden Lab will not design a system that lets people openly violate
the permissions of SL goods and take them to other worlds. We
recognize that intellectual property is the engine that drives Second
Life, and we are completely committed to preserving the qualities that
make Second Life the unique, innovative and dynamic place that it is
today."

Your interperetation of this statement is simply your interpretation.
My interperetation is, "We acknowledge that intellectual property is
important in secondlife and we'll do what we can to protect it.".  It
also leaves them a liability protection disclaimer for people who
violate IP that Linden Lab has not discovered.  As a company, they
need to provide themselves that to protect from being sued. As other
people and yourself have said, most components of the current
permission system of easily bypassed by people who have a strong
interest in doing so (Ref: Second Inventory, Copybot, etc).

>I'd like to hear a second opinion on this. When I see someone emotionally all-capping and exclamation-pointing a proposition, I don't see science, I see religion.
Here's more evidence to confirm what Infinity is saying:
http://en.wikipedia.org/wiki/Secure_Sockets_Layer

>>may one day want to use those worlds?

"players of SL aren't clamouring to be able to make armour in SL and
port it into WoW...oops, they can't do that because there is *no user
generated content* in WoW "
This would seem to argue against what you are saying.  If there's no
user generated content in WoW, then they also don't require a
permission system.

" Let me tell you two words: Facebook TOS.
http://uk.reuters.com/article/technologyNewsMolt/idUKTRE51H6V820090218 "
Once again, vailed threat with no evidence that Linden Lab will
abandon the permission system.

"People who implement virtual worlds software, like people who
implement social media software, can no longer expect to do this in
isolation, and without accountability to, those who they are making it
*for*. The reason the call it virtual *world* is because *it's a world
with people in it*. The reason they call it social media is because
it's *social*. So you cannot develop in isolation from the
stakeholders in these worlds and spaces. They are not mere customers
you can hold at arm's length while you sell a product as a vendor;
interoperability begins at home, between the platform provider and the
users."
People have developed software in the open for quite a few years now
as is evidenced by the fact that anyone can join an IETF working
group.  All IETF standards have been this way.  Additionally, you take
part in this group.   Open Source software development has always been
open.  Most accept patches from the general population and have
mailing lists or internet chat rooms where the social and technical
aspects of the work is discussed.  So, I postulate that it isn't the
social media that's been kept out.  It's the social media that hasn't
been interested.

"Your "puzzlement" is typical of what I call the Geeks' Forced
Migration Policy, as it implies: "If you don't like it, leave." Like
America, "Love it or leave it". That's silly. Governance of software
is not like an opensource project where you disagree and make a fork.
That culture inhibits the free consensus that is needed for further
development of the 3D Internet." -
Over generalization.  See the history of Apache and most other GPL
licensed application.

Yes, I have compared the rigid, arcane, extensive, oppressive rules
and rituals and hive-mind humming of IETF as "like" BDSM culture in
this regard: it puts you in the wrong at every turn. You can never
understand *enough* about it. Journalists who try to report on it end
up "scarred". They are always incorrect, and always needing yet more
indoctrination. The atmosphere is not one of liberal democratic
discourse, where one can agree or disagree or criticize or support,
it's one in which there is only the double-plus-good promotion of the
positive proposal and the "yes" vote and never a "no" vote. Whatever
"necessity" there is about having this kind of culture to develop code
or technical standards and I'm not sure in fact it's a necessity even
there) it is not a necessity and is even an obstacle in the
development of socialware, which ought to be the third thing after
hardware and software in which the customer feedback, the laymen's
concerns, are constantly incorporated as a
 matter of course, and not just tacked on at the end of the process.
Whatever concerns you have with the IETF process, please contact them
about it so the process can be improved upon.  It really isn't subject
matter for this working group

Best Regards

Dan

On Sun, Feb 22, 2009 at 6:49 AM, [email-masked]
<[email-masked]> wrote:
> Yes, I have compared the rigid, arcane, extensive, oppressive rules and rituals and hive-mind humming of IETF as "like" BDSM culture in this regard: it puts you in the wrong at every turn. You can never understand *enough* about it. Journalists who try to report on it end up "scarred". They are always incorrect, and always needing yet more indoctrination. The atmosphere is not one of liberal democratic discourse, where one can agree or disagree or criticize or support, it's one in which there is only the double-plus-good promotion of the positive proposal and the "yes" vote and never a "no" vote. Whatever "necessity" there is about having this kind of culture to develop code or technical standards and I'm not sure in fact it's a necessity even there) it is not a necessity and is even an obstacle in the development of socialware, which ought to be the third thing after hardware and software in which the customer feedback, the laymen's concerns, are constantly incorporated as a
>  matter of course, and not just tacked on at the end of the process.
>
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox
>