Subject: Re: [mmox] mmox Digest, Vol 1, Issue 171

From: "[email-masked]" <[email-masked]>
Date: Sat, 28 Feb 2009 01:27:20 GMT

I think that's putting the cart before the horse. The use cases define 
what we actually need to work towards. If there is no use case for a 
feature, that means there's no reason to implement it, because nobody 
will use it. Meanwhile, if you don't have use cases, then you can't 
tease out what things you actually ought to be building.
Note that use cases are all about *what* you build, though -- not *how* 
you build it, which I feel is what you're trying to get at.
De-coupling and separability (as you describe) are all very useful 
traits in a technical design, but are all about the "how," not the 
"what."

Sincerely,

Jon,

I agree that you need to cite a robust list of use cases before you start building interoperability; it's this abstraction, and decoupling of interoperability from authentic uses that rapidly leads to destruction of existing authentic uses.

However, I didn't understand your list of use cases as "uses". They seemed to me like "function cases". I realize there may be some very narrow technical understanding of what a "use case" is. But when you listed them, I couldn't see their actual *purpose* with an agent, an action, and an outcome -- a use.

For example, you talked about the *functionality* of being able to come into a world and track an avatar's movements. But what is this *use*? What is is *for*? Is it for enabling a state's military or intelligence services to gain access to multiple virtual worlds easily and track people's behaviour, with an aim to preventing terrorism, let's say? Or it is for someone to decide where the hot spots are on their grid to lay out the traffic better and make sure avatars don't face obstacles in their travels or whatever. In other words, the enabling an entity to track avatars across multiple worlds is a function, not a use because the purpose isn't explicit.

By the same token, the man who ports the scene into another man's world to show him. He could be a pirate sucking the content out of a world with original content and showing it to others to sell, or he could be making the blueprint of a hospital emergency room and showing it to doctors on another platform in another country for their input. That is, functionality has different uses -- you could call usage stripped of content and meaning a "use case" but it's worth being explicit, because if the basic reason we're all getting together here to interoperate and merge world capacities is for governments to make it easier to engage in surveillance where people increasingly spend their time, why are we making that easier as a technical proposition without some due process and democratic deliberation about why that might need some check gates on it? Or the same with the pirating. Why make a system that endlessly ports back and forth "scenes" (which are artwork and content, after all) and sucks all the content out of worlds where people produce original work, and merely hand it over to others to sell in other worlds -- again, with no technical check gate.

Prokofy Neva

____________________________________________________________
Solve paternity questions with expert DNA testing. Click now!
http://thirdpartyoffers.juno.com/TGL2141/fc/BLSrjpTKPABlBom8isv5wEaJAKVGuY1dMnsVKDHHj7Zt3gQlldPvRJMXhss/

---

From: Jon Watte <[email-masked]>
Date: Fri, 27 Feb 2009 22:48:39 -0800

> However, I didn't understand your list of use cases as "uses". They seemed to me like "function cases". I realize there may be some very narrow technical understanding of what a "use case" is. But…

I actually think I'm pretty clear in what the use is in each case.

Quoting from the use case page (http://www.interopworld.org/mmox-use-cases):

Use case "Friend invite":
  "User A wants user B to visit him/her in system/world A"
This means that the use of interoperability is that user A gets a visit 
from user B who uses a different world -- it's a social interaction. 
Presumably, user A values the interaction with user B.

Use case "Collborative Training":
  "company A and city B agree to connect their worlds for a defined 
duration to conduct a training excercise"
This means that the use of interoperability is that two different 
organizations can collborate for a defined benefit (training in a 
geo-specific locale) that could not be done without interoperability. 
The value is the increase in readiness and disaster preparedness.

Use case "Scene Transfer":
  "user decides to donate that prototype to an organization that uses 
virtual world system B"
This means that the use of interoperability is that development work 
done in one world is re-used in another world, assuming permissions 
allow it. The value of this use is increased leverage of work, and the 
converse lowered cost of the output of work.

Use case "Analysis":
  "The product from ISV A can be connected to any virtual world "
This means that the use of interoperability is that software can be 
developed and re-used on many worlds. The value is the increased 
leverage of work, and the converse lowered cost of the output of work.

Use case "Data Logger"
  "the data logger tool can be seen as a separate "virtual world peer" 
and connected to by any virtual world "
The use case here is that I can present data recorded from one virtual 
world to any virtual work user, regardless of platform. The value is the 
ability to analyze virtual world interactions post-facto, as well as 
preserve historical records.

For the definition of "leverage of work," "social interaction," "value" 
etc, I defer to classical economics, online dictionaries, general 
education etc.

Sincerely,

jw

> By the same token, the man who ports the scene into another man's world to show him. He could be a pirate sucking the content out of a world with original content and showing it to others to sell, or he could be making the blueprint of a hospital emergency room and showing it to doctors on another platform in another country for their input. That is, functionality has different uses -- you could call usage stripped of content and meaning a "use case" but it's worth being explicit, because if the basic reason we're all getting together here to interoperate and merge world capacities is for governments to make it easier to engage in surveillance where people increasingly spend their time, why are we making that easier as a technical proposition without some due process and democratic deliberation about why that might need some check gates on it? Or the same with the pirating. Why make a system that endlessly ports back and forth "scenes" (which are artwork and content, after al
>  l) and sucks all the content out of worlds where people produce original work, and merely hand it over to others to sell in other worlds -- again, with no technical check gate.
>
> Prokofy Neva
>
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox
>
>