Subject: [mmox] MMOX Group Charter

From: Charles Krinke <[email-masked]>
Date: Sat, 21 Feb 2009 10:40:44 -0800 (PST)

I am reading the group charter again at : 

http://trac.tools.ietf.org/bof/trac/wiki/MmoxCharter

I guess the action item for the near term is to make this charter as acceptable as possible to gain some credence from the IETF?

Do I get that right? Is this our main action item at this point?

Charles

---

From: Gareth Nelson <[email-masked]>
Date: Sat, 21 Feb 2009 18:58:54 +0000

That appears to be the general consensus on what the current priority is, yes

On Sat, Feb 21, 2009 at 6:40 PM, Charles Krinke <[email-masked]> wrote:
> I guess the action item for the near term is to make this charter as
> acceptable as possible to gain some credence from the IETF?
>
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox
>
>

---

From: Gareth Nelson <[email-masked]>
Date: Sat, 21 Feb 2009 19:00:53 +0000

Looking again, this is very very OGP-biased, is this not something we
ought to correct?

---

From: Yesha Sivan <[email-masked]>
Date: Sat, 21 Feb 2009 21:45:51 +0200

Could someone send a reference to what is OGP?

--Yesha

Dr. Yesha Y. Sivan, http://www.dryesha.com; Connecting Real and Virtual
Worlds.

---

From: [email-masked]
Date: Sat, 21 Feb 2009 12:48:03 -0800 (PST)

Open Grid Protocol is the result of the effort between Linden Lab, IBM, and OpenSim (and other interested parties) to define a protocol to allow interaction between virtual worlds.

http://wiki.secondlife.com/wiki/Open_Grid_Protocol

Regards,
Tom Hoff

________________________________
From: Yesha Sivan <[email-masked]>
To: Gareth Nelson <[email-masked]>
Cc: [email-masked]
Sent: Saturday, February 21, 2009 11:45:51 AM
Subject: Re: [mmox] MMOX Group Charter

--Yesha

Dr. Yesha Y. Sivan, http://www.dryesha.com; Connecting Real and Virtual Worlds.

---

From: Morgaine <[email-masked]>
Date: Sat, 21 Feb 2009 23:01:09 +0000

> http://trac.tools.ietf.org/bof/trac/wiki/MmoxCharter

That's the original draft, #1.  We're now at iteration #4, which is
available in this post:
http://www.ietf.org/mail-archive/web/mmox/current/msg00066.html .  The
changes have been extremely important, particularly in respect of vendor
neutrality.

I've chronicled the group's work on the charter up to draft #4 in this post
here:  http://www.ietf.org/mail-archive/web/mmox/current/msg00349.html

Further improvements are of course welcome and necessary.  I'll try to keep
people's versions chronicled, as the various mailers in use are playing
havoc with the threading so finding the passage of the draft through our
contributions is like picking up broken glass.

I'm also maintaining a page of useful MMOX links outside IETF space which
some might find helpful here:  https://wiki.secondlife.com/wiki/MMOX .
Under *MMOX Workgroup Charter Drafts*  you can find links to the various
iterations that we have made so far, as well as links to my chronicling
posts.

Morgaine.

---

From: Marshall Eubanks <[email-masked]>
Date: Sat, 21 Feb 2009 18:02:43 -0500

On Feb 21, 2009, at 6:01 PM, Morgaine wrote:

> available in this post:  http://www.ietf.org/mail-archive/web/mmox/current/msg00066.html 
>  .  The changes have been extremely important, particularly in  
> respect of vendor neutrality.
>

Can't you update the wiki version ?

Regards
Marshall

> I've chronicled the group's work on the charter up to draft #4 in  
> this post here:  http://www.ietf.org/mail-archive/web/mmox/current/msg00349.html
>
> Further improvements are of course welcome and necessary.  I'll try  
> to keep people's versions chronicled, as the various mailers in use  
> are playing havoc with the threading so finding the passage of the  
> draft through our contributions is like picking up broken glass.
>
> I'm also maintaining a page of useful MMOX links outside IETF space  
> which some might find helpful here:  https://wiki.secondlife.com/wiki/MMOX 
>  .  Under MMOX Workgroup Charter Drafts  you can find links to the  
> various iterations that we have made so far, as well as links to my  
> chronicling posts.
>
>
> Morgaine.

---

From: Morgaine <[email-masked]>
Date: Sat, 21 Feb 2009 23:05:08 +0000

> Looking again, this is very very OGP-biased, is this not something we

It's already been corrected --- I wrote this post for you this morning, you
may recall:  http://www.ietf.org/mail-archive/web/mmox/current/msg00349.html
:-)

Morgaine.

---

From: Morgaine <[email-masked]>
Date: Sat, 21 Feb 2009 23:25:01 +0000

> Can't you update the wiki version ?

I don't know. :-)

I've asked for clarification of the rules on IETF draft update policy, but
haven't received an answer yet.  Clearly it would be far easier to let the
IETF wiki do the history management, and far easier on the eye to look at
wiki pages than emails, but I cannot proceed (even if I obtained a wiki
login) until I know the rules.

Morgaine.

On Sat, Feb 21, 2009 at 11:02 PM, Marshall Eubanks <[email-masked]>wrote:

>  I've chronicled the group's work on the charter up to draft #4 in this
>> post here:
>> http://www.ietf.org/mail-archive/web/mmox/current/msg00349.html
>>
>> Further improvements are of course welcome and necessary.  I'll try to
>> keep people's versions chronicled, as the various mailers in use are playing
>>  Under MMOX Workgroup Charter Drafts  you can find links to the various

---

From: Jon Watte <[email-masked]>
Date: Sat, 21 Feb 2009 16:11:17 -0800

Morgaine wrote:
> which some might find helpful here:  
> https://wiki.secondlife.com/wiki/MMOX .  Under *MMOX Workgroup Charter 
> Drafts*  you can find links to the various iterations that we have 
> made so far, as well as links to my chronicling posts.

Can we please move to a Wiki that doesn't require a Second Life login to 
edit?

Sincerely,

jw

---

From: Charles Krinke <[email-masked]>
Date: Sat, 21 Feb 2009 16:25:07 -0800 (PST)

I see nothing wrong with Morgaine using her companies wiki for her companies draft proposals.

I would say, Jon, that you could use your companies wiki for your companies draft proposals and it would be entirely fair.

As I understand the process, there is a revision to the draft proposal which is on the secondlife wiki now at https://wiki.secondlife.com/wiki/MMOX and it is the one labeled draft #4. I also understand this "charter draft" does not mention LLSD or OGP at all and in reading it, it seems reasonable.

Charles Krinke
OpenSim Core Developer
http://opensimulator.org
OSGrid Director

http://osgrid.org

________________________________
From: Jon Watte <[email-masked]>
To: Morgaine <[email-masked]>
Cc: Charles Krinke <[email-masked]>; [email-masked]
Sent: Saturday, February 21, 2009 4:11:17 PM
Subject: Re: [mmox] MMOX Group Charter

Morgaine wrote:
> I'm also maintaining a page of useful MMOX links outside IETF space which some might find helpful here:  https://wiki.secondlife.com/wiki/MMOX .  Under *MMOX Workgroup Charter Drafts*  you can find links to the various iterations that we have made so far, as well as links to my chronicling posts.

Can we please move to a Wiki that doesn't require a Second Life login to edit?

Sincerely,

jw

---

From: Morgaine <[email-masked]>
Date: Sun, 22 Feb 2009 01:18:47 +0000

I should clarify that I have nothing to do with Linden Lab whatsoever, other
than being a resident in Second Life.  That wiki is available to all SL
residents, commonly for personal wiki pages --- it is in effect a public
wiki.

Members of the AWG use this for group communication, as in the case of the
aforementioned <https://wiki.secondlife.com/wiki/MMOX> MMOX links page that
I maintain at https://wiki.secondlife.com/wiki/MMOX.  There is no Linden Lab
involvement in this, although of course they are welcome to improve the page
if they wish, as is everyone else.

Morgaine.

On Sun, Feb 22, 2009 at 12:25 AM, Charles Krinke <[email-masked]> wrote:

> I would say, Jon, that you could use your companies wiki for your companies
> draft proposals and it would be entirely fair.
>
> As I understand the process, there is a revision to the draft proposal
> which is on the secondlife wiki now at
> https://wiki.secondlife.com/wiki/MMOX and it is the one labeled draft #4.
> I also understand this "charter draft" does not mention LLSD or OGP at all
> and in reading it, it seems reasonable.
>
> Charles Krinke
> OpenSim Core Developer
> http://opensimulator.org
> OSGrid Director
> http://osgrid.org
>
> ------------------------------
> *From:* Jon Watte <[email-masked]>
> *To:* Morgaine <[email-masked]>
> *Cc:* Charles Krinke <[email-masked]>; [email-masked]
> *Sent:* Saturday, February 21, 2009 4:11:17 PM
> *Subject:* Re: [mmox] MMOX Group Charter
>
> Morgaine wrote:

---

From: Charles Krinke <[email-masked]>
Date: Sat, 21 Feb 2009 17:24:56 -0800 (PST)

My apologies, Morgaine. I was reacting more to the negative connotations about SecondLife in the first place. Personally, I find SecondLife to be a fine virtual world with an interesting, sometimes eclectic group. Plus, I find lots of interesting business, educational, government and scientific sims there also.

I flubbed the company connotation, Morgaine and walk around with a virtual sackcloth and ashes.

Charles

________________________________
From: Morgaine <[email-masked]>
To: Charles Krinke <[email-masked]>
Cc: Jon Watte <[email-masked]>; [email-masked]
Sent: Saturday, February 21, 2009 5:18:47 PM
Subject: Re: [mmox] MMOX Group Charter

I should clarify that I have nothing to do with Linden Lab whatsoever, other than being a resident in Second Life.  That wiki is available to all SL residents, commonly for personal wiki pages --- it is in effect a public wiki.

Members of the AWG use this for group communication, as in the case of the aforementioned MMOX links page that I maintain at https://wiki.secondlife.com/wiki/MMOX.  There is no Linden Lab involvement in this, although of course they are welcome to improve the page if they wish, as is everyone else.

Morgaine.

Charles Krinke
OpenSim Core Developer
http://opensimulator.org
OSGrid Director

http://osgrid.org

Sincerely,

jw

---

From: Lawson English <[email-masked]>
Date: Sat, 21 Feb 2009 18:55:03 -0700

Charles Krinke wrote:
> My apologies, Morgaine. I was reacting more to the negative 
> connotations about SecondLife in the first place. Personally, I find 
> SecondLife to be a fine virtual world with an interesting, sometimes 
> eclectic group. Plus, I find lots of interesting business, 
> educational, government and scientific sims there also.
>

Prim or mesh-based?

Lawson

---

From: Kajikawa Jeremy <[email-masked]>
Date: Sun, 22 Feb 2009 10:54:06 +0900

Im willing to setup a custom Wiki on my appengine account using an
  own-login-session schema if thats appropriate?

Im actually working on such things already though I do admit to being
 slow with coding (being a persistently pedant about details when
coding)

Sincerely,
  Jeremy

---

From: Morgaine <[email-masked]>
Date: Sun, 22 Feb 2009 02:39:28 +0000

> I flubbed the company connotation, Morgaine and walk around with a virtual

Haha, no harm done.  And you do look rather fetching in that outfit. ;-)

Morgaine.

On Sun, Feb 22, 2009 at 1:24 AM, Charles Krinke <[email-masked]> wrote:

> My apologies, Morgaine. I was reacting more to the negative connotations
> about SecondLife in the first place. Personally, I find SecondLife to be a
> fine virtual world with an interesting, sometimes eclectic group. Plus, I
> find lots of interesting business, educational, government and scientific
> sims there also.
>
> *From:* Morgaine <[email-masked]>
> *To:* Charles Krinke <[email-masked]>
> *Cc:* Jon Watte <[email-masked]>; [email-masked]
> *Sent:* Saturday, February 21, 2009 5:18:47 PM
> I should clarify that I have nothing to do with Linden Lab whatsoever,
> other than being a resident in Second Life.  That wiki is available to all
> SL residents, commonly for personal wiki pages --- it is in effect a public
> wiki.
>
> aforementioned <https://wiki.secondlife.com/wiki/MMOX> MMOX links page
> that I maintain at https://wiki.secondlife.com/wiki/MMOX.  There is no
> Linden Lab involvement in this, although of course they are welcome to
> improve the page if they wish, as is everyone else.
>
> Morgaine.
>
>
>
>> I would say, Jon, that you could use your companies wiki for your
>> companies draft proposals and it would be entirely fair.
>>
>> Drafts*  you can find links to the various iterations that we have made so
>> far, as well as links to my chronicling posts.
>>

---

From: "Meadhbh Hamrick (Infinity)" <[email-masked]>
Date: Sat, 21 Feb 2009 22:10:37 -0800

well.. it isn't a canonical page.

On Feb 21, 2009, at 4:11 PM, Jon Watte wrote:

>>  .  Under *MMOX Workgroup Charter Drafts*  you can find links to  
>> the various iterations that we have made so far, as well as links  
>> to my chronicling posts.
>

---

From: "Meadhbh Hamrick (Infinity)" <[email-masked]>
Date: Sat, 21 Feb 2009 23:50:03 -0800

and if we do our job right, you'll be able to teleport between SL to  
OSGrid and still be wearing that virtual sackcloth.

On Feb 21, 2009, at 5:24 PM, Charles Krinke wrote:

> I should clarify that I have nothing to do with Linden Lab  
> whatsoever, other than being a resident in Second Life.  That wiki  
> is available to all SL residents, commonly for personal wiki pages  
> --- it is in effect a public wiki.
>
> Members of the AWG use this for group communication, as in the case  
> of the aforementioned MMOX links page that I maintain at https://wiki.secondlife.com/wiki/MMOX 
> .  There is no Linden Lab involvement in this, although of course  
> they are welcome to improve the page if they wish, as is everyone  
> else.
>
> Morgaine.
>
>
>
> As I understand the process, there is a revision to the draft  
> proposal which is on the secondlife wiki now at https://wiki.secondlife.com/wiki/MMOX 
>  and it is the one labeled draft #4. I also understand this "charter  
> draft" does not mention LLSD or OGP at all and in reading it, it  
> seems reasonable.
>
> Charles Krinke
> OpenSim Core Developer
> http://opensimulator.org
> OSGrid Director
> http://osgrid.org
>
> > I'm also maintaining a page of useful MMOX links outside IETF  
> space which some might find helpful here:  https://wiki.secondlife.com/wiki/MMOX 
>  .  Under *MMOX Workgroup Charter Drafts*  you can find links to the

---

From: Gareth Nelson <[email-masked]>
Date: Sun, 22 Feb 2009 12:30:29 +0000

For some odd reason I thought the wiki was  more authorative than the
mailing list ;)

On Sat, Feb 21, 2009 at 11:05 PM, Morgaine
<[email-masked]> wrote:
> may recall:
> http://www.ietf.org/mail-archive/web/mmox/current/msg00349.html  :-)
>
>
> Morgaine.
>

---

From: Jon Watte <[email-masked]>
Date: Sun, 22 Feb 2009 10:35:02 -0800

Charles Krinke wrote:
> https://wiki.secondlife.com/wiki/MMOX and it is the one labeled draft 
> #4. I also understand this "charter draft" does not mention LLSD or 
> OGP at all and in reading it, it seems reasonable.
>

You mean, apart from this part?

October 2009  Publication of LLSD Draft as an Informational RFC

It's right there, among the list of goals in the message linked to as 
"draft #4."

Sincerely,

jw

---

From: Jon Watte <[email-masked]>
Date: Sun, 22 Feb 2009 10:41:32 -0800

Morgaine wrote:
> Members of the AWG use this for group communication, as in the case of 
> the aforementioned MMOX links page that I maintain at 
> https://wiki.secondlife.com/wiki/MMOX.  There is no Linden Lab 
> involvement in this, although of course they are welcome to improve 
> the page if they wish, as is everyone else.

So you think that "becoming a Second Life resident" is not an 
unreasonable requirement for someone participating in an open standards 
effort?

Sincerely,

jw

---

From: Morgaine <[email-masked]>
Date: Mon, 23 Feb 2009 10:57:28 +0000

On Sun, Feb 22, 2009 at 6:41 PM, Jon Watte <[email-masked]> wrote:

>> aforementioned MMOX links page that I maintain at
> So you think that "becoming a Second Life resident" is not an unreasonable
> requirement for someone participating in an open standards effort?
>
>
I think someone's making a mountain out of a molehill. ;-)

There is no "document" at that URL that anyone needs to reference.  It's
just a page of links, partly to make our scattered posts defining versions
#2, #3 and #4 of the draft charter more accessible, and exactly the same
information on that matter is available in my MMOX post here:
http://www.ietf.org/mail-archive/web/mmox/current/msg00349.html

But you know that already, since the wiki page is publicly accessible.

If the complaint is about write access, then whichever wiki one uses would
still require a login to be registered.  What's the difference between
getting a wiki login from Linden Lab or from any other provider?  It doesn't
force you to use Second Life, and it doesn't cost anything.  And Lindens
aren't evil, generally. ;-)  A better complaint would be to ask why the IETF
doesn't provide a wiki for IETF groups to use directly, other than
(apparently) indirectly via chairs and ADs.

Seriously, it's a molehill, and I think we have bigger fish to fry.

Morgaine.