Subject: Re: [mmox] mmox Digest, Vol 1, Issue 163

From: Chris Down <[email-masked]>
Date: Fri, 27 Feb 2009 17:13:09 +0000

This did not get to the list and therefore I am including your complete 
email in my reply and keep my comments short.

I do not intend to carry on this thread as
(a) It does not really belong on this list
(b) You are obviously not interested in anyone's point of view but your 
own.

I have given you some friendly advice and you choose to criticise and 
ignore it. You twist peoples replies and are deliberately obtuse.

On 27/02/2009 15:53, [email-masked] wrote:
> I'm going to answer this on the list as I think off-list admonishments are inappropriate.
>
>> You seem to object to open source and I don't understand why. I use both closed an opensource products and I have no objection to paying for the closed source products I use as long as I get support for that product.
>
> I object to opensource exclusivity and the collectivist and forced-sharing mentality that goes along with it as any kind of norm. It's not a norm. The overwhelming majority of hundreds of millions of people use Microsoft or Apple operating systems, not Linux. This is why I often say "open source=closed society" -- because of the failure to ensure there is *choice* between collectivist and proprietary software and because of the notion that a project is "open" merely technically, although usually it is so complex and rigid in its cultural norms that it isn't really open in practice.

Uhm. MAC OSX is a layer on top of Darwin. "Darwin is an open source 
POSIX-compliant computer operating system released by Apple Inc. in 
2000. It is composed of code developed by Apple, as well as code derived 
from NEXTSTEP, FreeBSD, and other free software projects".

>> I am sure that you are aware that without opensource you would not have SecondLife. The viewer that LL wrote comprises a lot of opensource products.
>
> This notion that you cannot criticize opensource mentality without being lectured with homilies like "Don't you know the Internet wouldn't be here today" etc. is silly. So what? It's only one form of property,  not exclusively the norm, nor necessarily desirable. By itself, it does not ensure *the choice of commerce*. That's the problem.
>
>> The servers that LL use run on (openssource)Linux machines as does a large portion of the internet.
>
> And...so what? A goodly portion of the Internet *does not* run on Linuxness too. Without the commerce or the ebays and the amazons, there'd be no Internet *either*. And a large part of the consumer sector of IT *does not* run on Linux. So there. There is no need for us to genuflect constantly to the Linux cult in creating standards for the Metaverse.
>
>> People will always put forward unpopular ideas, it does not mean that
> they will be adopted. Anyone involved in SecondLife, Opensimulator or
> any any other similar product is fully aware of the necessity for a
> system that allows (secure) trading. However there are many use cases
> that this is not necessary and in fact having such a system mandated
> would cause problems.
>
> This is a peculiar proposition  indeed. Suddenly, there's an admission that concepts stripping out trading and commerce might be "unpopular". Say, there'd be a good reason for that! Because they are not the norm, nor reflective of the mass of human activity on the real world planet. The idea that in real life, you would never strip out trading or secure trading from any country unless you were way out on the extremes of say, a North Korea, doesn't seem to mitigate against your extremism. Just because there are purportedly "use cases" that dictate that trade is "not necessary" is hardly a reason to drop commerce completely from a system (I think such use cases would be in the distinct minority and your claim that there are "many" isn't proven).
You choose to deliberately misrepresent what I said.
>
> It surely is odd that I would have to stump for you all to put commerce, trade, property rights and such into a virtual world system when every single one of you on this list benefits from commerce in some fashion, if not directly by working for profit-making companies that function in the real world in free enterprise systems that make your profit from selling technology, services, or entertainment -- or from universities that exist either on taxpayers' funds generated from commerce or from private foundation grants generated from the last centuries' wealth in industries.
>
> So I can only throw that back to you, the way you constantly and speciously throw at critics this notion that "OMGODZORZ the entire Internet is based on opensource and Linux so shut up already".
>
>> What David said was "..... for the moment, I'm going to keep those terms off the table to think about the problem in its more general form."
>
> Yes, a seemingly innocent, innocuous, practical, speculative sort of proposition that is "just for the prototyping" and "just for discussion" and "just to make it easy to conceptualize".
>
> And yet I point out that it is at this moment that all the tethered terms of avatar=person, property rights, geographic contiguity (the hatred of geographic contiguity by extremists often goes with the hatred of commerce for reasons I don't yet understand), etc. all begin to lose their moorings and we enter the realm of Extropia or the Bright Future of Communism. I so marked the moment. My purpose in so marking the moment wasn't to engage in lengthy political debates on a "list just here to talk about technology please" but to point out the particular moments when decisions about social systems get welded into the technological blueprint. For you, commerce is a model and an add-on. It isn't for the overwhelming majority of users of Second Life who are utterly unintersted in opensource sandboxing but exist in a RL versimilitude of consumer creation and commerce.
>
>> To me that does not say these terms and their implications are being
> abandoned. It says we need to think in general terms before we look at
> specifics and I totally agree with this. I am not adopting any ism or
> ideology I am adopting a technique that assists it defining the outline before adding the detail and complexities that will eventually be necessary.
>
> Well, that's "to you" *shrugs*. I don't see it as "moving to general terms" but rather a profoundly disruptive, extremist, heavily ideological move, untethering the basic concepts of avatar, space, inventory, etc. from their
>
> You might say, "Good! The internet is about evolution! Embrace the inevitable! and all the other social Darwinisms we're always forced to endure from extremists. But it's not about having a political discussion. It's practical. It's saying, "Who's going to pay for this carnival ride, dude?" because you've stripped out commerce and invoked wacky notions of everybody generating soup out of stones and profit out of sharing as they goof off from their big IT jobs where they are paid for other mundane tasks.
>
>> Your arguments do not come across as logical they come across as wordy and, dare I say, aggressive.  My interpretation is that commerce, currency, property and profit are at a level of abstraction that will be considered as the standards develop.
>
> Um, I'm awfully glad you have a felt need for detecting and berating aggressiveness. This is laudable on a list. I hope you will be an equal-opportunity applier of this laudable goal to the many other aggressive statements made on the list by people with decidedly ambitious agendas.
>
> Commerce, currency, property and *gasp* profit (the horrah!) are not abstractions, not tack-on modules, not afterthoughts, but should be at the heart of the system. If they aren't, you no longer have choice. You've scrubbed them out of the DNA at the start. That's wrong. The tack-on modules should be the minority worlds that want to have endless tekkie sandboxing and sharing. Not a single one of the opensim projects has any viable population; those that even have any participation have put in some form of commerce, even with their own internal currency.
>
>> Why would you think I was situated at the extreme? Nothing I said in my email suggested that. My point of view is that in this (virtual)world there is room for people at the copyleft end of the spectrum and at the "I am only in it for the money" plus all sahdes in between. I have a potential application for a virtual world, it will be a completely closed environment and it will not need any currency, trading or IP protection but will require interop between other instances of the application. I will earn my money/profit from the products I sell that are used with the application.
>
> You are situated at the extreme if you are unwilling to put in a list of the basic ingredients of a virtual world at the start the functions of trade, commerce, currency etc. that reflect an inherent proposition of private property. Why is that so scary? It ought to be normal in the course of things. Every single MMORPG designer in the entire universe puts trade and inventory and currency into their game without a blink of the eye. What happens to virtual world makers that they get all weird about doing this?!
>
> I fail to see, if you have an application for a closed non-currency, non-copyright world that interoperability with other worlds that *do* have currency and copyright would present any sort of problem, unless of course you were expecting them to pour all their content for free, without permissions, and without payment, into your world. It ought to be obvious from plenty of real-life examples and from the examples of incidents we already see happening with these virtual worlds: if you lay down a system of capitalism, a system of socialism can fork off from it; if you lay down a system of communism, a system of capitalism cannot fork off from it.
>
>> I agree with you here and what I am saying is (trying to be diplomatic) it is not necessarily what you say that is putting people off it is the way that you say it. It can come across as slightly aggressive and intimidating. I am not trying to offend you I am only trying to express my concern.On this list, I suggest that it may be better to put your views forward in a more succinct and logical manner.
>
> Once again, you're suggesting that there is something inherently illogical or logically fallacious about calling for commerce, currency, capitalism. But the illogic comes in fact with demanding the opposite.
>
>> Leave your other views on opensource and techno communism for your blog and we will all get along fine :-)
>
> I fail to see why I have to be driven off to my blog as if I've raised something completely wacky -- like the concept of Extropianism itself overrepresented on this list. It's very important for someone to speak up at the outset of the interoperability exercise and point out that choices are being lost, options are being stripped out, forced marches are being flogged because of a few who showed up, under the tyranny of those who show up, to insist on their own extremist vision. We're already suffering from that problem with the AWG/OGP which began their work by questioning the viability of currency in the design documents and raising a storm of questions about intellectual property.
>
> It's important to come out of the code cave and realize that virtual worlds are for masses of people. Masses of people don't like living under technocommunism. It's a closed niche that is attractive only for some. They are entitled to that choice. They should not impose it on everyone else.

Chris

---

From: Kajikawa Jeremy <[email-masked]>
Date: Sat, 28 Feb 2009 07:21:42 +0900

I agree with you on this one Chris...

"dyerbrookme"/"Pokofy Neva"... I am utterly surprised by how
disconnected
  some of your statements appear to be with regards conversations on
this list.

TCP/IPv4 supports commerce... does it have any commercial functions
inside the
  protocol?...  from my understanding NONE...

TCP is limited scope to a reliable transport,  UDP is best-effort
unreliable,
  IP and ICMP is framing for the above to work on a commonality...

I see this list as endeavouring to provide a TCP or UDP hosted mechanism
  that is application specific forms of these protocols for allowing
objects
  to have both OSS and Commercial backing...

is an object transferred containing "commercial" content? yes/no
  Whichever... as long as it is transferable or otherwise able to have a
money
  transaction connected for those interested in money.

This list is remaining a *technical* discussion and we are trying to
remain
 "option open" with future proofing the protocol in-use...

My own proposal to this list was to have any object encoding allow
arbitrary
  extensible attributes attached to an ObjectID...  each VW may allow
the OID
  to be remapped as long as the attributes in full remain together.

with regards your anti-FOSS commentary... I don't care what you believe
in
  as long as your input is /*constructive*/ or proposing a mechanism
that
  does not detract or otherwise limit the functionality your welcome to
participate

I don't expect you to read this far or otherwise think about what Ive
said,
  I am treating this message akin to UDP.

All:  apologies for the long message...

  so far we have "3d space" for location provided by each system
  needing "object" creation/deletion/set/get updates...

  and we have need of "set"ting "motion".

I propose the standard have both UDP and TCP style messages in 2 queues
  the UDP or "throwaway" messages for updating movement.

The option for selecting an object as being "Avatar" or representing a
person.

using extending attributes like this for some machine readable and
allowing
  for records of human readable attributes would then allow us to
distill further...
  What kind of attributes are needed?
  What kind of attributes are common?
  Do we need to mandate any "special" handling or leave that to
implimentors?

Thats it for this braindump... Im just trying to keep up with this list
as another
  amateur with interest...

On Fri, 2009-02-27 at 17:13 +0000, Chris Down wrote:
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox