Subject: Re: [mmox] mmox Digest, Vol 1, Issue 113

From: "[email-masked]" <[email-masked]>
Date: Tue, 24 Feb 2009 01:41:09 GMT

But all virtual worlds are a "representation of inventory". For example, the Second Life central asset server sends the information about an object stored in its data base to me on my server and I rez out the object. It's at the level of sniffing packets, scraping parameters with hacks, etc. etc. that you can then grab that information of a texture UUID or the prim facets of furniture, etc. to then make the clone. 

____________________________________________________________
Looking for insurance?  Click to compare and save big.
http://thirdpartyoffers.juno.com/TGL2141/fc/BLSrjpTInoMo75HvoAAXqMdYPKU4MgEfTEHibVTPXD80YrlmRtL1ExKtapS/

---

From: Jon Watte <[email-masked]>
Date: Mon, 23 Feb 2009 17:53:01 -0800

[email-masked] wrote:
> But all virtual worlds are a "representation of inventory". For example, the Second Life central asset server sends the information about an object stored in its data base to me on my server and I rez out the object.

That's not actually the proposal. The proposal is that the second life 
content repository sends your inventory to a second life sim for 
"rezzing." No non-second-life server would "rez" your object. I look 
forward to your interpretation of the actual proposal, as it's currently 
being discussed. I also recommend you search this list for threads on 
"DRM" because there is a proposal there, too, that might interest you -- 
again, comments on the suitability of that proposal encouraged.

Btw: nobody has told me what "rez" actually stands for, and why that 
word would be better to use than just "instantiate."

Sincerely,

jw

---

From: Ann Otoole <[email-masked]>
Date: Mon, 23 Feb 2009 18:22:37 -0800 (PST)

From: Jon Watte <[email-masked]> Btw: nobody has told me what "rez" actually stands for, and why that word would be better to use than just "instantiate."

We will have to tie you to a chair and force you to watch Tron till you get the idea.
:)

Odds are excellent that more and more Second Life customers and
businesses will begin participating here using the SL jargon as more and
more Second Life customers and businesses are made aware of this
mailing list. This is a near certainty.

Abstraction, which means hiding irrelevant details, is a central theme in Computer Science.

"Rez" is an abstraction. 

"Rez" is one syllable word and is an acronym of sorts related to resolve as in resolve to the graphics card the appearance of an object of some sort.
Instantiate is another word with more syllables that has a definition in the dictionary. Invoked is another possible object oriented jargon candidate.

Jon will now "rez" a prim that has a script in it and then click the prim to cause the script to trigger it's on_touch() event.
Jon will now instantiate a 3D mesh, apply a texture bake, and then invoke it's methods to...

Same thing.

How is this: There are millions of people that use the colloquial slang word rez to mean what your use of your formal word instantiate means.
I'm confident we can tie our efforts up with arguments over acronyms and jargon if that is the purpose of the effort.

Nothing stopping anyone from creating an acronym cross reference as one of several necessary appendices though.

Bottom Line: Instantiate is in the dictionary. However it is possible "rez" will be in wikipedia before too long thus formalizing it as acceptable to the programmer generation.

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 23 Feb 2009 21:25:51 -0500

Can people please not use "Digest" to label threads ?

Regards
Marshall

On Feb 23, 2009, at 8:41 PM, [email-masked] wrote:

> But all virtual worlds are a "representation of inventory". For  
> example, the Second Life central asset server sends the information  
> about an object stored in its data base to me on my server and I rez  
> out the object. It's at the level of sniffing packets, scraping  
> parameters with hacks, etc. etc. that you can then grab that  
> information of a texture UUID or the prim facets of furniture, etc.  
> to then make the clone.
>
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox

---

From: Jon Watte <[email-masked]>
Date: Mon, 23 Feb 2009 19:42:25 -0800

Ann Otoole wrote:
> **Jon will now "rez" a prim that has a script in it and then click the 
> prim to cause the script to trigger it's on_touch() event.

Once you know the intended meaning of the word, right.

To quote a recent internal discussion from OLIVE world: "When the 
dobrepo sobs the thob, the foreman will activate schema based on path 
bindings to DPM props."

Yes, every word there has a specific and clear meaning to those who work 
with the OLIVE SDK, but I try to avoid using that kind of language in 
the external world. I'm not for or against specific words, but I am for 
clear and unequivocal communication, and if the target audience is 
unknown, a dictionary tends to be a good starting point.

And btw: it's not a "grid," it's a "world instance" running on a 
"cluster" :-)

Sincerely,

jw

---

From: Lawson English <[email-masked]>
Date: Wed, 25 Feb 2009 10:12:14 -0700

Jon Watte wrote:
> Ann Otoole wrote:
>> **Jon will now "rez" a prim that has a script in it and then click 
>> the prim to cause the script to trigger it's on_touch() event.
> Yes, every word there has a specific and clear meaning to those who 
> work with the OLIVE SDK, but I try to avoid using that kind of 
> language in the external world. I'm not for or against specific words, 
> but I am for clear and unequivocal communication, and if the target 
> audience is unknown, a dictionary tends to be a good starting point.
>

The AWG debated the use of grid for a while. Its obviously SL-centric 
since few other platforms have nice neat rectangular grids of 
simulators. Your terminology is better I think; although, since SL 
simulators can form contiguous "land masses" it's not quite accurate either.

A "world graph" just doesn't have the right feel...

L