Subject: Re: [mmox] mmox Digest, Vol 1, Issue 33

From: "[email-masked]" <[email-masked]>
Date: Sat, 14 Feb 2009 18:26:23 GMT

Re: >So, I think it's fine to say that "any interoperability standard must address content metadata, including authorship, ownership and sharing rights," but I don't think that mandating specific technical solutions (like specific DRM solutions) would be fruitful.

Jon, those of us who are merchants and landlords supporting merchants in Second Life get all this -- it's been explained literally thousands of times by the technical experts of SL. We all get that if you see it -- and you need to stream it to see it -- you can copy it, one way or another. That's all abundantly understood. The problem comes with a disagreement, based on that reality, of what you do next -- throw up your hands and say nothing can be done and cave to copyleftism, or create at least some deterrent or some permissions regime that at least mitigates the problem. 

The question is how you build in a response to the problem of theft of IP in *3-D social software* which you cannot treat in the same way as other kinds of 2-D software merely running applications in the background for wordprocessing and other functions *because people are literally inhabiting it in an immersive, 3-D environment*. They expect more of a versimilitude to real-life in such environments, and in fact, there are plenty of examples of 2-D software with licensing and permissions to support that. And just because music-sharing is removing DRM and going to other models doesn't mean that all content production and sale in virtual worlds has to follow lockstep the same solutions.

What that means is when you say "metadata" should be built in, the question then comes: how, and *as what*? Your invocation of the There model, which involve having users submit all their content to be cleared -- and then implicitly IP-secured -- by the platform provider -- hasn't been operational or acceptable in SL which has a free, non-clearance system for content creation -- you don't have to submit to the company, you just use the tools to make stuff. Currently, the SL system has three kinds of permission checkoff boxes you can select on anything you make: copy/mod/transfer. If you don't check off the boxes for "copy" or "transfer" at least for the ordinary user, not employing hacks or exploits, your work cannot be physically copied or transferred. It isn't some elaborate digital rights management, but it is a workable one that helps the *social* task of deterring theft because it readily conveys in embedded code form the maker's intent. It is widely respected. That *is* the metadata. It isn't just showing the avatar's name who created the object

What's happened with some of the more extreme AWG members in SL is that they've called for junking this metadata showing intent within objects as indefensible. They don't want to bother porting it into standards or other worlds beyond SL. They are basically just telling people either to tack a Creative Commons notecard on to their product or to call their lawyers if their IP is violated -- which it often is in the opensourced reverse-engineered worlds based on SL. But people interested in protecting IP without making creators jump through hoops and expenses like that fail to see why the metadata of a created object cannot include that regime of the 3 permission checkoffs. It simply is immaterial if coders see technically that this is crackable; they are inhabiting the 2-D world of the coder and his concerns; what matters is in the integral 3-D world of the user -- which you cannot hide from as a coder in a virtual world -- that at least some physical deterrent is produced against rampant theft, so that when theft *does* take place, you have a marker, you can can display that a hack was used in defiance of the obvious permissions regime inworld.

Prokofy Neva

____________________________________________________________
Click here to find the perfect banking opportunity!
http://thirdpartyoffers.juno.com/TGL2141/fc/PnY6rw3AeR5l0tqa89HGwlQyJJb5V2kCCxU5fg1XwaioHgrJphDSV/

---

From: Jon Watte <[email-masked]>
Date: Wed, 18 Feb 2009 13:34:33 -0800

[email-masked] wrote:
> What that means is when you say "metadata" should be built in, the question then comes: how, and *as what*? Your invocation of the There model, which involve having users submit all their content to be cleared -- and then implicitly IP-secured -- by the platform provider -- 

That's a great question, and something that needs to be answered by the 
standard, when it appears. My initial suggestion was that it include 
authorship information, sharing right information (copylefted, 
copyrighted, time trial, and probably other models) and finally 
intermediate storage information (is a server allowed to cache the data 
for the possibility it's used in the future? What about clients?)

In general, copyright is very well understood, and is not treated 
differently in the eyes of US law in the digital world from the physical 
world. For example, the source for textures, or the source for a mesh, 
is generally copyrighted. However, that doesn't necessarily prevent me 
from building (from scratch) something that looks very similar, but it 
does tell me that I can't just take your stuff verbatim. Tagging digital 
assets with metadata, which includes licensing terms, is common sense, 
and is done with almost all digital media formats. I see no reason why 
virtual world standards would be any different.

If, for some reason, the sharing of content through interoperability is 
against someone's wishes as a creator, then I would assume that some 
platforms would implement platform-specific means to prevent content 
from being shared over the interoperability channel, and users who cared 
about interoperability would choose not to purchase that content. 
Creators would then choose their platform, and their specific use of 
that platform, according to how they feel would best serve their 
interests. I don't think that needs to be mandated in an 
interoperability specification.

Now, what users, and other systems, do with the metadata information is, 
to some extent, not controllable from the standard. The standard may say 
"copyright restrictions must be enforced within the user interface of a 
conforming implementation" -- but that doesn't mean much. An 
implementation may be non-conforming, or tools that rip data from hard 
disks can still exist, so it won't be a magic panacea.

Sincerely,

jw