Subject: [mmox] Conversions in an heterogeneous grid

From: Catherine Pfeffer <[email-masked]>
Date: Wed, 25 Feb 2009 14:13:38 +0100

Infinity wrote:
> <pdutastic>
>   <foo type="integer">13</foo>
>   <bar type="date">2008-12-15T13:17:23.235Z</bar>
>   <baz type="integer">93</baz>
>   <qux type="integer">161</qux>
> </pdutastic>

Now consider :
<pdutastic
      foo="13"
      bar="2008-12-15T13:17:23.235Z"
      baz="93"
      qux="161" />

Nothing prevents you here from converting 2008-12-15T13:17:23.235Z into an
integer percentage (zero) using the same conversion rules that are currently
in the LLSD specification (you get expected and sent types from the
schemas), or even, which is simpler, by using a "any-string to integer"
conversion.

-- 
Cathy

---

From: "Meadhbh Hamrick (Infinity)" <[email-masked]>
Date: Wed, 25 Feb 2009 09:43:29 -0800

there are no conversions between date and integer in the current draft  
of LLSD.

On Feb 25, 2009, at 5:13 AM, Catherine Pfeffer wrote:

> Nothing prevents you here from converting 2008-12-15T13:17:23.235Z  
> into an integer percentage (zero) using the same conversion rules  
> that are currently in the LLSD specification (you get expected and  
> sent types from the schemas), or even, which is simpler, by using a  
> "any-string to integer" conversion.
>
> -- 
> Cathy
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox