Subject: [mmox] Agenda for 3/24 MMOX BoF

From: "Meadhbh Hamrick (Infinity)" <[email-masked]>
Date: Fri, 6 Mar 2009 14:44:53 -0800

What:

MMOX BoF - Birds of a Feather session for the proposed "Massively  
Multi-Participant Online X { X : X = 'applications' ∨ 'games' }"  
working group

Time / Space:

*	Tuesday, 24 March, 2009 ( 15:20 - 17:00 ) @ Continental 1&2
*	More info on IETF 74 @ http://www.ietf.org/meetings/74/
*	Check http://tools.ietf.org/agenda/74 for changes

BoF Chairs:

Meadhbh Hamrick <[email-masked]>
Barry Leiba <[email-masked]>

Agenda:

0:00 - 0:10 :	Introduction / Blue Sheets / Agenda Bashing
0:10 - 0:15 :	Rationale for Original Charter
0:15 - 0:35 :	Discussion of Technical Proposals
0:15 - 0:20 : 	LLSD ( http://tools.ietf.org/html/draft-hamrick-llsd-00 )
0:20 - 0:25 :	LESS ( http://tools.ietf.org/html/draft-jwatte-less-protocol-01 
  )
0:25 - 0:30 :	OGP Base & Auth ( http://tools.ietf.org/html/draft-lentczner-ogp-base-00 
  and http://tools.ietf.org/html/draft-hamrick-ogp-auth-00 )
0:30 - 0:35 :	VP-Identity ( http://www.ietf.org/proceedings/staging/draft-wolf-vp-identity-00.txt 
  )
0:35 - 0:50 :	Concepts
0:35 - 0:40 :	Architectural Models (including discussion of http://tools.ietf.org/html/draft-cscholz-mmox-architecture-00 
  )
0:40 - 0:50 :	Security Ramifications
0:50 - 1:05 :	Charter Bashing (including discussion of http://tools.ietf.org/html/draft-jwatte-mmox-use-cases-00 
  and http://www.ietf.org/proceedings/staging/draft-ietf-mmox-problem-00.txt 
  )
1:05 - 1:35 :	Open Discussion and Q & A
1:35 - 1:40 :	Next Steps

Documents for Review:

*	http://tools.ietf.org/html/draft-hamrick-llsd-00
*	http://tools.ietf.org/html/draft-jwatte-less-protocol-01
*	http://tools.ietf.org/html/draft-lentczner-ogp-base-00
*	http://tools.ietf.org/html/draft-hamrick-ogp-auth-00
*	http://www.ietf.org/proceedings/staging/draft-wolf-vp-identity-00.txt
*	http://tools.ietf.org/html/draft-cscholz-mmox-architecture-00
*	http://tools.ietf.org/html/draft-jwatte-mmox-use-cases-00
*	http://www.ietf.org/proceedings/staging/draft-ietf-mmox-problem-00.txt

---

From: "Meadhbh Hamrick (Infinity)" <[email-masked]>
Date: Fri, 6 Mar 2009 14:56:11 -0800

What:

Time / Space:

BoF Chairs:

Agenda:

15:20 - 15:30 (:05) 	Introduction / Blue Sheets / Agenda Bashing
15:30 - 15:35 (:10) 	Rationale for Original Charter
15:35 - 15:55 (:20) 	Discussion of Technical Proposals
15:35 - 15:40 (:05)	LLSD ( http://tools.ietf.org/html/draft-hamrick-llsd-00 
  )
15:40 - 15:45 (:05) 	LESS ( http://tools.ietf.org/html/draft-jwatte-less-protocol-01 
  )
15:45 - 15:50 (:05)	OGP Base & Auth ( http://tools.ietf.org/html/draft-lentczner-ogp-base-00 
  and http://tools.ietf.org/html/draft-hamrick-ogp-auth-00 )
15:50 - 15:55 (:05)	VP-Identity ( http://www.ietf.org/proceedings/staging/draft-wolf-vp-identity-00.txt 
  )
15:55 - 16:10 (:15)	Concepts
15:55 - 16:00 (:05)	Architectural Models (including discussion of http://tools.ietf.org/html/draft-cscholz-mmox-architecture-00 
  )
16:00 - 16:10 (:10)	Security Ramifications
16:10 - 16:25 (:15)	Charter Bashing (including discussion of http://tools.ietf.org/html/draft-jwatte-mmox-use-cases-00 
  and http://www.ietf.org/proceedings/staging/draft-ietf-mmox-problem-00.txt 
  )
16:25 - 16:55 (:30)	Open Discussion and Q & A
16:55 - 17:00 (:05)	Next Steps

Documents for Review:

*	http://www.ietf.org/proceedings/staging/draft-ietf-mmox- 
problem-00.txt

---

From: Tammy Nowotny <[email-masked]>
Date: Sat, 07 Mar 2009 09:53:38 -0500

Meadhbh Hamrick (Infinity) wrote:
> Meadhbh Hamrick <[email-masked] <mailto:[email-masked]>>
> Barry Leiba <[email-masked] <mailto:[email-masked]>>
>
>

But, but... clock time in this case is the global standard, i.e., Linden 
Time!  I don't understand... <joking>

Seriously, though, Linden Time is not the global standard.  The standard 
is UTC, which some of us might know better as GMT or Zulu Time.   Time 
zones may be worth addressing in the standards.  I don't know if you 
would want to mandate that all virtual worlds should operate on UTC 
(although I think SL should do so), but you definitely should specify 
how to relate the VW's time to UTC.  That would include the issue of 
daylight saving time--- as you know here in the USA, we are starting 
daylight saving back up tomorrow since most Americans and Canadians have 
used up all the daylight they saved up last summer.  In other parts of 
the northern hemisphere, daylight saving starts later because North 
Americans have been using up their daylight faster than other northern 
peoples--- and of course many people live in the southern hemisphere and 
have a surplus of daylight at the moment because it is late summer down 
there, not late winter :-)

---

From: Charles Krinke <[email-masked]>
Date: Sat, 7 Mar 2009 07:50:13 -0800

Time is always a fun one, Tammy.

To those who provide software only, such as OpenSim, Wonderland, Croquet,
Fortrerra, others, time may be less important that to those that operate
virtual worlds such as SecondLife, OSGrid, There.com, others.

On OSGrid & OpenSim mailing lists, the consensus seems to be "UTC" in
general. There are folks with specialized grids using OpenSim for corporate
purposes inside firewalls that seem to prefer to use the server time zone.

So, ... I would concur that UTC makes the most sense. But, ... I also have
to say that MMOX might want to have an offset from UTC for flexibility.

This is, of course, with all due respect to LindenLab and SLT.

Charles Krinke
OpenSim Core Developer
OSGrid Director

On Sat, Mar 7, 2009 at 6:53 AM, Tammy Nowotny <[email-masked]> wrote:

> Multi-Participant Online X { X : X = 'applications' ∨ 'games' }" working
> group
>
>  Time / Space:
>
> Seriously, though, Linden Time is not the global standard.  The standard is
> UTC, which some of us might know better as GMT or Zulu Time.   Time zones
> may be worth addressing in the standards.  I don't know if you would want to
> mandate that all virtual worlds should operate on UTC (although I think SL
> should do so), but you definitely should specify how to relate the VW's time
> to UTC.  That would include the issue of daylight saving time--- as you know
> here in the USA, we are starting daylight saving back up tomorrow since most
> Americans and Canadians have used up all the daylight they saved up last
> summer.  In other parts of the northern hemisphere, daylight saving starts
> later because North Americans have been using up their daylight faster than
> other northern peoples--- and of course many people live in the southern
> hemisphere and have a surplus of daylight at the moment because it is late
> summer down there, not late winter :-)
>
>
> _______________________________________________
> mmox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmox
>
>

-- 
Charles Krinke
OpenSim Core Developer
OSGrid Director

---

From: Marshall Eubanks <[email-masked]>
Date: Sat, 7 Mar 2009 11:09:16 -0500

On Mar 7, 2009, at 10:50 AM, Charles Krinke wrote:

> To those who provide software only, such as OpenSim, Wonderland,  
> Croquet, Fortrerra, others, time may be less important that to those  
> that operate virtual worlds such as SecondLife, OSGrid, There.com,  
> others.
>
> On OSGrid & OpenSim mailing lists, the consensus seems to be "UTC"  
> in general. There are folks with specialized grids using OpenSim for  
> corporate purposes inside firewalls that seem to prefer to use the  
> server time zone.
>

My recommendation is not to reinvent the wheel with time issues -  
mistakes are almost inevitable. Use UTC, and
remember that leap seconds can have either sign.

Regards
Marshall

> So, ... I would concur that UTC makes the most sense. But, ... I  
> also have to say that MMOX might want to have an offset from UTC for  
> flexibility.
>
> But, but... clock time in this case is the global standard, i.e.,  
> Linden Time!  I don't understand... <joking>
>
> Seriously, though, Linden Time is not the global standard.  The  
> standard is UTC, which some of us might know better as GMT or Zulu  
> Time.   Time zones may be worth addressing in the standards.  I  
> don't know if you would want to mandate that all virtual worlds  
> should operate on UTC (although I think SL should do so), but you  
> definitely should specify how to relate the VW's time to UTC.  That  
> would include the issue of daylight saving time--- as you know here  
> in the USA, we are starting daylight saving back up tomorrow since  
> most Americans and Canadians have used up all the daylight they  
> saved up last summer.  In other parts of the northern hemisphere,  
> daylight saving starts later because North Americans have been using  
> up their daylight faster than other northern peoples--- and of  
> course many people live in the southern hemisphere and have a  
> surplus of daylight at the moment because it is late summer down

---

From: "Meadhbh Hamrick (Infinity)" <[email-masked]>
Date: Sat, 7 Mar 2009 15:03:00 -0800

we're using time local to the event, which in this case will be the  
same as linden time.

it's a respected tradition in aviation and IETF meetings.

meetings held in upcoming locations (stockholm and hiroshima, for  
instance) will, if they follow this tradition, use time local to those  
events.

---

From: Kajikawa Jeremy <[email-masked]>
Date: Sun, 8 Mar 2009 20:10:52 +0900

Then what is the local time vector from UTC or GMT?

can those be optionally included when refering to time for allowing
each local system
  to run a local clock and only need lookup a current TZ vector from
GMT or UTC ?

Jeremy

On Sun, Mar 8, 2009 at 8:03 AM, Meadhbh Hamrick (Infinity)
<[email-masked]> wrote:
> we're using time local to the event, which in this case will be the same as
> linden time.
> meetings held in upcoming locations (stockholm and hiroshima, for instance)
> will, if they follow this tradition, use time local to those events.