Subject: [MMUSIC] RE: Last Call: Support for IPv6 in SDP to Proposed Standard

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 31 Jan 2002 09:05:27 +0100

I think Gonzalo already answered this. 
Further clarifications are below, but 
we might be getting off-topic for this draft.

   > (this way the receiving IPv6 node can decide the mechanism 
  > >   > to reach the 
  > >   > IPv4-address; that is, if u= can contain either IPv4 or 
  > >   > IPv6 address)
  > 
  > I'll restate this: this depends on the definition of u=.
  > 
  > If 'u' can have:
  >  1) only IPv6 addresses, using mapped address is fine
  >  2) either iPv6 or IPv4 address, IMO IPv4 should be used 
  > when _sending_ 
  > the packet

=> See below.

  > 
  > We're arguing about point 2).  My point is that if address 
  > can be either,
  > some nodes [a dual stack] can receive values with u=[ipv4] 
  > _anyway_, and
  > must be able to cope with them.

=> I was not conerned about dual stacked nodes,
they'll obviously understand. Some systems
require IPv6 only though, Others might prefer
to run IPv6 only for simplicity, so you shouldn't 
assume dual stacks all the time.

Hesham

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 31 Jan 2002 22:35:36 +0200

Hi,

The draft defines how to express IPv6 addresses in SDP. How you use this
format is up to the application (i.e., outside the scope of this draft).
Remember that SDP is used by many protocols (SIP, SAP, MGCP, RTSP). 

A good example is SIP. An MMUSIC document defines how to use SDP in
conjunction with SIP. 3G systems, for instance, will use SDP and IPv6
together. They will define how to use this format when establishing a
session. They will explicitly say which address you have to put in the c
line (IPv4, or IPv6 or maybe FQDN).

Therefore, comments about the actual format are very welcome. Other
comments are interesting for other documents, but I do not think the
IESG has to be involved in such a discussion until those documents are
done. 

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]