Subject: [MMUSIC] Request for IANA 'gfmtp' registry

From: "Rajesh Kumar" <[email-masked]>
Date: Wed, 14 Aug 2002 17:45:41 -0700

Dear MMUSIC colleagues,

I have submitted  the following application to the IANA for a new registry
where subparameters of the 'gfmtp' SDP attribute  may be registered. This
parameter is defined in
http://search.ietf.org/internet-drafts/draft-rajeshkumar-mmusic-gfmtp-02.txt
and will, most likely, be part of the ITU V.150.1 modem relay standard.

The reason why 'gfmtp'  should not be registered simply as an SDP attribute
is that in the IANA SDP registry it is not possible to add sub-parameters of
the 'gfmtp'  attribute (such as vbd=on/off) in the same way as new
attributes can be added. The attribute 'fmtp' which is similar to 'gfmtp'
does not have this problem because its subparameters are covered under MIME
registrations.

Please advise, correct and guide.

Thanks,

Rajesh

 | -----Original Message-----
 | From: [email-masked] [mailto:[email-masked]]
 | Sent: Wednesday, August 14, 2002 5:07 PM
 | To: [email-masked]; [email-masked]
 | Subject: General Request for Assignments
 |
 |
 | Contact Name :
 | Rajesh Kumar
 |
 | Contact Email :
 | [email-masked]
 |
 | Type of Assignment :
 | A new registry for the values of the SDP 'gfmtp' attribute. A
 | new registry is needed since new sub-parameters and their values
 | may be defined.
 |
 | Registry :
 | A new registry is needed since new sub-parameters and their
 | values may be defined. The SDP parameters registry allow the
 | additon of attributes that are statically defined in a standards
 | specification.
 |
 | Description :
 | There may be generic parameters (such as the boolean VBD) that
 | may be applied across the board to a number of formats, and are
 | not an integral part of the MIME definition of any particular
 | format. For these, the 'fmtp' attribute in RFC 2327 may not be
 | applied. A new SDP attribute, 'gfmtp' is defined for these, per
 | the recommendation of the IETF MMUSIC group. Since the
 | sub-parameters of the 'gfmtp' parameter are not part of any MIME
 | definition, a new registry is needed for vendors to define
 | sub-parameters for it in an interoperable manner.
 |
 | Additional Info :
 | draft-rajeshkumar-mmusic-gfmtp-02.txt defines the concept and
 | its history.
 | This parameter is being standardized in the ITU V.150
 | specification which addressed modem relay. Contact:Keith Chu,
 | Chairperson TIA TR-30.1, 949 579 4121 [email-masked]
 |
 |

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Wed, 14 Aug 2002 22:40:54 -0400

Rajesh,

This request should be included as part of the "IANA Considerations"
section of draft-rajeshkumar-mmusic-gfmtp-02.txt draft, rather than 
being submitted separately. 

Colin Perkins
MMUSIC co-chair