Subject: RE: [MMUSIC] video media control draft

From: "Even, Roni" <[email-masked]>
Date: Tue, 6 Aug 2002 08:59:51 +0300

Hi Petri,
In my draft draft-even-mmusic-video-media-control-00.txt, I have a
video-resolution attribute that allow to specify the maximum frame rate
supported per resolution. In the meeting this attribute was accepted for
SDP. I could not find the draft mentioned "draft-koskelainen-sdp263-02.txt"
Thanks
Roni Even

> -----Original Message-----
> From: Petri K. Koskelainen [mailto:[email-masked]]
> Sent: Monday, August 05, 2002 6:45 PM
> To: [email-masked]
> Subject: [MMUSIC] video media control draft
> 
> 
> 
> Hi,
> 
> That draft works only for H.263 codec so it is not
> a general solution. Moreover, using SDP a line 
> to express options (or group of options and 
> complex restrictions) is very difficult.
> 
> In the setup phase, you could advertize your
> codec capabilities (in SDP), so it
> is possible to change options during a call
> without further signaling. But I guess
> it makes sense to inform also signaling level
> about the change (since e.g. bandwidth requirement 
> may change considerably if you change options).
> 
> 
> Petri
> 
> -----------------------------
> 
> Hello,
> 
> Th draft I mentioned in a previous mail
> "draft-koskelainen-sdp263-02.txt" deals with SIZE and OPTIONS of video
> codec. How do you propose the manage them during a call.
> 
> All thoses things are in the stream itself, but, a Video UA need a way
> to express them during the initiation of the call and to control them
> during the call.
> 
> Thanks,
> 
> Patrick,
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Nils Henrik Lorentzen <[email-masked]>
Date: Tue, 6 Aug 2002 09:34:36 +0200

On Tuesday 06 August 2002 07:59, Even, Roni wrote:

> supported per resolution.

A difference between your draft and draft-koskelainen-sdp263-02.txt is that 
in the latter you may specify resolutions and options per payload type, 
instead of per media line. I think this is more flexible, and would suit our 
needs better. Any particular reason for having it per media-line ?

In your draft it would be a simple change to make it per payload:
a=video-resolution:<size>
to
a=video-resolution: <payload no> <size>
or possibly
a=video-resolution: [ PT=<payload no>] <size>
ie payload no is optional, so if not specified the resolutions would apply to 
all the payload types on the media line.

> In the meeting this attribute was accepted for

It expired quite some time ago, but can be found at:
http://www.dmn.tzi.org/ietf/mmusic/sdp-ng/input/draft-koskelainen-sdp263-02.txt

Nils Henrik Lorentzen