Subject: RE: [MMUSIC] video media control draft

From: "Sanjoy Sen" <[email-masked]>
Date: Mon, 12 Aug 2002 18:55:27 -0500

I saw this pretty old thread. I do support proposing frame-size on a per
codec (payload-type) basis. I would also like to throw in the requirement
that we need to be able to specify the preferred media qualities (e.g., in a
scale of 0-10) per payload-type (right now SDP defines a quality attribute
per m line). Thoughts?

Does it make sense to encode all these information as part of an "fmtp"
attribute for the payload-type? - e.g., a:fmtp:<PT> res=QCIF/quality=5

-Sanjoy

> -----Original Message-----
> From: Even, Roni [mailto:[email-masked]] 
> Sent: Wednesday, August 07, 2002 1:21 AM
> To: 'Nils Henrik Lorentzen'; [email-masked]; Even, Roni
> Subject: RE: [MMUSIC] video media control draft
> 
> 
> Nils,
> I think your suggestion makes sense. I will update the draft Roni
> 
> > -----Original Message-----
> > From: Nils Henrik Lorentzen [mailto:[email-masked]]
> > Sent: Tuesday, August 06, 2002 10:35 AM
> > To: [email-masked]; Even, Roni
> > Subject: Re: [MMUSIC] video media control draft
> > 
> > 
> > On Tuesday 06 August 2002 07:59, Even, Roni wrote:
> > 
> > > Hi Petri,
> > > In my draft draft-even-mmusic-video-media-control-00.txt, 
> I have a 
> > > video-resolution attribute that allow to specify the
> > maximum frame rate
> > > supported per resolution.
> > 
> > A difference between your draft and
> > draft-koskelainen-sdp263-02.txt is that 
> > in the latter you may specify resolutions and options per 
> > payload type, 
> > instead of per media line. I think this is more flexible, and 
> > would suit our 
> > needs better. Any particular reason for having it per media-line ?
> > 
> > In your draft it would be a simple change to make it per payload: 
> > a=video-resolution:<size> to
> > a=video-resolution: <payload no> <size>
> > or possibly
> > a=video-resolution: [ PT=<payload no>] <size>
> > ie payload no is optional, so if not specified the 
> > resolutions would apply to 
> > all the payload types on the media line.
> > 
> > > In the meeting this attribute was accepted for
> > > SDP. I could not find the draft mentioned
> > "draft-koskelainen-sdp263-02.txt"
> > 
> > It expired quite some time ago, but can be found at: 
> > http://www.dmn.tzi.org/ietf/mmusic/sdp-ng/input/draft-koskelai
> > nen-sdp263-02.txt
> > 
> > Nils Henrik Lorentzen
> > 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
>

---

From: "Andreas Kassler" <[email-masked]>
Date: Tue, 13 Aug 2002 09:49:16 +0200

RE: [MMUSIC] video media control draftSanjoy et al,
we were also concerned about the expressability of quality attributes that
defines the quality of service at application level for a given video(audio) stream. 
In draft-guenkova-mmusic-e2enp-sdpng-00.txt we basically have identified a requirement
to ... introduce (per) codec parametrization attributes like frame-rate, frame-size, color-
quality-range, overall-quality-range, etc. which should be  uniquely interpreted by the end-systems.

When it comes to negotiation of such attributes with the peer for setting up quality enhanced
media streams, we propose to specify such parameters on a per codec basis. The reason is 
that not all codecs support all combinations of such parameters. For example with a given
hardware, a sender may be able to compress at 25 fps at CIF a H.261 stream but may
not be able to compress at 25 fps at CIF a MPEG-4 stream due to limited resources.

We propose also to work on these issues within the SDPng context.

-Andreas
  ----- Original Message ----- 
  From: Sanjoy Sen 
  To: 'Even, Roni' ; 'Nils Henrik Lorentzen' ; [email-masked] 
  Sent: Tuesday, August 13, 2002 1:55 AM
  Subject: RE: [MMUSIC] video media control draft

  I saw this pretty old thread. I do support proposing frame-size on a per codec (payload-type) basis. I would also like to throw in the requirement that we need to be able to specify the preferred media qualities (e.g., in a scale of 0-10) per payload-type (right now SDP defines a quality attribute per m line). Thoughts?

  Does it make sense to encode all these information as part of an "fmtp" attribute for the payload-type? - e.g., a:fmtp:<PT> res=QCIF/quality=5

  -Sanjoy

---

From: Colin Perkins <[email-masked]>
Date: Tue, 13 Aug 2002 13:59:05 -0400

>attribute for the payload-type? - e.g., a:fmtp:<PT> res=QCIF/quality=5

No, because a=fmtp is part of the payload type definition. If we do this at
all, it should be a new attribute (there was a "generic format parameter"
attribute proposal a while back, that may be suitable).

But, really, this is something for SDPng to do right.

Colin