Subject: RE: [MMUSIC] Presenting draft-westerlund-mmusic-sdp-bwparam-00.txt

From: "Lior Sion" <[email-masked]>
Date: Wed, 16 Oct 2002 10:08:35 +0200

Hi,

Comments inline.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, October 09, 2002 10:03 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [MMUSIC] Presenting draft-westerlund-mmusic-sdp-bwparam-00.txt

Hi Magnus, 
Regarding the draft, I think it points out the current problems related to  b=AS quite well.

My comments are as follows:

- Correct me if I am wrong, but the aim is to override the b=AS: with the usage of <b=TIAS + a=prate> and possibly with RR + RS, right? I mean, if an SDP description contains b=AS at any level, then it can not contain b=TIAS also, since there can be only one bandwidth value per session or media component listed in an SDP. I think it should be a little bit clarified, whether b=AS is being killed and replaced by the usage of <b=TIAS + a=prate> + RR and RS for RTP based streaming. 

I think that under no circumstances we can remove the b=as from the proposal. Too many old software are using this feature and are relying on it
ecognize it.

- If b=TIAS is present in an SDP description, then there MUST be a=prate in the attribute list of the media components, right?

Why do you think this would be necessary?

Regards,

Lior Sion

**************************************************************************************************
The contents of this email and any attachments are confidential.
It is intended for the named recipient(s) only.
If you have received this email in error please notify the system manager or  the 
sender immediately and do not disclose the contents to any one or make copies.

** eSafe scanned this email for viruses, vandals and malicious content **
**************************************************************************************************

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 16 Oct 2002 10:29:23 +0200

Hi Lior,

Could you please get a better mail program that insert ">" or be more 
clear in what  is your comments and what is the previous writer. See 
comments below:

Lior Sion wrote:

>[Lior]
>I think that under no circumstances we can remove the b=as from the proposal. Too many old software are using this feature and are relying on it. I guess that the new b=tias would override the b=as if the client recognize it.
>
Yes, you are correct that we can't remove the b=AS. I will add 
recommendations and rules regarding b=AS in respect to b=TIAS in the 
next version.

>[Lior]

The prate attribute is required in all usage scenarios that describe a 
datagram transport, especially RTP. The reason is that otherwise it will 
be impossible to calculate the true bitrate this stream requires over 
the used transport technology. 

Regards

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]