Subject: [MMUSIC] B=AS in SDP

From: "Lior Sion" <[email-masked]>
Date: Tue, 1 Oct 2002 11:22:05 +0300

Hello,

We have a long argument about the concept of the bandwidth in the SDP (b=as line), and i would like to raise it before closure of the new SDP draft.
The question is what part of the session's bandwidth is included in this parameter - data only (no headers), data + rtp headers, or data + rtp + ip headers, rtp + rtcp, etc. 

Although I've seen all arguments in favor of adding the headers and the RTCP to this value, i can't see how this can be done. Since the client chooses the block size (using blocksize parameter in RTSP SETUP request), only then i can calculate the number of packets to be sent, and even this it's only an assumption (in mpeg4 for example, i can't be sure how many packets the server would create for each frame, due to headers boundaries). Since protocol headers (i.e., UDP) are added to each packets, total bw can not be guessed beforehand.

Moreover, at SDP stage, streaming server still doesn't know the underlying protocol. It can be TCP, UDP, etc. and this has major influence on packet sizes and header sizes per packet.

What do you think?

Lior

**************************************************************************************************
The contents of this email and any attachments are confidential.
It is intended for the named recipient(s) only.
If you have received this email in error please notify the system manager or  the 
sender immediately and do not disclose the contents to any one or make copies.

** eSafe scanned this email for viruses, vandals and malicious content **
**************************************************************************************************

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 01 Oct 2002 11:25:43 +0200

Hi Lior,

As Emre says we have had discussion on this topic before. The b=AS in 
the case that the media is transported over RTP is the bitrate of 
IP/UDP/RTP headers + payload data, not including RTCP bitrate.

I agree that it might create some unclarities in the case of streaming 
due to unknown transport, etc. There also exist more problems with this 
approach, namely the overhead for IP headers. With two versions of IP it 
gets problematic. I plan to publish a draft next week that investigates 
this problem.

But to be realistic when can't change the definition of "b=AS". What can 
be done is proposing new bandwidth modifiers that give more appropriate 
values. We should also look at how this shall be handled in SDP-NG.

Regards

Magnus Westerlund

-- 

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]