Subject: RE: [MMUSIC] error 412, Precondition Failed

From: "Lior Sion" <[email-masked]>
Date: Thu, 31 Oct 2002 14:28:30 +0200

Magnus,

If the Server-Client have some type of (even proprietary) extra-pre session init phase (in addition to the RTSP SETUP phase), that has to be included before the PLAY request (i.e., coupling extra "sub protocol" inside the RTSP, which is basically allowed), this response is valid.

I guess that examples for those protocols is easy to provide.

Regards,
Lior

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: Thursday, October 31, 2002 2:22 PM
> To: Lior Sion
> Cc: Mmusic (E-mail)
> Subject: Re: [MMUSIC] error 412, Precondition Failed
> 
> 
> Lior Sion wrote:
> 
> >Hi,
> >In RTSP RFC as well as the new version, error 412 
> (Precondition Failed) is "assigned" to DESCRIBE and SETUP 
> request. Is that for a specific reason? Why can it be a reply 
> to a PLAY request?
> >Regards,
> >Lior Sion
> >
> 
> Hi Lior,
> 
> The reason why 412 is not allowed for the other is that they are 
> connected to the request conditional headers If-Match, 
> If-Modified-Since. They are used to set a condition if the 
> media should 
> be described or set up. So they are in regard to the 
> media/resource you 
> are controlling. As this is only done during describe and 
> setup the 412 
> response is only for these method.
> 
> Do you have any use case that falls within the definition of 
> 412 in RFC 
> 2616, chapter 10.4.13 that can occur in a PLAY request? In that case 
> please inform us and we can correct this if necessary.
> 
> Regards
> 
> Magnus Westerlund 
> 
> Multimedia Technologies, Ericsson Research ERA/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 
> 
> 
> 

**************************************************************************************************
The contents of this email and any attachments are confidential.
It is intended for the named recipient(s) only.
If you have received this email in error please notify the system manager or  the 
sender immediately and do not disclose the contents to any one or make copies.

** eSafe scanned this email for viruses, vandals and malicious content **
**************************************************************************************************

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 31 Oct 2002 14:06:47 +0100

Lior,

If a server has an extension proprietary or not, that extension should 
include the specification that 412 shall be used for responses when it 
isn't meet. I don't think allowing 412 on all methods is warrant, given 
the current RTSP base specification. A base spec implementation has no 
reason to implement and allow for 412 response in other methods then 
SETUP and DESCRIBE.

Any other comments on this issue? However, thank you for bring up this, 
I think other values in that table are wrong, for example 457 (Invalid 
Range) is also allowed for PAUSE.

Regards

Magnus

-- 

Magnus Westerlund