Subject: RE: [MMUSIC] Presenting draft-westerlund-mmusic-sdp-bwparam-00.txt

From: [email-masked]
Date: Wed, 16 Oct 2002 11:23:56 +0300

Hi Lior,
Comments inlined:

> -----Original Message-----
> From: ext Lior Sion [mailto:[email-masked]]
> Sent: 16. October 2002 11:09
> To: Aksu Emre (NMP/Tampere); [email-masked]
> Cc: [email-masked]
> Subject: RE: [MMUSIC] Presenting
> draft-westerlund-mmusic-sdp-bwparam-00.txt
> 
> 
> Hi,
> 
> Comments inline.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 09, 2002 10:03 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [MMUSIC] Presenting 
> draft-westerlund-mmusic-sdp-bwparam-00.txt
> 
> 
> Hi Magnus, 
> Regarding the draft, I think it points out the current 
> problems related to  b=AS quite well.
> 
> My comments are as follows:
> 
> - Correct me if I am wrong, but the aim is to override the 
> b=AS: with the usage of <b=TIAS + a=prate> and possibly with 
> RR + RS, right? I mean, if an SDP description contains b=AS 
> at any level, then it can not contain b=TIAS also, since 
> there can be only one bandwidth value per session or media 
> component listed in an SDP. I think it should be a little bit 
> clarified, whether b=AS is being killed and replaced by the 
> usage of <b=TIAS + a=prate> + RR and RS for RTP based streaming. 
> 
> I think that under no circumstances we can remove the b=as 
> from the proposal. Too many old software are using this 
> feature and are relying on it
> ecognize it.
> 

Yes, I agree. I also had a syntactical concern, and Magnus made it clear that more than one "b=" attribute can be listed one after another in the same line. So, no problems.

> - If b=TIAS is present in an SDP description, then there MUST 
> be a=prate in the attribute list of the media components, right?
> 
> Why do you think this would be necessary?
> 

The main reason was section 6.3 in Magnus' draft. In order to have the formula work, it seems that we need both TIAS an prate values, where the prate value is extracted from the SDP description. Also the formula parameters are bound with a "MUST" statement ( i.e. "...layers the following MUST be done.")

BR
Emre

> Regards,
> 
> Lior Sion
> 
> **************************************************************
> ************************************
> The contents of this email and any attachments are confidential.
> It is intended for the named recipient(s) only.
> If you have received this email in error please notify the 
> system manager or  the 
> sender immediately and do not disclose the contents to any 
> one or make copies.
> 
> ** eSafe scanned this email for viruses, vandals and 
> malicious content **
> **************************************************************
> ************************************
> 
> 
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 16 Oct 2002 10:32:50 +0200

Hi Emre,

>Yes, I agree. I also had a syntactical concern, and Magnus made it clear that more than one "b=" attribute can be listed one after another in the same line. So, no problems.
To be clear, when multiple bandwidth modifiers are used they will each 
have its own line. They are not listed after each other on the same line.

Regards

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]