Subject: Re: [MMUSIC] I-D ACTION:draft-ietf-mmusic-reservation-flows-00.txt

From: [email-masked]
Date: Wed, 16 Oct 2002 12:22:14 +0530

Hi all,

Can this grouping be used in addition to FID within
a session description? What I mean to ask is that
can the same media line be a part of 2 groups? For
the current groupings defined (LS and FID) this cannot
be possible. The draft specifying the new group
semantics does not mention the same. Maybe it would
be a good point to mention that each stream MUST be
a part of only one grouping.

For example, is the following a valid session description?

    v=0
    o=Laura 289083124 289083124 IN IP4 four.example.com
    t=0 0
    c=IN IP4 131.160.1.112
    a=group:FID 1 2
    a=group:SRF 1 2
    m=audio 30000 RTP/AVP 0
    a=mid:1
    m=audio 30002 RTP/AVP 8
    a=mid:2

Regards,
Siddharth.

------------------
Siddharth Toshniwal @ Hughes Software Systems
Prestige Opal,
146, Infantry Road
Bangalore - 560001 (India)

[email-masked] on 10/15/2002 05:01:27 PM

Please respond to [email-masked]

To:   IETF-Announce: ;
cc:   [email-masked] (bcc: Siddharth J Toshniwal/HSSBLR)

Subject:  [MMUSIC] I-D ACTION:draft-ietf-mmusic-reservation-flows-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Multiparty Multimedia Session Control
Working Group of the IETF.

     Title          : Mapping of Media Streams to Resource Reservation
Flows
     Author(s) : G. Camarillo, A. Monrad
     Filename  : draft-ietf-mmusic-reservation-flows-00.txt
     Pages          : 6
     Date      : 2002-10-14

This document defines an extension to the SDP grouping framework. It
allows requesting that a group of media streams is mapped into a
single resource reservation flow.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-reservation-flows-00.
txt

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 16 Oct 2002 10:24:05 +0300

Hi,

inline:

[email-masked] wrote:
> a session description?

Yes. FID and SRF semantics do not have any interactions. FID tells you
which stream you have to use to send media at a particular point of
time. SRF tells you how to perform resource reservation. Two orthogonal
problems.

> What I mean to ask is that
> can the same media line be a part of 2 groups?

Yes.

> For
> be possible.

Why not? I can define an FID of two audio lines, and then group them
with a third media line which transports video using LS.

What you cannot do is to use the *same* semantics to group one line more
than once.

> The draft specifying the new group

Yes, this is a valid session description.

Thanks,

Gonzalo