Subject: Re: [MMUSIC] Definition of a RTSP Sesison

From: [email-masked]
Date: Thu, 26 Jun 2003 19:21:14 +0200

hi aravind,

I like your definition, a few remarks:

It could be useful (e.g. in the redicrection at DESCRIBE case) to introduce the
notion that a RTSP "connection" may be "session-less" or something....

now is it obvious and do we need to define
when exactly does the session start from the server point of view
(it is when the Session ID is "sent" in the reply to SETUP?)
and the client point of view (is it when the session ID is received?)?

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.platform4.philips.com

                                                                                                                                       
                                                   To:   [email-masked]                                                               
                                                   cc:   (bcc: Philippe Gentric/MP4-SUR/CE/PHILIPS)                                    
                                                   Subject:    [MMUSIC] Definition of a RTSP Sesison                                   
                                                                                                                                       
               Aravind Narasimhan                  Classification:                                                                     
               <aravind.narasimhan@sun.                                                                                                
               com>                                                                                                                    
                                                                                                                                       
               Sent by:                                                                                                                
               [email-masked]                                                                                                   
                                                                                                                                       
               26/06/2003 18:29                                                                                                        

Hey Folks,
    In the process of updating the RTSP spec, I've noticed that
definition of a RTSP Session needs more work.  I have come up with a
proposal below.  Please send your comments:

Current Definiton:

A state established on a RTSP server by a client with a SETUP request.
The RTSP session exists until it is timed out by the server or is
explicitly removed by a TEARDOWN request. A session implies existence of
state about the media resources that can be played and their respective
transports.

My Proposed Definition:

A stateful abstraction upon which the main control methods of RTSP
operate. A RTSP Session is established by a RTSP server upon the
completion of a successful SETUP request and is labelled by a Session
Identifier at that time.  The session exists until timed out by the
server or explicitly removed by a TEARDOWN request.  A RTSP Session is a
stateful entity; a RTSP server maintains an explicit session state
machine (see Appendix A) where most state transitions are triggered by
client requests.  The existence of a session implies the existence of
state about the session's media resources and their respective
transports.  A given session can have zero or more media resources
associated with it.  A RTSP server uses the session to aggregate control
over multiple media resources.

Aravind

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Aravind Narasimhan <[email-masked]>
Date: Sat, 28 Jun 2003 23:18:42 -0400

>notion that a RTSP "connection" may be "session-less" or something....
I'd rather not introduce the notion of an RTSP "connection", because I 
think it muddles the picture.  The whole point of RTSP is that it is 
independent of Transport level connections and that it mainly operates 
on a RTSP Session.  Now, if I understand it right, the spirit of your 
comment is really just to explicitly clarify that there are RTSP methods 
that do not act on a RTSP session, but rather on underlying media 
resources or presentation resources.  I'll see if I can work it in to 
the defintion, though it is mentioned elsewhere in the spec, namely 
section 1.8 on RTSP States.

>(it is when the Session ID is "sent" in the reply to SETUP?)
Yes.  This is useful to establish as it clarifies the protocol

>and the client point of view (is it when the session ID is received?)?
A RTSP session is a server entity.  It is created, maintained and 
destroyed by the server.  A client is a slave to the server for any 
session properties, information and state.  So from the client point of 
view a session is really only valid at the instant when a response is 
received, as the server may go down or decide to time out the session  
etc.  While it is important to clarify this, we need to make sure that 
there is one unified view of a session and that is the view maintained 
by the server.  I'll see if I can work this in too, but now it's getting 
complex.  We may want to create a new section just to talk about the 
session and keep the defintion in the glossary section small.

Aravind