Subject: RE: [MMUSIC] Questions/Comments on draft-ietf-mmusic-sdp-bwparam-03.txt

From: [email-masked]
Date: Thu, 12 Jun 2003 14:12:44 +0300

Hi Magnus,

> The session level value is bit redundant. It is simply the sum of all 
> media streams and reflect the total amount of bandwidth needed to 
> accommodate this session. This can of course be calculated by 
> a receiver.
> 

Also, in the <draft-ietf-mmusic-sdp-bwparam-03.txt>, in section 6.2.3, Usage rules section, it is stated that:
"...The session level value, if present, MUST be the sum of all media level values.".

I believe this is a true statement for constant bitrate streams. But what about VBR cases? At least for RTP usage, the definition of bandwidth is for max bandwidth consumption over a 1 second sliding window, right? Hence, max bandwidth consumption at session level may be smaller or equal to the sum of these max bandwidths at media levels. And if the client is making resource reservation for QoS purposes, then there may possibly be a redundant amount of bandwidth allocation if the session level bandwidth is simply the absolute sum. Therefore, I believe that the session level TIAS bandwidth value MAY be smaller than the sum of the media level TIAS values. 

I guess for unicast case, a possible way to see the session level bandwidth consumption is during the hinting process of the data at the server side.

Regards,
Emre

Emre Baris Aksu
Nokia Mobile Phones

> -----Original Message-----
> From: ext Magnus Westerlund [mailto:[email-masked]]
> Sent: 12 June, 2003 13:22
> To: Geetha Srikantan
> Cc: [email-masked]
> Subject: Re: [MMUSIC] Questions/Comments on
> draft-ietf-mmusic-sdp-bwparam-03.txt
> 
> 
> Hi,
> 
> Thanks for the comments.
> 
> Geetha Srikantan wrote:
> > I have a few questions and comments on 
> draft-ietf-mmusic-sdp-bwparam-03.txt:
> > 
> > 1. Page 9, the last few lines - What is the difference 
> between 'RTP-based media  
> >    stream' and 'RTP transport' here? It's not very clear 
> when the session level  
> >    TIAS value can be used.
> 
> There is no difference, I can change the RTP-based media 
> stream to "RTP 
> transported media stream".
> 
> The session level value is bit redundant. It is simply the sum of all 
> media streams and reflect the total amount of bandwidth needed to 
> accommodate this session. This can of course be calculated by 
> a receiver.
> 
> > 
> > 2. Section 6.2.3, 2nd paragraph - it would be good to 
> clarify that this entire 
> >    paragraph refers to the media level values.
> >    This paragraph is a little confusing to read..it might 
> help to mention
> >    explicitly that it is RECOMMENDED to use both the AS and 
> TIAS fields;
> >    AS for backwards compatibility, older implementations 
> would ignore the TIAS 
> >    field; TIAS would be recognized by newer and compliant 
> implementations,
> >    which must ignore the AS value.
> 
> No, It does not only apply for the media level, but both 
> levels. AS can 
> be present at both levels, if one includes it at either level one is 
> recommended to include TIAS also.
> 
> I don't quite understand what you mean with confusing to read. The 
> information you ask for is there: "..., it is RECOMMENDED to also 
> include the "AS" modifier when using "TIAS"". Do you have a more 
> concrete proposal on how reformulate the paragraph?
> 
> >    
> > 3. 6.3, 2nd paragraph - here too it might help clarity to 
> assert the 'MUST NOT' 
> >    case , before the 'MAY' case.
> 
> So you would like to be reformulated into something like this:
> 
> "At the SDP session level, the maxprate value MUST be the sum of all 
> media-level packet rates. The "maxprate" attribute MUST NOT 
> be present 
> at session level if the media streams use different transport. The 
> attribute MAY be present if the media streams use the same 
> transport. If 
>   the attribute is present at the session level it SHOULD also be 
> present at the media level for all media streams."
> 
> Is that better? If not please provide concrete proposals of 
> the paragraph.
> 
> 
> >    
> > 4. 6.3, is there any ambiguity in the last paragraph? For 
> instance, is it ok to
> >    *not* have maxprate if one or the other of TIAS or the 
> max packet rate 
> >    for the transport is not available?
> 
> Yes, if one can't derive a packet rate due to for example non packet 
> based transport then its ok. However if you use TIAS and have a 
> transport like IP/UDP/RTP you shall have it. Perhaps I should 
> reformulate the sentence to be more strict and explanatory.
> 
> >    
> > 5. It would be great to have a complete example of SDP 
> using TIAS and maxprate
> >    attributes.   
> >    
> 
> Yes, you are correct. I will look into it.
> 
> 
> Best Regards
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research ERA/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 13 Jun 2003 10:31:58 +0200

Hi Emre,

Comments below.

> I believe this is a true statement for constant bitrate streams. But what about VBR cases? At least for RTP usage, the definition of bandwidth is for max bandwidth consumption over a 1 second slidi…

Yes, you are correct that if one has several VBR streams they can be 
scheduled so that the sum of all the streams has a lower maximum.

The session level application of the TIAS value has been something I 
have been had different views on, during the development of the this 
draft. For a while I had TIAS only as media level attribute. As I see it 
there are three possible ways to go with this issue.

1. Remove TIAS and maxprate at session level. This will remove the 
redundancy compared to ver 03 definition. It will simplify and prevent 
any possibilities for contradictions between the values.

2. Keep it as defined today as the sum of all media streams values. Is 
redundant, has the possibility to be contradicting between session level 
and media level.

3. Define is at being the actual value when all media streams are sent. 
  Will allow for getting a whole session value that are less then the 
sum of media level values. Will be more complex and will require more 
implementation to consider if both values are present. A given value on 
session level will only be true if all media streams are actually used. 
Not known how often you can actually use this.

Looking at this list I now see that using 2 as current proposed may be 
the least good solution. I would like to get more input if they believe 
in 3.

Best Regards

Magnus Westerlund