Subject: Re: [MMUSIC] RTSP: Implicit redirection

From: [email-masked]
Date: Wed, 18 Jun 2003 15:15:49 +0200

Magnus, Tom,

[I was trying to write down what I had though
was expressed during the RTSP conf call,
apparently I got it wrong  ...
these transatlantic phone lines are really bad
must be the echelon probes injecting static ;-]

Again I cannot agree more that it is possible to setup
2 different servers so that one serves the SDP
and the other one serves the streams ...

the thing that remains unclear is the returned status?

in case the DESCRIBE response is:

* a Location that points to another server => 3xx ?
or
* a SDP with absoluted URLs pointing to another server => 2yy ?
or
* both (are we going to permit it ?) => 2zz ?

and then what are the value of xx, yy and zz ?

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.platform4.philips.com

                                                                                                                                           
                                                       To:   Tom Marshall <[email-masked]>                                             
                                                       cc:   Philippe Gentric/MP4-SUR/CE/PHILIPS@EMEA1                                     
                                                        IETF MMUSIC WG <[email-masked]>                                                   
                                                       Subject:    [MMUSIC] RTSP: Implicit redirection                                     
               Magnus Westerlund                                                                                                           
               <magnus.westerlund@ericsson.            Classification:                                                                     
               com>                                                                                                                        
                                                                                                                                           
               Sent by:                                                                                                                    
               [email-masked]                                                                                                       
                                                                                                                                           
               17/06/2003 16:50                                                                                                            

Hi Philippe and Tom,

I agree with Tom here. It would be much simpler to just specify that any
received SDP can point to another host using the a=control URLs. If you
do DESCRIBE on the aggregated control URL you should receive the same
SDP description.

The only implementation simplifying restriction I would like to
introduce is that all media streams SHOULD be served by the same server.

Any counter reasons?

Best Regards

Magnus

Tom Marshall wrote:
> This all seems overly complex and inconsistent to me.  Why are people
> trying
> so hard to insist that the SDP come from the same server as the media?
> If
> we simply require that the client honor the hostname in the complete
> stream
> urls (whether from Content-Base or a=control) everything becomes very
> simple
> and constistent.
>
> If we require the client to make different assumptions based on whether
> the
> SDP came from the current RTSP control connection or via another means,
> we
> require a series of workarounds to make it work properly:
>
>  - An inconsistent message with respect to urls.  We are requiring that
>    clients explicitly ignore the hostname in certain situations.
>
>  - Inconsistent behavior through proxies.  A proxy will always honor the
>    hostname but clients are forbidden from doing so.
>
>  - More complexity: another feature tag and 2xx response code to
> support.
>
> If we simply require the client to honor the hostname in the stream
> urls,
> all of the above issues go away.  The only changes are as follows:
>
>  - The client MUST be prepared to examine the hostname and, if
> necessary,
>    reconnect for the SETUP.  This seems a pretty simple thing to
> implement.
>
>  - The typical non-redirecting server SHOULD take care to echo the
> hostname
>    exactly as it appears in the client request in order to make the
> client's
>    hostname comparison easy.  The server should already be doing this.
>
> Remember, the notion that a DESCRIBE response not redirect the client
> was
> only added in an attempt to reduce the complexity of RTSP.  If it is not
> serving that purpose, it should be removed.
>
> --

Magnus Westerlund

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 19 Jun 2003 15:45:55 +0200

Hi Philippe,

> apparently I got it wrong  ...

I just think that we misunderstood each others positions.

> and the other one serves the streams ...

Yes, you can, however if you would ask the media server for the SDP I 
think you SHOULD also get the SDP from that one.

> * a Location that points to another server => 3xx ?

Use the 3rr code that is suitable for the case. I think usage of any of 
the 301, 302, and 305 can be used.

> * a SDP with absoluted URLs pointing to another server => 2yy ?

I think simply to use 200. The request has been fulfilled.

> * both (are we going to permit it ?) => 2zz ?

I would recommend against it. You use either of the behaviour, not both 
simultaneous. That behaviour is definitely not understood by the 
deployed clients. I welcome more opinions regarding this.

Best Regards

Magnus Westerlund