Subject: [MMUSIC] Questions/Comments on draft-ietf-mmusic-sdp-bwparam-03.txt

From: Geetha Srikantan <[email-masked]>
Date: Wed, 11 Jun 2003 18:08:31 -0700 (PDT)

I have a few questions and comments on draft-ietf-mmusic-sdp-bwparam-03.txt:

1. Page 9, the last few lines - What is the difference between 'RTP-based media  
   stream' and 'RTP transport' here? It's not very clear when the session level  
   TIAS value can be used.

2. Section 6.2.3, 2nd paragraph - it would be good to clarify that this entire 
   paragraph refers to the media level values.
   This paragraph is a little confusing to read..it might help to mention
   explicitly that it is RECOMMENDED to use both the AS and TIAS fields;
   AS for backwards compatibility, older implementations would ignore the TIAS 
   field; TIAS would be recognized by newer and compliant implementations,
   which must ignore the AS value.
   
3. 6.3, 2nd paragraph - here too it might help clarity to assert the 'MUST NOT' 
   case , before the 'MAY' case.
   
4. 6.3, is there any ambiguity in the last paragraph? For instance, is it ok to
   *not* have maxprate if one or the other of TIAS or the max packet rate 
   for the transport is not available?
   
5. It would be great to have a complete example of SDP using TIAS and maxprate
   attributes.   
   
thanks
geetha

internet: [email-masked]
 
> To: [email-masked]
> cc: [email-masked]
> From: Colin Perkins <[email-masked]>
> Date: Thu, 29 May 2003 09:01:32 -0400
> Subject: [MMUSIC] WG last call: draft-ietf-mmusic-sdp-bwparam-03.txt
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.12
> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/mmusic>, 
<mailto:[email-masked]?subject=unsubscribe>
> List-Id: Multiparty Multimedia Session Control Working Group <mmusic.ietf.org>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/mmusic>, 
<mailto:[email-masked]?subject=subscribe>
> 
> This is to announce a working group last call on the Transport Independent
> Bandwidth Modifier for SDP <draft-ietf-mmusic-sdp-bwparam-03.txt>. Please
> send any final comments on this draft to the mailing list by Friday, 13th
> June 2003. If no substantive issues are raised by that time, we propose to
> ask the IESG to publish this as a Proposed Standard RFC.
> 
> -- 
> Colin Perkins
> http://csperkins.org/
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 12 Jun 2003 12:22:21 +0200

Hi,

Thanks for the comments.

>    stream' and 'RTP transport' here? It's not very clear when the session level  

There is no difference, I can change the RTP-based media stream to "RTP 
transported media stream".

The session level value is bit redundant. It is simply the sum of all 
media streams and reflect the total amount of bandwidth needed to 
accommodate this session. This can of course be calculated by a receiver.

>    which must ignore the AS value.

No, It does not only apply for the media level, but both levels. AS can 
be present at both levels, if one includes it at either level one is 
recommended to include TIAS also.

I don't quite understand what you mean with confusing to read. The 
information you ask for is there: "..., it is RECOMMENDED to also 
include the "AS" modifier when using "TIAS"". Do you have a more 
concrete proposal on how reformulate the paragraph?

>    case , before the 'MAY' case.

So you would like to be reformulated into something like this:

"At the SDP session level, the maxprate value MUST be the sum of all 
media-level packet rates. The "maxprate" attribute MUST NOT be present 
at session level if the media streams use different transport. The 
attribute MAY be present if the media streams use the same transport. If 
  the attribute is present at the session level it SHOULD also be 
present at the media level for all media streams."

Is that better? If not please provide concrete proposals of the paragraph.

>    for the transport is not available?

Yes, if one can't derive a packet rate due to for example non packet 
based transport then its ok. However if you use TIAS and have a 
transport like IP/UDP/RTP you shall have it. Perhaps I should 
reformulate the sentence to be more strict and explanatory.

> 5. It would be great to have a complete example of SDP using TIAS and maxprate

Yes, you are correct. I will look into it.

Best Regards

Magnus Westerlund

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]