Subject: [MMUSIC] Inconsistency in draft-ietf-mmusic-sdp-new-13.txt

From: Pekka Pessi <[email-masked]>
Date: Mon, 14 Jul 2003 18:05:41 +0300

Hello all,

	In the sdp-new, there seems to be a contradiction between the
	ABNF definition of "token-char" and comments after the
	definition:

      token-char =          %x21 / %x23-27 / %x2A-2B / %x2D-2E / %x30-39
                            / %x41-5A / %x5E-7E
                            ; definition from RFC 2045 -
                            ; "any (US-ASCII) CHAR except SPACE, CTLs,
                            ; or tspecials".
                            ; the tspecials are ()<>@,;:

	According to the ABNF, the tspecials include quote (%22, "),
	slash (%2F, /), equal (%3D, =), question mark (%3f, ?), square
	brackets (%5B, [ and %5D, ]), and backslash (%5C, \), too:

                            ; the tspecials are ()/<>@,;:"=?[\]

	As it looks like that the sdp-new-14 is recycled once more, so
	it is possible to fix the comment there (or ABNF, if that is
	more appropriate).

					--Pekka

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Wed, 16 Jul 2003 09:53:01 +0200

> 	it is possible to fix the comment there (or ABNF, if that is

I'd like to solicit opinions from implementors about this. Please state
your preference for either:

 1) Leave the ABNF for token-char as-is, but remove the comment

 2) Change the ABNF for token-char to be:

	token-char = %x21-27 / %x2A-2B / %x2D-2F / %x30-39 / %x3D / %x3F / %x41-5B
                    / %x5C-%x5D / %x5E-7E

    adding the characters mentioned above.

-- 
Colin Perkins
[email-masked]