Subject: [MMUSIC] RE: [dccp] Using DCCP for VoIP

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 24 Jul 2003 16:42:06 -0400

Not really.  If you are going to have a problem, you would
rather have the video go before the audio, and thus you
would prefer to keep the congestion control separate.

I'd rather they be entirely separate.

Brian

> -----Original Message-----
> From: Eddie Kohler [mailto:[email-masked]]
> Sent: Thursday, July 24, 2003 4:21 PM
> To: [email-masked]
> Cc: Phelan, Tom; [email-masked]; [email-masked]; 'Reiner Ludwig'
> Subject: Re: [dccp] Using DCCP for VoIP 
> 
> 
> Hi all,
> 
> On this issue:
> 
> > IMHO this issue is related to my question in the other mail about
> > managing audio AND video at the same time: probably DCCP 
> should have a
> > way to handle "collectively" a bunch of streams, be it 
> audio plus video
> > or two-way audio!
> 
> Our thought was that, given DCCP's unreliability, it is 
> trivial to layer
> multiple streams on top. The first byte of packet data could indicate
> stream number to the application. This works as long as both 
> streams want
> to share the same congestion control state + CC mechanism -- 
> is this the
> case?
> 
> Eddie
> 
> _______________________________________________
> dccp IETF mailing list: [email-masked]
> list info:  https://www1.ietf.org/mailman/listinfo/dccp
> wg charter: http://www.ietf.org/html.charters/dccp-charter.html
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Eddie Kohler <[email-masked]>
Date: Thu, 24 Jul 2003 15:01:31 -0700

> I'd rather they be entirely separate.

This may be a good reason to keep the data *together*, on one connection,
actually. The sender can react to congestion feedback by throwing out the
video first. If you have two separate connections, both of their rates will
decrease.

Eddie