Subject: Re: [MMUSIC] SDP b= clarification

From: Colin Perkins <[email-masked]>
Date: Tue, 2 Sep 2003 21:58:17 +0100

On Thursday, Aug 28, 2003, at 20:38 Europe/London, Tom Marshall wrote:
> In RFC3556, the example SDP shows multiple b=lines in the media 
> sections.
> In RFC2327 (and the updated draft sdp-new-13), the b= line is specified
> without any corresponding note that the line may be repeated.  I've 
> always
> assumed this meant exactly one instance was allowed.  If that is the 
> case,
> the example SDP in 3556 is noncompliant.  Since multiple b= lines are
> presumedly desirable, I think the sdp-new draft should be updated to 
> reflect
> this.

The ABNF in draft-ietf-mmusic-sdp-new-13.txt explicitly allows 
repetition.

   bandwidth-fields =    *("b=" bwtype ":" bandwidth CRLF)
   bwtype =              token
   bandwidth =           1*DIGIT

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Tom Marshall <[email-masked]>
Date: Tue, 2 Sep 2003 14:58:53 -0700

>   bandwidth-fields =    *("b=" bwtype ":" bandwidth CRLF)

Cool.  Could we get a note in the text that corresponds with the ABNF?

-- 
I stayed up all night playing poker with tarot cards.  I got a full
house and four people died.
        -- Steven Wright