Subject: RE: [MMUSIC] RTSP: Bug 771638 - a=range in SDP to indicate live media

From: "Jae-Hwan Kim" <[email-masked]>
Date: Wed, 15 Oct 2003 12:02:13 +0900

Hi,

Just a simple question regarding range header although it is far from an
live indicating.
I saw an example, 2 range headers at session-level SDP because the
original content contains a=range in its hinted SDP area: the first one
is 'a=range:npt=0-620' server made and the other is
'a=range:npt=0-300'(or npt=0-) originally from the server; in case of
two different range attributes exist. Almost all hinted server just
seems to get and forward SDP and RTP data.

How can we, as a player, understand this SDP? 
Just I think the possible and right behavior is as followings:
1) If there are two or more a=range header at a session-level or
media-level, the maximum one shall be used.
2) But if there is npt=0-, it means also this content is not seekable.

I would appreciate it for your advice.

Cheers,
Jae-Hwan

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]] 
> Sent: Wednesday, October 15, 2003 2:37 AM
> To: IETF MMUSIC WG
> Subject: [MMUSIC] RTSP: Bug 771638 - a=range in SDP to 
> indicate live media
> 
> 
> Hi,
> 
> The below text is proposed for resolving the the following bug:
> 
> http://rtsp.org/bug771638 - a=range in SDP to indicate live media
> 
>  From Annex C:
> 
> "
> Range of Presentation
> 
> The ``a=range'' attribute defines the total time range of the 
> stored session or an individual media. That Live sessions are 
> non-seekable can also be indicated, while the length of live 
> sessions can be deduced from the ``t'' and ``r'' parameters.
> 
> The attribute is both a session and a media level attribute. 
> For presentations that contains media streams of the same 
> durations, the range attribute {\SHOULD} only be used at 
> session-level. In case of different length the range 
> attribute {\MUST} be given at media level for all media. If 
> the attribute is present at media level and session level the 
> media level values {\SHALL} be used.
> 
> The unit is specified first, followed by the value range. The 
> units and their values are as defined in Section 
> \ref{sec:smpte}, \ref{sec:npt} and \ref{sec:clock}. Any open 
> ended range (start-), i.e. without stop range, is of 
> unspecified duration and {\SHALL} be considered as 
> non-seekable content unless this property is overridden.
> 
> 
> This attribute is defined in ABNF \cite{rfc2234} as:
> 
> a-range-def = "a" "=" "range" ":" ranges-specifier CRLF
> 
> 
> 
> Examples:
> 
>    a=range:npt=0-34.4368
>    a=range:clock=19971113T2115-19971113T2203
>    Non seekable stream of unknown duration:
>    a=range:npt=0-
> 
> "
> 
> Any comments should be given before wednesday the 22nd of October.
> 
> Cheers
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research EAB/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 15 Oct 2003 09:06:09 +0200

Hi Jae-Hwan,

I am not certain I understand your concern.

You have cases where the SDP has the following attributes in it:
a=range:npt=0-620
a=range:npt=0-300

In my opinion this is an erroneous SDP. The server creating this SDP has 
made a mistake. The only concern I have with limiting the SDP attribute 
to only contain a single range is that the following case is not 
possible to express:

Range: npt=0-300, npt=450-600

That is possible to express in the RTSP range header. And is maybe even 
more useful when used with "clock" to inform what parts that are 
available of yesterdays recorded TV programs.

If the above was not what you meant, please clarify.

Cheers

Magnus

-- 

Magnus Westerlund