Subject: Re: [MMUSIC] SDP b= clarification

From: Colin Perkins <[email-masked]>
Date: Wed, 22 Oct 2003 00:05:37 +0100

On Tuesday, Sep 2, 2003, at 22:58 Europe/London, Tom Marshall wrote:
> On Tue, Sep 02, 2003 at 09:58:17PM +0100, Colin Perkins wrote:
>> On Thursday, Aug 28, 2003, at 20:38 Europe/London, Tom Marshall wrote:
>>> In RFC3556, the example SDP shows multiple b=lines in the media
>>> sections.
>>> In RFC2327 (and the updated draft sdp-new-13), the b= line is 
>>> specified
>>> without any corresponding note that the line may be repeated.  I've
>>> always
>>> assumed this meant exactly one instance was allowed.  If that is the
>>> case,
>>> the example SDP in 3556 is noncompliant.  Since multiple b= lines are
>>> presumedly desirable, I think the sdp-new draft should be updated to
>>> reflect
>>> this.
>>
>> The ABNF in draft-ietf-mmusic-sdp-new-13.txt explicitly allows
>> repetition.
>>
>>   bandwidth-fields =    *("b=" bwtype ":" bandwidth CRLF)
>>   bwtype =              token
>>   bandwidth =           1*DIGIT
>
> Cool.  Could we get a note in the text that corresponds with the ABNF?

Provided there are no objections, if you suggest explicit wording 
changes, I can incorporate them into -15.

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Tom Marshall <[email-masked]>
Date: Wed, 22 Oct 2003 13:20:43 -0700

> changes, I can incorporate them into -15.

This would be the simplest change:

  --- draft-ietf-mmusic-sdp-new-14.txt    2003-10-22 12:51:26.000000000 -0700
  +++ draft-ietf-mmusic-sdp-new-14-edited.txt     2003-10-22 13:18:57.000000000 -0700
  @@ -495,7 +495,7 @@
            p=* (phone number)
            c=* (connection information - not required if included in
                 all media)
  -         b=* (bandwidth information)
  +         b=* (zero or more bandwidth information lines)
            One or more time descriptions (see below)

  @@ -519,7 +519,7 @@
            i=* (media title)
            c=* (connection information - optional if included at
                 session-level)
  -         b=* (bandwidth information)
  +         b=* (zero or more bandwidth information lines)
            k=* (encryption key)
            a=* (zero or more media attribute lines)
   
-- 
Football combines the two worst features of American life.
It is violence punctuated by committee meetings.
        -- George F. Will

---

From: Colin Perkins <[email-masked]>
Date: Sun, 26 Oct 2003 19:52:48 +0000

>   --- draft-ietf-mmusic-sdp-new-14.txt    2003-10-22 

Will be in -15

-- 
Colin Perkins
http://csperkins.org/