Subject: RE: [MMUSIC] specifying the multicast interface

From: "Matthew Heaney" <[email-masked]>
Date: Thu, 16 Oct 2003 19:13:09 -0400

Because a customer asked us to.

A multicast session is started on a TrueCast server using a web-based
admin interface.  The admin user specifies the multicast address and
port he wants, the name of the presentation, etc.  

Currently, our admin tool doesn't allow you to specify the IP of the
interface card, even though explicitly specifying the interface over
which to multicast the session is allowed per the BSD socket API.  So we
have to fix it.

For now I'll just use a GET_PARAMETER to get the interface list, and
then augment the SETUP request with an "X-multicast-interface" header.

> -----Original Message-----
> From: Thomas Zeng [mailto:[email-masked]] 
> Sent: Wednesday, October 15, 2003 8:55 PM
> To: Matthew Heaney; [email-masked]
> Subject: RE: [MMUSIC] specifying the multicast interface
> 
> 
> Why does one need to publish "the IP of the NIC used to 
> multicast the session" ?
> 
> -----Original Message-----
> From: Matthew Heaney [mailto:[email-masked]]
> Sent: Wednesday, October 15, 2003 8:27 AM
> To: Thomas Zeng; [email-masked]
> Subject: RE: [MMUSIC] specifying the multicast interface
> 
> 
> 
> 
> > -----Original Message-----
> > From: Thomas Zeng [mailto:[email-masked]]
> > Sent: Monday, October 13, 2003 1:50 PM
> > 
> > Yes, you can provide the IP of the selected IF via the c=
> > line in SDP, 
> 
> But doesn't that specify the multicast address?  The 
> interface address is different -- it's the IP of the NIC used 
> to multicast the session.
> 
> 
> 
> > but the final say is upto RTSP negotiations,
> > ie., you can use the Transport header in the SETUP 
> > request/response to over-ride SDP. Transport header has the 
> > following general parameters, quoting 2326:
> > 
> > 
> >    destination:
> >           The address to which a stream will be sent. The client may
> >           specify the multicast address with the destination
> > parameter.
> 
> But isn't this the multicast address?  This is not the same 
> as the interface address.
> 
> 
> > 
> >    source:
> >           If the source address for the stream is different
> > than can be
> >           derived from the RTSP endpoint address (the server 
> > in playback
> >           or the client in recording), the source MAY be specified.
> 
> Not sure whether this qualifies as the interface address.
> 
> 
> > Hope this is the answer you are looking for.
> 
> I don't think so, but thanks anyway.
> 
> -Matt
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 17 Oct 2003 16:13:22 +0200

Hi Matthew,

I have some problem of understanding why you need to specify the 
outgoing interface to use. Is this multihomes servers that you have an 
interest of ensuring that the transmissions are made using the right 
sender address? A little more explanation on the needs and advantages to 
specify the sending interface would be appreciated. Especially if we 
should consider adding anything to the RTSP standard.

Then I would also recommend you to skip the "X-" from your parameter 
name, as if it would be standardized in the future you don't have to 
change the implementations, to also support the new name. The only 
consideration is that if someone in the future registers this name is 
that the proprietary use are responsible for updating there feature or 
giving it a new name.

cheers

Magnus

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]