Subject: [MMUSIC] Rtspspec-bugs digest, Vol 1 #106 - 1 msg

From: [email-masked]
Date: Tue, 28 Oct 2003 20:31:13 -0800

This is an automatic digest of bugs submitted and changed on the RTSP bug tracker.  To see a list of bugs, visit:

http://sf.net/projects/rtspspec

When replying, please make your Subject line more specific than "Re: Rtspspec-bugs digest"

Today's Topics:

   1. [ rtspspec-Bugs-831553 ] Error in rfc2326bis-04 example 15.4 (SourceForge.net)

--__--__--

Message: 1
To: [email-masked]
From: "SourceForge.net" <[email-masked]>
Date: Mon, 27 Oct 2003 21:20:21 -0800
Subject: [rtspspec-bugs] [ rtspspec-Bugs-831553 ] Error in rfc2326bis-04 example 15.4

Bugs item #831553, was opened at 2003-10-28 05:20
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377744&aid=831553&group_id=23194

Category: Editorial
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Thomas M Zeng (zengtm)
Assigned to: Nobody/Anonymous (nobody)
Summary: Error in rfc2326bis-04 example 15.4

Initial Comment:
The last two messages in this example is:

   C->M: PLAY rtsp://live.example.com/concert/audio 
RTSP/1.0
         CSeq: 3
         Session: 0456804596

   M->C: RTSP/1.0 200 OK
         CSeq: 3
         Session: 0456804596
         Range:npt=now-

But I wonder how the receiver could perform the sync
between RTP timestamp and NPT, without a RTP-Info 
header in the PLAY response? I wouldn't like to see 
such RTSP conversation in our applicatoin.

A real implementation would likely to conduct the PLAY 
request/response including RTP-Info, for example: 

C->M: PLAY rtsp://live.example.com/concert/audio 
RTSP/1.0
         CSeq: 3
         Session: 0456804596
         Range: now-

   M->C: RTSP/1.0 200 OK
         CSeq: 3
         Session: 0456804596
         Range:npt=1000-
         RTP-Info: 
url=rtsp://live.example.com/concert/audio; seq=1473; 
rtptime=80000

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377744&aid=831553&group_id=23194

End of Rtspspec-bugs Digest

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 29 Oct 2003 09:46:01 +0100

Hi,

As Thomas has logged a bug about some examples, I like to point out that 
the examples has not been corrected to follow the specification text. 
Therefore I strongly suggest that people ignore the examples unless they 
are willing to send us complete proposals for how they should look.

Thanks Thomas for the proposal for how to fix it, however I have a 

> url=rtsp://live.example.com/concert/audio; seq=1473; 

Yes, it is correct that RTP-Info are need. However there are several 
options in this example:

- Have a Range header in the Play request?

- Should the server specify the current point since session start, or 
only give a now, which doesn't provide the client any reference to where 
in the live session the stream is in, but provides the minimum 
information about what is needed for synchronization.

If you have any comments. Please respond.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]