Subject: RE: [MMUSIC] Comedia draft

From: [email-masked]
Date: Fri, 14 May 2004 13:15:09 +0300

Gonzalo,

> I have removed that section from the draft because I believe 
> it is out 
> of the scope of the comedia draft. I want the comedia draft 
> to specify 
> how to describe connection oriented streams in SDP. Explaining how to 
> make RTP streams traverse NATs should be dealt with in a 
> different document.

I see your point. However, the symmetric RTP would make use of the
setup attribute and all mechanisms defined in comedia draft. Actually 
the section we are talking about was less than half a page. Does it 
really make sense to create a different document just for this?

> That much said, the ICE framework provides a way to traverse 
> NATs which 
> is much better than the one described in comedia-05. 

What I propose to document is the symetric RTP not a specific discussion 
how to traverse NAT with RTP streams.

> In any event, if 
> there is still interest to document the latter approach, we 
> can discuss 
> where to do it.

At least I'm interested to document the use of symmetric RTP. 
My preference would be to put back the mentioned section in to the
comedia draft, as I see it is relevant to what you describe there.
Said that, do you see any other document where to do it?

Regards
Marco

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 14 May 2004 13:30:11 +0300

Marco,

I am cc:ing the chairs for advice on this one.

My opinion is that a draft defining symmetric RTP should discuss the 
advantages of it, which types of NATs can be traversed, which ones 
cannot be traversed, why an implementer would want to use symmetric RTP 
instead or in addition to ICE, etc... and all these discussions do not 
belong to the comedia draft at all.

So, I would propose that symmetric RTP is documented in a separate, 
possibly new, document.

Your suggestion of saving one document by defining symmetric RTP in 
comedia does not seem compeling to me, but I would like to hear the 
chairs' opinion. I will do what they think it is more appropriate.

Thanks,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

---

From: Colin Perkins <[email-masked]>
Date: Fri, 14 May 2004 11:38:15 +0100

I agree with Gonzalo. If a definition for symmetric RTP is important, then 
it should go into a separate draft.

Colin

On Friday 14 May 2004 11:30, Gonzalo Camarillo wrote:
> > What I propose to document is the symetric RTP not a specific
> > discussion how to traverse NAT with RTP streams.
> >
> >>In any event, if

-- 
Colin Perkins
http://csperkins.org/

---

From: Joerg Ott <[email-masked]>
Date: Fri, 14 May 2004 12:46:11 +0200 (MEST)

Completely agree with Colin.  And we should make different functions explicit
rather than hiding them.

Joerg

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 14 May 2004 13:28:52 +0200

A Comment,

Without having read the changes properly. Are you certain about talking 
about the same thing when you mention symmetric RTP?

I could see that this is two different things:

1. The rather normal property for certain applications that one send and 
receive RTP data on the same UDP port.

2. The special property to require that one send and receive RTP session 
to ensure that one can traverse NATs.

As the first one is important and need to be supported, while the second 
and explicit requirements to perform the second can either be implicitly 
clear by the solution, or need to be explicitly signalled. Depending on 
what is really the case, the second bullet will either be taken care of 
automatically, or need extension.

In the case of RTP I think one should look at the interface between the 
AVT draft for RTP framing for connection oriented transport.

Cheers

Magnus

Joerg Ott wrote:

>>I agree with Gonzalo. If a definition for symmetric RTP is important,
> 
> then 
> 
>>>cannot be traversed, why an implementer would want to use symmetric
> 
> RTP
> 
>>>instead or in addition to ICE, etc... and all these discussions do
> 
> not
> 
>>>>>how to describe connection oriented streams in SDP. Explaining how
> 
> to
> 
>>>>setup attribute and all mechanisms defined in comedia draft.
> 
> Actually
> 
>>>>the section we are talking about was less than half a page. Does
> 
> it
> 

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]