Subject: [MMUSIC] Comedia draft

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 14 May 2004 11:02:15 +0300

Folks,

we have just submitted a new version of the comedia draft. Until it 
appears in the archives, you can fetch it from:

http://standards.ericsson.net/gonzalo/papers/draft-ietf-mmusic-sdp-comedia-06.txt

We have simplified the draft and removed stuff that has been addressed 
by other documents which appeared after version 05 of comedia was written.

This is an important piece still missing in SDP, so we would encourage 
people to provide feedback so that we can move this forward reasonable 
quickly.

Comments are very welcome.

Thanks,

Gonzalo

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: [email-masked]
Date: Fri, 14 May 2004 13:40:12 +0300

Gonzalo,

> Your suggestion of saving one document by defining symmetric RTP in 
> comedia does not seem compeling to me, but I would like to hear the 
> chairs' opinion. I will do what they think it is more appropriate.

That is my amble proposal and question to you. But, as I said, I'm
fine with other approaches as well.

Marco

---

From: [email-masked]
Date: Fri, 14 May 2004 13:48:16 +0300

Hi Colin,

> I agree with Gonzalo. If a definition for symmetric RTP is 
> important, then 
> it should go into a separate draft.

Fine.

Thank you
Marco

> -----Original Message-----
> From: ext Colin Perkins [mailto:[email-masked]]
> Sent: 14 May, 2004 13:38
> To: Gonzalo Camarillo
> Cc: Stura Marco (Nokia-NET/Helsinki); [email-masked]; Joerg Ott
> Subject: Re: [MMUSIC] Comedia draft
> 
> 
> I agree with Gonzalo. If a definition for symmetric RTP is 
> important, then 
> it should go into a separate draft.
> 
> Colin
> 
> 
> 
> On Friday 14 May 2004 11:30, Gonzalo Camarillo wrote:
> > Marco,
> >
> > I am cc:ing the chairs for advice on this one.
> >
> > My opinion is that a draft defining symmetric RTP should discuss the
> > advantages of it, which types of NATs can be traversed, which ones
> > cannot be traversed, why an implementer would want to use 
> symmetric RTP
> > instead or in addition to ICE, etc... and all these 
> discussions do not
> > belong to the comedia draft at all.
> >
> > So, I would propose that symmetric RTP is documented in a separate,
> > possibly new, document.
> >
> > [email-masked] wrote:
> > > Gonzalo,
> > >
> > >>I have removed that section from the draft because I believe
> > >>it is out
> > >>of the scope of the comedia draft. I want the comedia draft
> > >>to specify
> > >>how to describe connection oriented streams in SDP. 
> Explaining how to
> > >>make RTP streams traverse NATs should be dealt with in a
> > >>different document.
> > >
> > > I see your point. However, the symmetric RTP would make use of the
> > > setup attribute and all mechanisms defined in comedia 
> draft. Actually
> > > the section we are talking about was less than half a 
> page. Does it
> > > really make sense to create a different document just for this?
> > >
> > >>That much said, the ICE framework provides a way to traverse
> > >>NATs which
> > >>is much better than the one described in comedia-05.
> > >
> > > What I propose to document is the symetric RTP not a specific
> > > discussion how to traverse NAT with RTP streams.
> > >
> > >>In any event, if
> > >>there is still interest to document the latter approach, we
> > >>can discuss
> > >>where to do it.
> > >
> > > At least I'm interested to document the use of symmetric RTP.
> > > My preference would be to put back the mentioned section in to the
> > > comedia draft, as I see it is relevant to what you describe there.
> > > Said that, do you see any other document where to do it?
> > >
> > > Regards
> > > Marco
> 
> -- 
> Colin Perkins
> http://csperkins.org/
>