Subject: RE: [MMUSIC] Re: sdp-new unregistered media types

From: "Even, Roni" <[email-masked]>
Date: Thu, 6 May 2004 15:56:46 +0300

Hi,
My comment is that if data and control are detracted then section 5.14
should be changed to say that application is used for all those cases. 
Otherwise I do not have a problem with data or control.

Roni Even

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Thursday, May 06, 2004 3:36 PM
To: Mark Handley
Cc: Even, Roni; Rod.Walsh; mmusic; magnus.westerlund
Subject: Re: [MMUSIC] Re: sdp-new unregistered media types

On Thursday 06 May 2004 13:29, Mark Handley wrote:
> >If you deprecate the data and control MIME type that will take away the
> >defined distinction between application data and control in 5.14. So
> >everything that is not audio video or text will be application.
> >For example if we want to add far end camera control will it be
> > application. Does that make sense or do we still want to enable such
> > distinctions.
>
> application as a MIME type is something of a catchall - it really
> should be called "misc" in my opinion.
>
> For example, SDP's MIME type is application/sdp
> Now SDP isn't really an application, and it isn't really application
> data - it's really control data or metadata.
>
> I added "control" (long before SDP types were associated with MIME
> types) because I prefered to make the distinction between data and
> metadata - I thought and still think adds clarity.  But the arguments
> both for and against are not really strong.
>
>
> Now, as to IETF process:
>
>  - if "control" isn't being used in an interoperable manner, we can't
>    progress it to draft standard.
>
>  - if "control" is being used in an interoperable manner by a few
>    people, we should not deprecate it.  The IANA considerations for
>    SDP are entirely consistent with not needed to have a MIME type for
>    this, although there should be a registry for the media formats.
>
>  - if the use of "control" is widespread, we should probably push for
>    a MIME Content Type to be registered for it.
>
>
> I assume Colin probably knows best what the current deployment status
> is, so I won't comment on that.

Actually, if people are using "control" or "data", it would be helpful if 
they could speak out. :)

Colin

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Thu, 6 May 2004 14:02:02 +0100

[cc list trimmed]

> Otherwise I do not have a problem with data or control.

Do you know of implementations using "data" or "control"?

Colin