Subject: Re: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-new-20.txt

From: sunil bhargo <[email-masked]>
Date: Mon, 27 Sep 2004 05:18:42 -0700 (PDT)

Hi,
    Doubts regarding the following sections :-

1. 
"an SDP parser MUST completely ignore any session
description that contains a type letter that it does
not understand"
              
       Isn't the word MUST having very strong
implications which might not be necessary. For example
intermediate SDP parsers between the client and server
if everything that is not understood is rejected then
it might be problem. First thing that comes to mind
are the proxies(caching or dumb) they would have to
deny the service instead of proxying the presentation.

     But somewhere else we mention as well 
"An SDP parser MUST ignore any attribute it doesn't
understand."
     So do we mean to say that any type other than
attribute if not understood then deny service or do we
mean something else.

2. bwtype has missing RR and RS in section 5.8 or are
these intentionally missing.

sunil bhargo

--- [email-masked] wrote:

> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> This draft is a work item of the Multiparty
> Multimedia Session Control Working Group of the
> IETF.
> 
> 	Title		: SDP: Session Description Protocol
> 	Author(s)	: M. Handley, et al.
> 	Filename	: draft-ietf-mmusic-sdp-new-20.txt
> 	Pages		: 45
> 	Date		: 2004-9-20
> 	
> This memo defines the Session Description Protocol
> (SDP). SDP is
> intended for describing multimedia sessions for the
> purposes of
> session announcement, session invitation, and other
> forms of
> multimedia session initiation.
> 
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-new-20.txt
> 
> To remove yourself from the I-D Announcement list,
> send a message to 
> [email-masked] with the word
> unsubscribe in the body of the message.  
> You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP.
> Login with the username
> "anonymous" and a password of your e-mail address.
> After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-mmusic-sdp-new-20.txt".
> 
> A list of Internet-Drafts directories can be found
> in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE
> /internet-drafts/draft-ietf-mmusic-sdp-new-20.txt".
> 	
> NOTE:	The mail server at ietf.org can return the
> document in
> 	MIME-encoded form by using the "mpack" utility.  To
> use this
> 	feature, insert the command "ENCODING mime" before
> the "FILE"
> 	command.  To decode the response(s), you will need
> "munpack" or
> 	a MIME-compliant mail reader.  Different
> MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing
> with
> 	"multipart" MIME messages (i.e. documents which
> have been split
> 	up into multiple messages), so check your local
> documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant
> mail reader
> implementation to automatically retrieve the ASCII
> version of the
> Internet-Draft.
> > _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

		
__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - 100MB free storage!
http://promotions.yahoo.com/new_mail 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: sunil bhargo <[email-masked]>
Date: Wed, 29 Sep 2004 03:25:04 -0700 (PDT)

Hi,
         If the presentation is encoded into number of
streams(MBR) one expects to see equivalent number of
m= sections if that is so then how can multiple
streams refer to the same m= section as implied below
:-

      "For applications where hierarchically encoded
streams are being sent to a unicast address, it may be
necessary to specify multiple transport ports.  This
is done using a similar notation to that used for IP
multicast addresses in the "c=" field:
m=<media> <port>/<number of ports> <transport> <fmt
list>
      In such a case, the ports used depend on the
transport protocol.For RTP, the default is that only
the even numbered ports are used for data with the
corresponding one-higher odd ports used for the RTCP
belonging to the RTP session, and the <number of
ports>
denoting the number of RTP sessions.  For example:
          m=video 49170/2 RTP/AVP 31 "
 
          If multiple streams don't refer to the same
section then <port>/<number of ports>  might not be
valid as each media section will give its own ports.
If multiple streams are mapped to one m= section then
how will the b=AS parameter be specified on per media
basis. But I might be missing something. 
          
sunil bhargo

--- Colin Perkins <[email-masked]> wrote:

> On 20 Sep 2004, at 20:42, [email-masked]
> wrote:
> Multimedia Session Control 
> > Working Group of the IETF.
> >
> > intended for describing multimedia sessions for
> the purposes of
> > session announcement, session invitation, and
> other forms of
> 
> There's a single change in this version: to remove
> the underspecified 
> "control" and "data" media types, aligning the SDP
> media types with 
> MIME media types. If there's a use for these media
> types they can be 
> registered separately. They've been removed here in
> the interests of 
> getting the base spec out.
> 
> Colin
> 
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com