Subject: [MMUSIC] Need text for a sub-registry in comedia-tls

From: Allison Mankin <[email-masked]>
Date: Mon, 26 Dec 2005 12:30:53 -0800

Jonathan,

I haven't seen you propose text for the hash-func sub-registry,
and time's a flying.  I see no reason other than the
sub-registry not to put comedia-tls on the January 5
IESG agenda.  (Since comedia-tls is a normative reference
for the two BFCP documents, we should definitely keep
comedia-tls moving).

Could you propose text before January 3?
A resubmitted internet-draft is NOT needed, I will us
a Note to the RFC Editor, so just send your proposed text
it to this list as early as you can, so that there can
be list consideration as well.

If you would like me to propose this text, let me know.
I can do so on the 1st when I return from some travel.

Thanks,

Allison

------- Forwarded Message

Date:    Tue, 13 Dec 2005 11:18:21 -0500
From:    Russ Housley <[email-masked]>
Subject: Re: comedia-tls iana considerations (was Re: [MMUSIC] Re: Progressing/
	  Resolving the IESG Review of the BFCP specs)

Correct.

At 11:02 AM 12/13/2005, Colin Perkins wrote:
>Allison,
>
>[cc'ing Jonathan Lennox, to ensure this doesn't get lost]
>
>To confirm: you're proposing an update to comedia-tls IANA
>considerations, not to sdp-bfcp?
>
>Colin
>
>
>
>
>On 12 Dec 2005, at 20:49, Allison Mankin wrote:
>>Thanks to Russ and Ted for the prompt re-review of the BFCP documents.
>>
>>Russ wrote:
>>>This document depends on the fingerprint Attribute definition in
>>>[10], which is draft-ietf-mmusic-comedia-tls-05.  The definition of
>>>the fingerprint attribute includes:
>>
>>     hash-func              =  "sha-1" / "sha-224" / "sha-256" /
>>                               "sha-384" / "sha-512" /
>>                               "md5" / "md2" / token
>>                               ; Additional hash functions can only
>>come
>>                               ; from updates to RFC 3279
>>
>>>RFC 3279 does not define the short strings used here.  RFC 3279
>>>provides ASN.1 object identifiers, which are not suitable
>>>here.  draft-ietf-mmusic-comedia-tls needs to say how these
>>>identifiers will be assigned.  Will IANA maintain a registry?
>>
>>Good point.  I'll note to the WG that Russ also sent this to the IESG
>>as a Last Call comment on the document.
>>
>>There are some instances when attribute values are registered in IANA,
>>not just the att-field.  One that is comparable is the key management
>>protocol identifier from draft-ietf-mmusic-kmgmt-ext.
>>
>>So a suggestion is to add to the IANA Considerations a crisp new
>>sub-registry for the hash-func values in the fingerprint attribute.
>>Its rules for registration can be that new identifiers are
>>permitted only for hash functions found in RFC 3279 or updates
>>of RFC 3279.
>>
>>Does the editor want to propose some IANA Considerations text?
>>
>>Allison (wearing the hat of an AD shepherd for comedia-tls)
>>
>>
>>
>>_______________________________________________
>>mmusic mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/mmusic
>

------- End of Forwarded Message

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Lennox <[email-masked]>
Date: Tue, 27 Dec 2005 10:46:16 -0500

> I can do so on the 1st when I return from some travel.

I sent a response asking if it would be useful for the hash function textual
name registry needed to be more broadly defined, but since I got no
response, I'll proceed with the appropriate text scoped just to comedia-tls.

-- 
Jonathan Lennox
[email-masked]