Subject: RE: [MMUSIC] Using RTSP with SIP

From: "Osher Hmelnizky" <[email-masked]>
Date: Sun, 5 Feb 2006 09:41:06 +0200

Hi,

What I'm trying to say is: why can't I use SIP for the call
establishment and RTSP for the stream control. How can synchronize two
protocols on the MRF side? 

On the client side it is no problem, but server side should be aware
that two sessions are interconnected to the one specific call.

Such synchronization I saw in the SIP/MRCP draft
(draft-ietf-speechsc-mrcpv2-09).

Thanks a lot

Osher

________________________________

From: Burger, Eric [mailto:[email-masked]] 
Sent: Friday, February 03, 2006 4:34 AM
To: Osher Hmelnizky
Subject: RE: [MMUSIC] Using RTSP with SIP

What are you trying to accomplish?  Two sessions are two sessions.  It
is either SIP or RTSP.  MRCP (not an IETF standard) has two, distinct
sessions.

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Osher Hmelnizky
Sent: Tuesday, January 10, 2006 7:26 AM
To: [email-masked]
Subject: [MMUSIC] Using RTSP with SIP

In the last MRCP draft (draft-ietf-speechsc-mrcpv2-09), in order to
synchronize the SIP and MRCP Sessios, defined

a=channel:xxx

as part of application SDP.

I'm trying to find out how I can synchronize SIP and RTSP streams at the
Media Server layer without any indication.

As a=channel defined at the SDP level can I use this parameter to sync
between SIP and RTSP Streams.

Thanks a lot.

Osher

 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Burger, Eric" <[email-masked]>
Date: Sun, 5 Feb 2006 08:17:22 -0500

That is something totally different and explicitly outside the scope of MRCPv2.  What you want is something like the mediactrl work (not chartered).  Search the I-D directory for mediactrl.  To subscribe, send 'subscribe mediactrl' to [email-masked]

________________________________________
From: Osher Hmelnizky [mailto:[email-masked]] 
Sent: Sunday, February 05, 2006 2:41 AM
To: Burger, Eric
Cc: [email-masked]
Subject: RE: [MMUSIC] Using RTSP with SIP

Hi,

What I'm trying to say is: why can't I use SIP for the call establishment and RTSP for the stream control. How can synchronize two protocols on the MRF side? 
On the client side it is no problem, but server side should be aware that two sessions are interconnected to the one specific call.
Such synchronization I saw in the SIP/MRCP draft (draft-ietf-speechsc-mrcpv2-09).

Thanks a lot

Osher

________________________________________
From: Burger, Eric [mailto:[email-masked]] 
Sent: Friday, February 03, 2006 4:34 AM
To: Osher Hmelnizky
Subject: RE: [MMUSIC] Using RTSP with SIP

What are you trying to accomplish?  Two sessions are two sessions.  It is either SIP or RTSP.  MRCP (not an IETF standard) has two, distinct sessions.

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Osher Hmelnizky
Sent: Tuesday, January 10, 2006 7:26 AM
To: [email-masked]
Subject: [MMUSIC] Using RTSP with SIP

In the last MRCP draft (draft-ietf-speechsc-mrcpv2-09), in order to synchronize the SIP and MRCP Sessios, defined
       a=channel:xxx

I'm trying to find out how I can synchronize SIP and RTSP streams at the Media Server layer without any indication.

As a=channel defined at the SDP level can I use this parameter to sync between SIP and RTSP Streams.

Thanks a lot.

Osher