Subject: RE: [MMUSIC] Re: comedia-tls: proposed change for certificate identities

From: "Hadriel Kaplan" <[email-masked]>
Date: Thu, 2 Feb 2006 16:49:46 -0500

FWIW, I like this change a lot.   
-hadriel

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jonathan Lennox
> Sent: Monday, January 30, 2006 8:22 AM
> To: Sam Hartman
> Cc: [email-masked]; EKR; [email-masked]; [email-masked];
> [email-masked]
> Subject: [MMUSIC] Re: comedia-tls: proposed change for certificate
> identities
> 
> On Sunday, January 29 2006, "Sam Hartman" wrote to "Jonathan Lennox,
> [email-masked], [email-masked], EKR, [email-masked],
> [email-masked]" saying:
> 
> > >>>>> "Jonathan" == Jonathan Lennox <[email-masked]> writes:
> >
> >
> >     Jonathan> * If your SDP was sent over an end-to-end authenticated
> >     Jonathan> and integrity-protected channel, there are no
> >     Jonathan> constraints on what identity you assert in your TLS
> >     Jonathan> certificates; you can use anything you want.  Identity
> >     Jonathan> is handled by the transporting protocol.
> >
> > What about hop-by-hop authenticated with each hop integrity protected.
> > IMHO in many environments, this presents acceptable man-in-the-middle
> > risk.  I think that it may present significantly easier to deal with
> > usability issues so I think it should at least be allowed if not
> > encouraged.
> 
> This will certainly be the most common way of securing SDP, I think --
> this
> describes how sips, i.e. sip over hop-by-hop TLS, works.  You're
> vulnerable
> to a broken or subverted sip proxy server, but otherwise you're safe.
> 
> If there's consensus that it's acceptable to allow this mode, I can add
> language allowing it.  However, I think this is a big enough change I'd
> like
> to hear positive consensus for it; this should get something more than
> just
> consent-by-silence from the working group.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Fri, 24 Feb 2006 15:53:24 +0000

On 30 Jan 2006, at 13:22, Jonathan Lennox wrote:
> On Sunday, January 29 2006, "Sam Hartman" wrote:
> This will certainly be the most common way of securing SDP, I think  
> -- this
> language allowing it.  However, I think this is a big enough change  
> I'd like
> to hear positive consensus for it; this should get something more  
> than just

There was a comment from Hadriel Kaplan supporting this change, but  
this is a big enough issue that I'd like more feedback before we go  
forward. Any comments from other members of the working group (or  
from the security ADs)?

Colin

---

From: Sam Hartman <[email-masked]>
Date: Fri, 24 Feb 2006 11:48:54 -0500

>>>>> "Colin" == Colin Perkins <[email-masked]> writes:

    Colin> There was a comment from Hadriel Kaplan supporting this change, but
    Colin> this is a big enough issue that I'd like more feedback before we go
    Colin> forward. Any comments from other members of the working group (or
    Colin> from the security ADs)?

As the one who proposed it, I supported it.

I'm a bit worried that this may be used to bootstrap lawful intercept
more easily than some other solution.  However I think that concern is
not very realistic because without this feature, I don't think we're
going to see usable media encryption as a reality.

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 25 Feb 2006 14:21:28 -0800

> forward. Any comments from other members of the working group (or

This seems like the right approach to me.

-Ekr