Subject: RE: [MMUSIC] Re: mmusic Digest, Vol 22, Issue 3

From: "Osher Hmelnizky" <[email-masked]>
Date: Tue, 7 Feb 2006 09:59:03 +0200

Hi,

When I'm thinking on the Media server implementation in the IMS
architecture, it's clear that most of the SIP devices running over the
UDP for call establishment. Most of the xml-types streaming/media
controls over the SIP using INFO approaches. I'm not sure that this is a
right approach for real time streaming control (explicitly for video).
RTSP2 (the last draft) defines RTSP to use TCP as transport protocol.
TCP is the right approach for real time streaming control.

I adopt SIP/Info streaming control for announcement and recording, but
for real time stream control I think it's not enough, because of the big
delays when, for example Application Server should be involved in the
DTMF detection and creation of the appropriate control to the media
server.

SIP/MRCP2&RTSP seems me right approach for media server control. SIP for
session establishment and MRCP or RTSP for the streaming control and
media services.
I think it should be one common technique for synchronization between
SIP and other protocol like RTSP. It may be done using the SDP(for
example SIP/MRCP2).

Any thoughts?

Kind regards

Osher

-----Original Message-----
From: Robert Hagens [mailto:[email-masked]] 
Sent: Monday, February 06, 2006 5:03 PM
To: 'Colin Perkins'; 'Teodora Guenkova-Luy'
Cc: [email-masked]; Osher Hmelnizky
Subject: RE: [MMUSIC] Re: mmusic Digest, Vol 22, Issue 3

The other non-standard aspect of SIP/RTSP is that there is a good chuck
of
overlap between SIP and RTSP. If you (for example) negotiate the SDP
with
SIP, you really don't need to bother with the DESCRIBE and SETUP of
RTSP.
After the SIP negotiation, you're ready to PLAY. This leads one to
question
if all of the complexity of RTSP is required in these cases; a simpler
version of media control being desirable.

Rob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of
Colin Perkins
Sent: Monday, February 06, 2006 2:57 AM
To: Teodora Guenkova-Luy
Cc: [email-masked]; [email-masked]
Subject: Re: [MMUSIC] Re: mmusic Digest, Vol 22, Issue 3

SDP has the concept of "m=control ..." to signal other control  
sessions. If one were to define how to signal RTSP sessions could be  
setup using SIP, that would likely be the appropriate way to do it.

This subject comes up regularly - maybe it would be appropriate for  
someone to write a draft fleshing out the details?

Colin

On 6 Feb 2006, at 09:48, Teodora Guenkova-Luy wrote:
> SIP and RTSP are two different sessions. Their frameworks do not  
> exclude the scenario that both of them shall be synchronised,  
> however, there is no existing solution on such synchronisation. You  
> can synchronize SIP and RTSP only at presentation level (i.e. SDP),  
> like done for SIP and MRCP, as at session level SIP and RTSP are  
> different instances that are not aware of each other. You could  
> "misuse" the SDP SIP/MRCP attribute "a=channel:xxx" with your own  
> parameters for RTSP, or use the SDP "i=" line also with your own  
> paramentes, or define your own attribute line, e.g.  
> "a=stacksynch:whatever". However, all these are non-standard  
> solutions.
> KR,
> Teodora
>
> [email-masked] wrote:
>
>>
>> Message: 1
>> Date: Sun, 5 Feb 2006 09:41:06 +0200
>> From: "Osher Hmelnizky" <[email-masked]>
>> Subject: RE: [MMUSIC] Using RTSP with SIP
>> To: "Burger, Eric" <[email-masked]>
>> Cc: [email-masked]
>> Message-ID:
>> 	 
>> <[email-masked]>
>> Content-Type: text/plain; charset="us-ascii"
>>
>> Hi,
>>
>>
>> What I'm trying to say is: why can't I use SIP for the call
>> establishment and RTSP for the stream control. How can synchronize  
>> two
>> protocols on the MRF side?
>> On the client side it is no problem, but server side should be aware
>> that two sessions are interconnected to the one specific call.
>>
>> Such synchronization I saw in the SIP/MRCP draft
>> (draft-ietf-speechsc-mrcpv2-09).
>>
>>
>> Thanks a lot
>>
>>
>> Osher
>>
>>
>> ________________________________
>>
>> From: Burger, Eric [mailto:[email-masked]] Sent: Friday,  
>> February 03, 2006 4:34 AM
>> To: Osher Hmelnizky
>> Subject: RE: [MMUSIC] Using RTSP with SIP
>>
>>
>> What are you trying to accomplish?  Two sessions are two  
>> sessions.  It
>> is either SIP or RTSP.  MRCP (not an IETF standard) has two, distinct
>> sessions.
>>
>>
>> ________________________________
>>
>> From: [email-masked] [mailto:[email-masked]] On  
>> Behalf
>> Of Osher Hmelnizky
>> Sent: Tuesday, January 10, 2006 7:26 AM
>> To: [email-masked]
>> Subject: [MMUSIC] Using RTSP with SIP
>>
>>
>> In the last MRCP draft (draft-ietf-speechsc-mrcpv2-09), in order to
>> synchronize the SIP and MRCP Sessios, defined
>>
>> a=channel:xxx
>>
>>
>> as part of application SDP.
>>
>>
>> I'm trying to find out how I can synchronize SIP and RTSP streams  
>> at the
>> Media Server layer without any indication.
>>
>>
>> As a=channel defined at the SDP level can I use this parameter to  
>> sync
>> between SIP and RTSP Streams.
>>
>>
>> Thanks a lot.
>>
>>
>> Osher
>>
>>
>>
>>
>>
>> -------------- next part --------------
>> An HTML attachment was scrubbed...
>> URL: http://www1.ietf.org/pipermail/mmusic/attachments/ 
>> 20060205/0ce380c0/attachment.htm
>>
>> ------------------------------
>>
>> Message: 2
>> Date: Sun, 5 Feb 2006 08:17:22 -0500
>> From: "Burger, Eric" <[email-masked]>
>> Subject: RE: [MMUSIC] Using RTSP with SIP
>> To: "Osher Hmelnizky" <[email-masked]>
>> Cc: [email-masked]
>> Message-ID:
>>
<[email-masked]>
>> Content-Type: text/plain;	charset="iso-8859-1"
>>
>> That is something totally different and explicitly outside the  
>> scope of MRCPv2.  What you want is something like the mediactrl  
>> work (not chartered).  Search the I-D directory for mediactrl.  To  
>> subscribe, send 'subscribe mediactrl' to  
>> [email-masked]
>>
>> ________________________________________
>> From: Osher Hmelnizky [mailto:[email-masked]]  
>> Sent: Sunday, February 05, 2006 2:41 AM
>> To: Burger, Eric
>> Cc: [email-masked]
>> Subject: RE: [MMUSIC] Using RTSP with SIP
>>
>> Hi,
>>
>> What I'm trying to say is: why can't I use SIP for the call  
>> establishment and RTSP for the stream control. How can synchronize  
>> two protocols on the MRF side? On the client side it is no  
>> problem, but server side should be aware that two sessions are  
>> interconnected to the one specific call.
>> Such synchronization I saw in the SIP/MRCP draft (draft-ietf- 
>> speechsc-mrcpv2-09).
>>
>> Thanks a lot
>>
>> Osher
>>
>> ________________________________________
>> From: Burger, Eric [mailto:[email-masked]] Sent: Friday,  
>> February 03, 2006 4:34 AM
>> To: Osher Hmelnizky
>> Subject: RE: [MMUSIC] Using RTSP with SIP
>>
>> What are you trying to accomplish?  Two sessions are two  
>> sessions.  It is either SIP or RTSP.  MRCP (not an IETF standard)  
>> has two, distinct sessions.
>>
>> ________________________________________
>> From: [email-masked] [mailto:[email-masked]] On  
>> Behalf Of Osher Hmelnizky
>> Sent: Tuesday, January 10, 2006 7:26 AM
>> To: [email-masked]
>> Subject: [MMUSIC] Using RTSP with SIP
>>
>> In the last MRCP draft (draft-ietf-speechsc-mrcpv2-09), in order  
>> to synchronize the SIP and MRCP Sessios, defined
>>       a=channel:xxx
>>       as part of application SDP.
>>
>> I'm trying to find out how I can synchronize SIP and RTSP streams  
>> at the Media Server layer without any indication.
>>
>> As a=channel defined at the SDP level can I use this parameter to  
>> sync between SIP and RTSP Streams.
>>
>> Thanks a lot.
>>
>> Osher
>>
>>
>>
>>
>>
>>
>> ------------------------------
>>
>> _______________________________________________
>> mmusic mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/mmusic
>>
>>
>> End of mmusic Digest, Vol 22, Issue 3
>> *************************************
>>
>
> -- 
> -----------------------------------------
> Teodora Guenkova-Luy
>
> Dept. Distributed Systems, University of Ulm, Oberer Eselsberg,  
> 89069 Ulm, Germany
>
> Tel.: +49 (0731) 502-4148 FAX: +49 (0731) 502-4142
>
> e-Mail: [email-masked]
>
> Home Page: http://www-vs.informatik.uni-ulm.de/~Guenkova/
> -----------------------------------------
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Teodora Guenkova-Luy <[email-masked]>
Date: Tue, 07 Feb 2006 14:45:08 +0100

Dear Osher,
I see some problems with your task definition/requirements:
1. For real-time streaming you already have some kind of streaming 
control through RTCP (see also RFC 3551)
2. As SIP and RTSP are much more complex then the RTCP controls, they 
should be used only in cases that the application needs to adapt (i.e. 
to re-negotiate capabilities) and not for permanent monitoring/controls.
3. The classical TCP is not a solution when controlling mobile 
environments. It can be even an obstacle, when the underlying physical 
network is not faultless (e.g. thread failures due to carrier 
disruptions). The better solution is UDP (SIP), however, it is also not 
a perfect solution. The problem on this place is that the development of 
real-time applications considers currently only the media alone (i.e. 
aproaches like FEC, ARQ, etc.), what is not considered till now is that 
the controls for the real-time media are even more urgent then the media 
itself. SIP actually also does not provide a complete solution but 
refers to RFC 2914.
So if your media server does not care about the mobility of the clients, 
you can simplify your task and stick to TCP with both SIP and RTSP.
IMHO it is right to use SDP for signalling the association of the 
control sessions with SIP and RTSP. However, currently SDP does not 
really provide a specific solution for your problem and probably will 
not be further enhanced and developed in the future to provide a 
solution (see draft-ietf-mmusic-sdpng-trans-04).
So if you do not care about a standardized solution, but care about the 
faultlessness of your control signalling in non-mobile environments, you 
can use combinations of SIP (with TCP), RTSP and SDP and enhance them 
according to your needs using the respective enhancement mechanisms of 
these protocols. If you shall care about the clients mobility you have 
to stick to UDP (as carrier of SIP and RTSP) and ensure its 
faultlessness with e.g. DiffServ-like mechanisms.
KR,
Teodora

IMHO, SDP is the correct pla

Dept. Distributed Systems, University of Ulm, 
Oberer Eselsberg, 89069 Ulm, Germany

Tel.: +49 (0731) 502-4148 
FAX: +49 (0731) 502-4142