Subject: Re: [MMUSIC] SIP-RSTP Draft

From: Colin Perkins <[email-masked]>
Date: Thu, 2 Mar 2006 16:22:39 +0000

I'm not sure I understand this viewpoint. As you note below, there is  
a lot in common between a SIP and an RTSP stack, and I would expect  
there to be a lot of scope for code reuse. I don't see much potential  
for savings due to combining the two protocols, especially since you  
don't avoid the application logic complexity.

Colin

On 28 Feb 2006, at 00:03, Mahesh Govind wrote:
> HI,
>
>
>
> I have few questions here , from an implementor’s point of view.
>
> Chances are there that these may be discussed many times .
>
>
> Instead of having dual stack, whether a convergence of RTSP with  
> sip is better?
>
> This is because if you compare the syntax and semantics of a RTSP  
> and SIP message
>
> I think they have many things in common.
>
>
> 1)       Message structure
>
> 2)       Headers
>
> 3)       Message body
>
> 4)       Authorization and Authentication
>
> 5)       Problems with Nat and fire wall
>
>
> Also sip provided many more things which RTSP lacks.
>
>
> Why should I implement two protocols, which does some what similar  
> job.
>
> If you think from an endpoint perspective, where you have memory  
> constraints, if I can avoid
>
> a protocol stack , I can save many things.
>
> Another question is if I am using RTSP for media control, I have to  
> use some other mechanism
>
> to fetch the details of  the media streams.
>
>
>
> Consider a use case of a device such as an Integrated set top box,  
> which provides a voip phone facility also.
>
> For making such a device I may be using sip .SIP may be used to  
> fetch the program details, sip may be used to
>
> Make phone calls, if we can add some (missing) features to sip  
> which will help us to have control media streams,
>
> I can leave with a single protocol for all the signaling purpose.
>
>
> I think it may be better if we can have an apple to apple  
> comparison with SIP and RTSP .It may not seems to be fully
>
> Logical, still I think it may be worth. I think such a comparison  
> may cover
>
> 1)       Syntax
>
> 2)       Semantics
>
> 3)       Entities
>
> 4)       Issues which are common to both protocols
>
> 5)       Advantages of each one over other.
>
> If it is ok I can provide such a comparison.
>
>
> With thanks and regards
>
> Mahesh
>
>
>
>
>
>
>
> -----Original Message-----
> From: Montpetit Marie-Jose-MGIF0300 [mailto:[email-masked]]
> Sent: Tuesday, February 28, 2006 3:34 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [MMUSIC] SIP-RSTP Draft
>
>
> Attached. We missed the deadline :-( With the Winter Break here I  
> guess it was unavoidable.
>
>
> I guess we can start a discussion? Xavier Marjou and I will be at  
> the meeting.
>
>
> Marie-Jose
>
>
> Marie-Jose Montpetit, Eng. Ph.D.
>
> Motorola Connected Home Solutions
>
> NEW PHONE: +1-781-372-8115
>
> [email-masked]
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Mahesh Govind <[email-masked]>
Date: Fri, 03 Mar 2006 08:11:18 +0900

HI,

Yes there will be a lot of common code. 
I think semantics also we can map.

For example, we can map most of the methods to SIP methods or procedures.
I consider methods like PAUSE as some thing like a far end hold.
Also I think SETUP may be an invite with appropriate media parameters, and
PLAY may be a reinvite and TEARDOWN to BYE .OPTIONS is already in SIP.
If we can add the missing headers to sip I think we can achieve most of the
stuff, with out addition of new code or adding much complexity to
application. 
I think this may be good to small devices or integrated communication
endpoints. Application still can call well written APIs to achieve RTSP like
functionality. It may not even know, about the lower layer stuff.

Also most of the cases with RTSP one need some other protocol to carry the
program details. SIP can be used for all.

With thanks and regards
Mahesh

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]] 
Sent: Friday, March 03, 2006 1:23 AM
To: Mahesh Govind
Cc: 'Montpetit Marie-Jose-MGIF0300'; [email-masked]
Subject: Re: [MMUSIC] SIP-RSTP Draft

Colin

On 28 Feb 2006, at 00:03, Mahesh Govind wrote:
> HI,
>
>
>
> I have few questions here , from an implementor's point of view.
>

---

From: Colin Perkins <[email-masked]>
Date: Fri, 3 Mar 2006 00:13:49 +0000

Mahesh,

My point was that there may be little benefit from doing the mapping  
of RTSP onto SIP, since you won't save much, if anything, in code  
size or complexity, compared to a well engineered system that shares  
code between the two protocol implementations.

Can I see advantages of initiating a session using SIP, then handing  
over to RTSP for control? Perhaps. Recasting RTSP within SIP? The  
benefit of that is a lot less clear.

Colin

---

From: Mahesh Govind <[email-masked]>
Date: Fri, 03 Mar 2006 10:04:07 +0900

HI Colin,

I  may not be 100 % correct but,
The question which is always popping up was, why can't we see streaming 
also as a sip session (since sip is defined as a protocol for .....)

Also as a user of both protocols, following questions also pops up,

1) Can we start and stop a media stream using existing SIP  mechanisms?
   RTSP also does the same thing
2) Is there any difference between a multimedia stream initiated with sip ,
and that initiated with RTSP .
I think for the live stream the user cannot do much different things with
both the protocol .But for a stored stream, RTSP achieves functionality like
ff and reverse play with the help of headers. I think we can achieve these
VCR type functionality with out much overhead/complexity with SIP.

By mapping I meant achieving the functionality, for the user of the
protocol.

I think a sip only solution, which uses the existing sip semantics, may be
less complex than , first using sip and then switching to a different
protocol .

With regards
Mahesh

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]] 
Sent: Friday, March 03, 2006 9:14 AM
To: Mahesh Govind
Cc: 'Montpetit Marie-Jose-MGIF0300'; [email-masked]
Subject: Re: [MMUSIC] SIP-RSTP Draft

Mahesh,

Colin