Subject: [MMUSIC] Re: Comments on draft-ietf-mmusic-ice-07

From: lazzaro <[email-masked]>
Date: Mon, 20 Mar 2006 12:11:44 -0800

On Mar 20, 2006, at 6:35 AM, Jonathan Rosenberg wrote:
> Hmm; I thought this definition was at least common across audio  
> codecs. I can update the text to say that this is specific for audio.

Audio voice codecs can be carried under RFC 3640
(mpeg4-generic), which uses the marker bit in a different
way than the talk-spurt semantics of normal voice codecs:

Marker (M) bit: The M bit is set to 1 to indicate that the RTP packet
payload contains either the final fragment of a fragmented Access
Unit or one or more complete Access Units.

[...]

3.2.3.1.  Fragmentation

    A packet SHALL carry either one or more complete Access Units, or a
    single fragment of an Access Unit.  Fragments of the same Access  
Unit
    have the same time stamp but different RTP sequence numbers.  The
    marker bit in the RTP header is 1 on the last fragment of an Access
    Unit, and 0 on all other fragments.

So, given than voice codecs would most be putting a
complete Access Unit in every packet (and most other
audio codecs too, I would think), every marker bit in
the stream is set to 1.

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 20 Mar 2006 16:52:32 -0500

Right, this was clarified in the meeting today. The agreement was that 
the ICE spec would say that the marker bit can be used when applicable, 
which will depend on the media type (audio only) and the codec.

-Jonathan R.

lazzaro wrote:

>    single fragment of an Access Unit.  Fragments of the same Access  Unit

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com