Subject: [MMUSIC] Re: Handling of incoming INVITE request for different MSRP session

From: Miguel Garcia <[email-masked]>
Date: Fri, 28 Apr 2006 11:37:21 +0300

So now posting to MMUSIC and the OMA mailing list.

I have cut the discussion only to one relevant point

Sudha wrote:
> With reference to sec. 8.1 of draft-ietf-simple-message-sessions-14.txt 
> the format of the m= line is:
> m=<media> <port> <protocol> <format list>
> The format list field MUST be set to "*".
> The media doesn't accomadate for the MSRP sessionId.
> The SessionId is specified in the url of the "a=path" attribute. Can the 
> session Id be specified in the format list?
> 

So, what you are saying is that if someone wants to establish a regular 
MSRP session for chatting, and a side-by MSRP session for file transfer, 
and it wants to multiplex both MSRP sessions over the same TCP 
connection, both m=message lines will be equal. True. What is the 
problem? I can't see a problem, one m=message line will have the typical 
MSRP attributes, the other one will contain, in addition to the typical, 
those specific for the file transfer. I don't see the problem.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Sudha <[email-masked]>
Date: Fri, 28 Apr 2006 14:43:43 +0530

Hi all,
There wont be any problem if normal MSRP chat and Filetransfer takes place  
in 2 diffrent MSRP sessions, each of them having their own attributes.

But what I meant to say in the previous discussions is:
-File Transfer and Chat cant take place in single session.

-I mistook the flow of SDP headers with two m= lines in the following way:
     v=0
     o=alice 2890844526 2890844527 IN IP4 alice.example.com
     s= -
     c=IN IP4 alice.example.com
     t=0 0
     m=message 7394 TCP/MSRP *
     m=message 7394 TCP/MSRP *
     a=accept-types:text/plain
     a=path:msrp://alice.example.com:7394/2s93i;tcp
     a=filename:My cool picture.jpg
     a=filetype:image/jpeg
This would certainly create a problem coz, we will not be able to specify,  
the Session Ids of MSRP Sessions and their accept-types.

Sample SDP Message with 2 m= lines:
     v=0
     o=alice 2890844526 2890844527 IN IP4 alice.example.com
     s= -
     c=IN IP4 alice.example.com
     t=0 0
     m=message 7394 TCP/MSRP *
     a=accept-types:text/plain
     a=path:msrp://alice.example.com:7394/2s93i;tcp
     m=message 7394 TCP/MSRP *
     a=path:msrp://atlanta.example.com:7394/jshA7we;tcp
     i=This is my latest picture
     a=sendonly
     a=accept-types:*
     a=filename:My cool picture.jpg
     a=filetype:image/jpeg
     ....

Hope the above flow is valid, and I feel there wont be any problem.

Thanks n Regds,
Sudha.

On Fri, 28 Apr 2006 14:07:21 +0530, Miguel Garcia  
<[email-masked]> wrote:

>> The SessionId is specified in the url of the "a=path" attribute. Can  
>> the session Id be specified in the format list?
>>
>

-- 
Best Regards,
Sudha V.S
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Sudha <[email-masked]>
Date: Fri, 28 Apr 2006 16:24:33 +0530

Hi Gonzali,
Refer to inline discussion.

On Fri, 28 Apr 2006 14:50:06 +0530, Gonzalo Camarillo  
<[email-masked]> wrote:

> Hi Sudha,
>
> I do not fully understand what you mean, but note that you can transfer  
> files within an MSRP session as usual. In that case, you would only need  
> a single 'm' line, as usual.
	Did you mean to say, File transfer can take place in the same session  
which is used for chat? This is quiet impossible coz, you will not be able  
to differentiate which is the data frm the file and chat-data. Further  
MSRP Chat session will be terminated once the file transfer is complete.
>
> If you want to use another m line to transfer the file so that the other  
> party has a chance to accept or reject the transfer, you would add a  
> second 'm' line whose attributes would contain a different MSRP session  
> ID.
>
> I hope this helps,
>
> Cheers,
>
> Gonzalo
>
> Sudha wrote:
>> Hi all,
>> There wont be any problem if normal MSRP chat and Filetransfer takes  
>> place in 2 diffrent MSRP sessions, each of them having their own  
>> attributes.
>> This would certainly create a problem coz, we will not be able to  
>> specify, the Session Ids of MSRP Sessions and their accept-types.
>>>> With reference to sec. 8.1 of  
>>>> draft-ietf-simple-message-sessions-14.txt the format of the m= line  
>>>> is:
>>> So, what you are saying is that if someone wants to establish a  
>>> regular MSRP session for chatting, and a side-by MSRP session for file  
>>> transfer, and it wants to multiplex both MSRP sessions over the same  
>>> TCP connection, both m=message lines will be equal. True. What is the  
>>> problem? I can't see a problem, one m=message line will have the  
>>> typical MSRP attributes, the other one will contain, in addition to  
>>> the typical, those specific for the file transfer. I don't see the  
>>> problem.
>>>
>>> /Miguel
>>>
>>    --Best Regards,
>> Sudha V.S
>>    
>> ------------------------------------------------------------------------
>>  This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended  
>> solely for the use of the addressee(s). If you are not the intended  
>> recipient, please notify the sender by e-mail and delete the original  
>> message.Global Edge Software Ltd has taken every reasonable precaution  
>> to minimize this risk, but is not liable for any damage you may sustain  
>> as a result of any virus in this e-mail. You should carry out your own  
>> virus checks before opening the e-mail or attachment. Global Edge  
>> Software Ltd reserves the right to monitor and review the content of  
>> all messages sent to or from this e-mail address

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 28 Apr 2006 12:20:06 +0300

Hi Sudha,

If you want to use another m line to transfer the file so that the other 
party has a chance to accept or reject the transfer, you would add a 
second 'm' line whose attributes would contain a different MSRP session ID.

I hope this helps,

Cheers,

Gonzalo

Sudha wrote:
>>> draft-ietf-simple-message-sessions-14.txt the format of the m= line is: