Subject: RE: [MMUSIC] How to put multiple ptimes in SDP?

From: "Elwell, John" <[email-masked]>
Date: Fri, 05 May 2006 13:39:30 +0100

Magnus,

Apologies, I missed the mention of "scope" (in the sense of "range") in the
requirements section - I was looking at section 4.1.1. Comments:

1. I prefer the approach of extending SDP to the grouping and SDPng
approaches.
2. I prefer an attribute dedicated to ptime (as you propose) rather than the
more generic approach taken in the draft.
3. Like you, I am not so sure about the address-per-codec aspects - my
immediate concern is a solution for ptime.

A further remark on this last point. If a transcoder intervenes depending on
codec, how does this work with key management for SRTP? It seems to break
both SDescriptions and MIKEY.

John

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]] 
> Sent: 04 May 2006 17:03
> To: Elwell, John
> Cc: Colin Perkins; [email-masked]
> Subject: Re: [MMUSIC] How to put multiple ptimes in SDP?
> 
> Hi John,
> 
> I was not excluding the potential of listing multiple ptime 
> values or a 
> range. That is included in the requirements of the referenced 
> draft. So 
> please review that draft and see if that is in accordance with your 
> wishes. I think my proposed attribute even indicate that structure.
> 
> Cheers
> 
> Magnus
> 
> 
> 
> Elwell, John wrote:
> > Magnus,
> > 
> > I agree that work in this area would be desirable. However, 
> rather than
> > simply a recommended ptime I believe we should consider 
> maximum and minimum
> > recommended values. There are some devices that are concerned about
> > receiving very long packets, because of buffer space and 
> the negative impact
> > on quality. There are also devices that are concerned about 
> receiving very
> > short packets, because of the processing cycles needed to 
> handle the fast
> > arrival rate. Does anyone else see this as an issue?
> > 
> > John
> > 
> >> -----Original Message-----
> >> From: Magnus Westerlund [mailto:[email-masked]] 
> >> Sent: 04 May 2006 13:08
> >> To: Colin Perkins
> >> Cc: [email-masked]
> >> Subject: Re: [MMUSIC] How to put multiple ptimes in SDP?
> >>
> >> Hi,
> >>
> >> As this discussion pops up again and again I think that is 
> >> might be time 
> >> to fix it for people that really want to indicate a specific 
> >> amount of 
> >> media for a packet. There is a draft:
> >> http://www.ietf.org/internet-drafts/draft-xu-mmusic-sdp-codec-
> >> param-01.txt
> >>
> >> That contains a proposal for this together with some other 
> things. I 
> >> think the general requirements for the the ptime replacement 
> >> is pretty 
> >> good. I personally don't like the solution. I personally 
> >> think a single 
> >> attribute for recommended amount of media time in the payload 
> >> should be 
> >> defined. example: a=rptime:<pt> <value, values, or range>
> >>
> >> I am also quite questioning on the per payload transport 
> >> addresses. This 
> >> is in my opinion not in line with the structure of the media block 
> >> structure and how it relate to RTP sessions etc.
> >>
> >> So I think people should review this draft and provide 
> >> feedback on this 
> >> topic to possibly make some progress here.
> >>
> >> Cheers
> >>
> >> Magnus Westerlund
> >>
> >> Multimedia Technologies, Ericsson Research EAB/TVA/A
> >> 
> ----------------------------------------------------------------------
> >> Ericsson AB                | Phone +46 8 4048287
> >> Torshamsgatan 23           | Fax   +46 8 7575550
> >> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> >>
> >> _______________________________________________
> >> mmusic mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/mmusic
> >>
> > 
> 
> 
> -- 
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research EAB/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 9 May 2006 10:39:51 +0300

Hi,
I also see the need for the ptime extension described in the draft.

I prefer to see the extension to SDP for ptime per payload type but I am not sure why we need the range. The only requirement I saw is due to receiver buffer size, this is not a codec specific requirement and there is a maxptime parameter defined for media in the sdp draft.

I am not sure about the usage of address per payload type, I understand the example given so if media security is also addressed I would not object to such an extension.

Roni Even

> Sent: Thursday, May 04, 2006 3:08 PM
> To: Colin Perkins
> Cc: [email-masked]
> As this discussion pops up again and again I think that is might be time
> to fix it for people that really want to indicate a specific amount of
> http://www.ietf.org/internet-drafts/draft-xu-mmusic-sdp-codec-param-01.txt
> 
> That contains a proposal for this together with some other things. I
> think the general requirements for the the ptime replacement is pretty
> good. I personally don't like the solution. I personally think a single
> attribute for recommended amount of media time in the payload should be
> I am also quite questioning on the per payload transport addresses. This
> So I think people should review this draft and provide feedback on this

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 09 May 2006 09:00:53 +0100

Roni,

The range is needed in my opinion because of UAs that are unable to process
packets above a certain rate. I recall trying to test our UAs with devices
that fell over if we sent audio packets every 10ms.

John 

> From: Even, Roni [mailto:[email-masked]] 
> Sent: 09 May 2006 08:40
> To: Magnus Westerlund; Colin Perkins
> Cc: [email-masked]
> Subject: RE: [MMUSIC] How to put multiple ptimes in SDP?
> 
> Hi,
> I prefer to see the extension to SDP for ptime per payload 
> type but I am not sure why we need the range. The only 
> requirement I saw is due to receiver buffer size, this is not 
> a codec specific requirement and there is a maxptime 
> parameter defined for media in the sdp draft.
> 
> I am not sure about the usage of address per payload type, I 
> understand the example given so if media security is also 
> addressed I would not object to such an extension.
> 
> Roni Even
>

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 9 May 2006 11:05:21 +0300

John,
I understand this is like minptime, but is this per codec or per media. It looks to me that it is a media parameter.
Roni

> From: Elwell, John [mailto:[email-masked]]
> Sent: Tuesday, May 09, 2006 11:01 AM
> To: Even, Roni; Magnus Westerlund; Colin Perkins
> Cc: [email-masked]

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 09 May 2006 10:20:07 +0100

Roni,

Yes, you are probably right. The minimum packet time is likely to be
independent of codec type (except that obviously for framed codecs the
minimum packet time cannot be less than one frame). Although perhaps some
implementations could handle a slightly faster packet rate for G.711, say,
than for codecs that require more processing.

John 

> Sent: 09 May 2006 09:05
> To: Elwell, John; Magnus Westerlund; Colin Perkins
> Cc: [email-masked]
> I understand this is like minptime, but is this per codec or 
> per media. It looks to me that it is a media parameter.
> Roni
>