Subject: Re: [MMUSIC] IPR on the ICE draft

From: lazzaro <[email-masked]>
Date: Thu, 4 May 2006 14:01:30 -0700

On May 4, 2006, at 10:19 AM, Colin Perkins wrote:
> I find these terms problematic, since they appear to effectively  
> prohibit open source implementations of ICE. In particular, there  
> are many popular open source projects that lack the resources to  
> conduct legal negotiations for an IPR license, and there is no  
> guarantee that a royalty free license will be available at the  
> conclusion to such negotiations.
>
> Given the importance of ICE to widespread and interoperable  
> deployment of VoIP applications, such a restriction on free  
> implementation is disturbing.

I share Colin's concerns on this ...

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: lazzaro <[email-masked]>
Date: Mon, 8 May 2006 09:49:18 -0700

On May 8, 2006, at 9:00 AM, Cullen Jennings wrote:
> It's a very interesting quesiton to ask what part of ICE does not  
> have prior art. The online gaming people have been doing this stuff  
> for a long time.

On this web page:

http://alumnus.caltech.edu/~dank/peer-nat.html

Dan Kegel states that he implemented NAT
traversal for Activision in 1997 (scroll down
to end of page), and believes it was novel
at the time.  So, that's one stake in the
ground for prior art (no indication on the web
page if there was a patent taken out by Activision).

However, I was under the (mistaken?) impression
that IETF WGs had to work under the assumption
that all IPR claims were valid, and make decisions
on using IPR in WG items based on that
assumption ... otherwise the temptation for
ethically-challenged IPR holders to arrange
for "independent" voices to claim "don't worry,
there is prior art, let it in the standard" when in
fact there is no prior art is too high.

---
John Lazzaro