Subject: RE: [MMUSIC] How to put multiple ptimes in SDP?

From: "Elwell, John" <[email-masked]>
Date: Thu, 04 May 2006 16:19:41 +0100

Magnus,

I agree that work in this area would be desirable. However, rather than
simply a recommended ptime I believe we should consider maximum and minimum
recommended values. There are some devices that are concerned about
receiving very long packets, because of buffer space and the negative impact
on quality. There are also devices that are concerned about receiving very
short packets, because of the processing cycles needed to handle the fast
arrival rate. Does anyone else see this as an issue?

John

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]] 
> Sent: 04 May 2006 13:08
> To: Colin Perkins
> Cc: [email-masked]
> Subject: Re: [MMUSIC] How to put multiple ptimes in SDP?
> 
> Hi,
> 
> As this discussion pops up again and again I think that is 
> might be time 
> to fix it for people that really want to indicate a specific 
> amount of 
> media for a packet. There is a draft:
> http://www.ietf.org/internet-drafts/draft-xu-mmusic-sdp-codec-
> param-01.txt
> 
> That contains a proposal for this together with some other things. I 
> think the general requirements for the the ptime replacement 
> is pretty 
> good. I personally don't like the solution. I personally 
> think a single 
> attribute for recommended amount of media time in the payload 
> should be 
> defined. example: a=rptime:<pt> <value, values, or range>
> 
> I am also quite questioning on the per payload transport 
> addresses. This 
> is in my opinion not in line with the structure of the media block 
> structure and how it relate to RTP sessions etc.
> 
> So I think people should review this draft and provide 
> feedback on this 
> topic to possibly make some progress here.
> 
> Cheers
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research EAB/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 04 May 2006 18:03:16 +0200

Hi John,

I was not excluding the potential of listing multiple ptime values or a 
range. That is included in the requirements of the referenced draft. So 
please review that draft and see if that is in accordance with your 
wishes. I think my proposed attribute even indicate that structure.

Cheers

Magnus

-- 

Magnus Westerlund