Subject: [MMUSIC] relationship between RTSP request URL and RTP-Info stream URL.

From: "Patankar, Sujay" <[email-masked]>
Date: Tue, 25 Jul 2006 09:56:14 +0530

Hi,
Can someone tell me the relationship between the URL present in the
first line of an RTSP request (specifically the PLAY request), and the
URL present in the RTP-Info in the reply of a PLAY request?
Will the request URL be the same in all RTSP requests in one RTSP
session?
Thanks,
Sujay.

"This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you."

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Kylin Wei <[email-masked]>
Date: Tue, 25 Jul 2006 14:34:43 +0800

Hi Sujay: 

You need to know what are aggregate control and aggregate control URI. 
Aggregate control: The concept of controlling multiple streams
             using a single timeline, generally maintained by the
             server. A client, for example, uses aggregate control when
             it issues a single play or pause message to simultaneously
             control both the audio and video in a movie.

        Aggregate control URI: The URI used in an RTSP request to refer
             to and control an aggregated session. It normally, but not
             always, corresponds to the presentation URI specified in
             the session description. See Section 11.3 for more   
             information.

If a PLAY request URI is an aggregate control URI, it will contain all
stream URIs presented in RTP-Info field. Such as:
C->M: PLAY rtsp://example.com/twister.3gp/ RTSP/2.0        
M->C: RTSP/2.0 200 OK         
         RTP-Info: url="rtsp://example.com/twister.3gp/trackID=4"
            ssrc=0D12F123:seq=12345;rtptime=3450012,
           url="rtsp://example.com/twister.3gp/trackID=1";
            ssrc=4F312DD8:seq=54321;rtptime=2876889

A SETUP request URI must not be an aggregate control URI. So it may be not
same as a PLAY request URI.

Kylin Wei 

> -----Original Message-----
> From: Patankar, Sujay [mailto:[email-masked]]
> Sent: Tuesday, July 25, 2006 12:26 PM
> To: [email-masked]
> Subject: [MMUSIC] relationship between RTSP request URL and RTP-Info
stream
> URL.
> "This email message and any attachments are confidential information of
Starent
> Networks, Corp. The information transmitted may not be used to create or
change
> any contractual obligations of Starent Networks, Corp.  Any review,
> retransmission, dissemination or other use of, or taking of any action in
> reliance upon this e-mail and its attachments by persons or entities other
than
> the intended recipient is prohibited. If you are not the intended
recipient,
> please notify the sender immediately -- by replying to this message or by
> sending an email to [email-masked] -- and destroy all
copies
> of this message and any attachments without reading or disclosing their
> contents. Thank you."
>