Subject: [MMUSIC] a rtsp question how to determine the receiging ports on unicast case?

From: "woo john" <[email-masked]>
Date: Mon, 24 Jul 2006 03:18:05 +0000

hi,
When using RTSP to play an unicast stream,how is the receiving ports 
determined? I suppose using
SDP for presentation description.
Here is my understanding about RTSP.
A client sends 'Describe' message to the server.
The server response 'describe' with SDP. I am not sure if the rtp port 
numbers given in the SDP are for client's receiving ports or server's 
sending ports. On my opinion. server should not designate
the client's receving port number on unicast case.
The Client then sends 'setup' message to the server.Here it can give its 
receiving port range.But it never clearly clarify what is audio port number 
and what is video port number.
  Maybe i misunderstand the rtsp standard.
  Thanks in advance!

Regards,

woo

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Kylin Wei <[email-masked]>
Date: Mon, 24 Jul 2006 14:13:22 +0800

Hi woo:

In unicast case, a client reports his receiving ports to the server by SETUP
request. Such as :
         C->M: SETUP rtsp://example.com/twister.3gp/trackID=1 RTSP/2.0

         Transport: RTP/AVP;unicast;dest_addr=":8000"/":8001"
Then server responds with source address:
         M->C: RTSP/2.0 200 OK         
         Transport: RTP/AVP;unicast;dest_addr=":8000"/":8001;
                    src_addr="192.0.2.5:9000"/"192.0.2.5:9001"
If SETUP URI (trackID=1) represents the audio URI, the destination ports is
used to receive audio traffic. Relevant information is included in the
DESCRIBLE response. Such as:
         m=audio 0 RTP/AVP 0
         a=control: trackID=1
         m=video 0 RTP/AVP 26
         a=control: trackID=4

Kylin Wei 
> -----Original Message-----
> From: woo john [mailto:[email-masked]]
> Sent: Monday, July 24, 2006 11:18 AM
> To: [email-masked]
> Subject: [MMUSIC] a rtsp question how to determine the receiging ports
> onunicast case?
> 
> hi,