Subject: [MMUSIC] ICE: STUN server location

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Tue, 12 Sep 2006 16:32:37 +0200

Hi,

This issue is not related to ICE as such, but more to the SIP usage of
ICE.

I wonder whether it would be possible to return the address of the STUN
server(s) e.g. in a registration response. All SIP terminals may not
have a configured domain to perform a SRV lookup upon. And, in roaming-
and mobility scenarios different STUN servers may be used depending on
location.

Regards,

Christer
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 12 Sep 2006 11:33:22 -0400

As you say, this is well out of scope for ICE.

ICE proposes that it is either configured, or if not, describes a 
mechanism to determine the address from the AOR. I personally see no 
need to learn it through registration.

-Jonathan R.

Christer Holmberg (JO/LMF) wrote:

> 
> Hi,
> 
> This issue is not related to ICE as such, but more to the SIP usage of ICE.
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Tue, 12 Sep 2006 18:57:53 +0200

Hi, 

>ICE proposes that it is either configured, or if not, 
>describes a mechanism to determine the address from the AOR. 
>I personally see no need to learn it through registration.

The use-case I am thinking about is when there is no AOR.

Regards,

Christer

> > have a configured domain to perform a SRV lookup upon. And, in 
> > roaming- and mobility scenarios different STUN servers may be used 
> > depending on location.
> > 
> > Regards,
> > 
> > Christer
> > 
> > 
> >

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 12 Sep 2006 17:35:05 -0400

If there is no AOR, how is there a REGISTER response by which to learn a 
STUN server?

-Jonathan R.

Christer Holmberg (JO/LMF) wrote:

>>>This issue is not related to ICE as such, but more to the 
>>
>>SIP usage of ICE.
>>
>>>server(s) e.g. in a registration response. All SIP 
>>
>>terminals may not 
>>
>>----------------------------------------------------------------------
>>
>>>--
>>>

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 13 Sep 2006 09:33:34 +0200

Hi, 

>If there is no AOR, how is there a REGISTER response by which to learn
a STUN server?

The REGISTER request is sent to an IP address (not AOR) which have been
provided to the terminal using some configuration/discovery mechanism.

Regards,

Christer

> >>mechanism to determine the address from the AOR.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Sep 2006 16:01:04 -0400

The To field of the REGISTER has to contain the users AOR.

-Jonathan R.

Christer Holmberg (JO/LMF) wrote:

>>>>------------------------------------------------------------
>>
>>----------
>>
>>>>>--
>>>>>

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 14 Sep 2006 09:13:51 +0200

Hi, 

The problem is that the To field can be a static value, pointing to my
"home network" or "home operator". For example, in 3GPP the To field
represents the IMPU (AOR) pointing to the home network. But, in roaming
or mobility scenarios you want to find the STUN servers of the visited
network - not the home network.

Regards,

Christer

> > The REGISTER request is sent to an IP address (not AOR) which have 
> > been provided to the terminal using some 
> configuration/discovery mechanism.
> > 
> > Regards,
> > 
> > Christer
> > 
> > 
> >  
> > 
> >>-Jonathan R.
> >>
> >>>>>I wonder whether it would be possible to return the 
> address of the 
> >>>>>STUN