Subject: [MMUSIC] Where can I find header extensions of RTSP SET_PARAMETER msg?

From: "Fan Chen" <[email-masked]>
Date: Sat, 9 Sep 2006 14:32:22 +0800

Dear all,

I'm developing a RTSP/RTP server which could streaming audio/video streams
to Realplayer or Quicktime player.

Realplayer may send RTSP SET_PARAMETER to the server during session setup,
typical headers like 

Subscribe: stream=0;rule=0,stream=0;rule=1,stream=1;rule=0,stream=1;rule=1

SetDeliveryBandwidth: Bandwidth=477113;BackOff=0
Ping: Pong
PlayerStats: Stat1: 128 0 0 0 0 32_Kbps_Stereo_Music_-_RA8][Stat2: 32041
62243 0 0 0 0 0 0 0 0 40 32_Kbps_St

Where can I find the exact definitions of these headers and how to deal with
them? Who can help me ?

Best regards

Chen

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Joerg Ott <[email-masked]>
Date: Sat, 09 Sep 2006 15:34:16 +0300

These may be proprietary extensions.  But you do not have
to support these parameters; the player will work fine, too,
if you don't.

Joerg

> 
> I’m developing a RTSP/RTP server which could streaming audio/video 
> streams to Realplayer or Quicktime player.
> 
> Realplayer may send RTSP SET_PARAMETER to the server during session 
> setup, typical headers like
> 
> PlayerStats: Stat1: 128 0 0 0 0 32_Kbps_Stereo_Music_-_RA8][Stat2: 32041  62243 0 0 0 0 0 0 0 0 40 32_Kbps_St
> 
>  
> 
>  
> 
> Where can I find the exact definitions of these headers and how to deal 
> with them? Who can help me ?
> 
>  
> 
> Best regards
> 
>  
> 
> Chen
> 
> 
> ------------------------------------------------------------------------
>