Subject: RE: [MMUSIC] RE: I-D ACTION:draft-kaplan-mmusic-best-effort-srtp- 01.txt

From: "Elwell, John" <[email-masked]>
Date: Fri, 27 Oct 2006 07:07:27 +0100

Francois,

Yes, that would work.

John 

> -----Original Message-----
> From: Francois Audet [mailto:[email-masked]] 
> Sent: 27 October 2006 01:22
> To: Elwell, John; Hadriel Kaplan; [email-masked]
> Subject: RE: [MMUSIC] RE: I-D 
> ACTION:draft-kaplan-mmusic-best-effort-srtp-01.txt
> 
> Maybe we could use one a=srtp line for crypto, and another one for
> kmgmt?
> 
> (i.e., have a different PT for each?) 
> 
> > -----Original Message-----
> > From: Elwell, John [mailto:[email-masked]] 
> > Sent: Thursday, October 26, 2006 5:56 AM
> > To: Hadriel Kaplan; Audet, Francois (SC100:3055); [email-masked]
> > Subject: [MMUSIC] RE: I-D 
> > ACTION:draft-kaplan-mmusic-best-effort-srtp-01.txt
> > 
> > Hadriel, Francois,
> > 
> > Thanks for working on this update. Just one point. If both 
> > SDescriptions and MIKEY are offered (inclusion of a=crypto 
> > and a=key-mgmt lines) and a different payload type is also 
> > indicated for SRTP, this payload type would apply whether the 
> > SDescription-derived key or the MIKEY-derived key is used.
> > So until the SDP answer arrives, it would still not be 
> > possible to render SRTP. Of course, in the case of 
> > SDescriptions it is not possible anyway, but in the case of 
> > certain MIKEY options it ought to be possible. Unfortunately 
> > to resolve this we would need somewhat more complex syntax in 
> > the a=srtp line.
> > 
> > John
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: 25 October 2006 20:50
> > > To: [email-masked]
> > > Subject: I-D ACTION:draft-kaplan-mmusic-best-effort-srtp-01.txt
> > > 
> > > A New Internet-Draft is available from the on-line 
> Internet-Drafts 
> > > directories.
> > > 
> > > 
> > > 	Title		: Session Description Protocol (SDP) 
> > > Offer/Answer Negotiation For Best-Effort Secure Real-Time 
> Transport 
> > > Protocol
> > > 	Author(s)	: F. Audet, H. Kaplan
> > > 	Filename	: draft-kaplan-mmusic-best-effort-srtp-01.txt
> > > 	Pages		: 17
> > > 	Date		: 2006-10-25
> > > 	
> > > This document defines the requirements and a proposed 
> solution for 
> > >    an SDP Offer/Answer exchange model for negotiating 
> > best-effort SRTP
> > >    keys, i.e., in a backward-compatible manner with 
> > non-SRTP devices.
> > >    The proposed solution is a trivial interpretation of the 
> > usage of 
> > >    the profile and the usage of SDP indication of [sdesc] 
> > and [kmgmt].
> > > 
> > > A URL for this Internet-Draft is:
> > > http://www.ietf.org/internet-drafts/draft-kaplan-mmusic-best-e
> > > ffort-srtp-01.txt
> > > 
> > > To remove yourself from the I-D Announcement list, send a 
> > message to 
> > > [email-masked] with the word unsubscribe in 
> > the body of 
> > > the message.
> > > You can also visit
> > > https://www1.ietf.org/mailman/listinfo/I-D-announce
> > > to change your subscription settings.
> > > 
> > > Internet-Drafts are also available by anonymous FTP. 
> Login with the 
> > > username "anonymous" and a password of your e-mail address. After 
> > > logging in, type "cd internet-drafts" and then "get 
> > > draft-kaplan-mmusic-best-effort-srtp-01.txt".
> > > 
> > > A list of Internet-Drafts directories can be found in 
> > > http://www.ietf.org/shadow.html or 
> > > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > > 
> > > Internet-Drafts can also be obtained by e-mail.
> > > 
> > > Send a message to:
> > > 	[email-masked].
> > > In the body type:
> > > 	"FILE
> > > /internet-drafts/draft-kaplan-mmusic-best-effort-srtp-01.txt".
> > > 	
> > > NOTE:	The mail server at ietf.org can return the document in
> > > 	MIME-encoded form by using the "mpack" utility.  To use this
> > > 	feature, insert the command "ENCODING mime" before the "FILE"
> > > 	command.  To decode the response(s), you will need "munpack" or
> > > 	a MIME-compliant mail reader.  Different MIME-compliant 
> > mail readers
> > > 	exhibit different behavior, especially when dealing with
> > > 	"multipart" MIME messages (i.e. documents which have been split
> > > 	up into multiple messages), so check your local documentation on
> > > 	how to manipulate these messages.
> > > 
> > > Below is the data which will enable a MIME compliant mail reader 
> > > implementation to automatically retrieve the ASCII version of the 
> > > Internet-Draft.
> > > 
> > 
> > _______________________________________________
> > mmusic mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mmusic
> > 
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 27 Oct 2006 10:46:19 -0700

And another for srtp-dtls and another for zrtp?

Maybe there is a more efficient way to combine these.  Perhaps only
including a=srtp for those key exchange mechanisms which can allow
decrypting SRTP media that arrives prior to the SDP answer?  Or perhaps
specifying the payload types in such a way that they're assigned to each of
the a= key management mechanisms understood by the answerer.  As a possible
strawman for this last idea:

  m=blahblah
  a=key-mgmt blahblah
  a=crypto blahblah
  a=fingerprint blahblah (used by srtp-dtls)
  a=zrtp
  a=srtp key-mgmt 40 crypto 41 fingerprint 42 zrtp 43
  
-d

> Sent: Thursday, October 26, 2006 11:07 PM
> To: Francois Audet; Hadriel Kaplan; [email-masked]
> > > > 	Filename	: 
> draft-kaplan-mmusic-best-effort-srtp-01.txt
> > > > 	Pages		: 17
> > > > 	Date		: 2006-10-25
> > > >

---

From: "Robert R. Gilman" <[email-masked]>
Date: Fri, 27 Oct 2006 12:48:29 -0600

Would the payload type entries be comma-separated lists for multiple-payload
channels?  We would also want to distinguish between different cryptosuites
(even if they used the same master key/salt), perhaps via multiple ordered
"crypto" entries?
-Bob
----------------------------------------------------
Bob Gilman       [email-masked]      +1 303 538 3868

Dan Wing wrote:
>>>>>username "anonymous" and a password of your e-mail 
>>
>>address. After 
>>
>>>>>	MIME-encoded form by using the "mpack" utility. 
>>
>> To use this
>>
>>>>>	feature, insert the command "ENCODING mime" 
>>
>>before the "FILE"
>>
>>>>>	command.  To decode the response(s), you will 
>>
>>need "munpack" or
>>
>>>>>	"multipart" MIME messages (i.e. documents which 
>>
>>have been split
>>
>>>>>	up into multiple messages), so check your local 
>>
>>documentation on
>>
>>>>>Below is the data which will enable a MIME compliant 
>>
>>mail reader 
>>
>>>>>implementation to automatically retrieve the ASCII 
>>
>>version of the 
>>
>>>>>Internet-Draft.
>>>>>
>>>>