Subject: [MMUSIC] Comments on draft-ietf-mmusic-ice-11

From: "Alfred E. Heggestad" <[email-masked]>
Date: Sun, 29 Oct 2006 20:26:53 +0100

hi

here are some comment on some minor things in draft-ietf-mmusic-ice-11:

 > Section 4.1.  Gathering Candidates
 >
 >    Agents which serve end users directly, such softphones, hardphones,
 >                                           ^^^^^^^^^^^^^^^

typo -> should be "such as"

 > Section 5.6.  Forming the Check Lists
 >
 >      pair priority = 2^32*MIN(O-P,A-P) + 2*MAX(O-P,A-P) + (O-P>A-P:1?0)
 >
 >   Where O-P>A-P:1?0 is an expression whose value is 1 if O-P is greater
 >

it would be better to write "O-P>A-P:1?0" as "O-P>A-P?1:0", i.e. where the
question mark and the colon are swapped. this is standard C syntax, and
will evalate to 1 if O-P>A-P and 0 if not.

 > Section 7.7.2.  Processing the Response
 >
 >   the agent knows about, the mapped address representes a new peer
 >                                             ^^^^^^^^^^^

typo -> should be "represents"

 > Section 8.  Completing the ICE Checks
 >
 >   When a pair is aded to the valid list, and the agent was the answerer
 >                  ^^^^

typo -> should be "added"

 > Section 8.  Completing the ICE Checks
 >
 >      assymetric.  It is possible to fix both of these problems by
 >      ^^^^^^^^^^

typo. should be "asymmetric"

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 31 Oct 2006 13:05:49 -0500

Thanks. I've incorporated these into my working version of -13.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com