Subject: RE: [MMUSIC] SDP: rcvonly vs. sendonly

From: "Wayne Mills \(wmills\)" <[email-masked]>
Date: Wed, 29 Nov 2006 09:32:32 -0500

> -----Original Message-----
> From: Mark Handley [mailto:[email-masked]] 
> Sent: Wednesday, November 29, 2006 9:00 AM
> To: Holger Schmidt
> Cc: [email-masked]
> Subject: Re: [MMUSIC] SDP: rcvonly vs. sendonly
> 
> SDP was originally devised for multicast sessions, and this 
> wording reflects the original use.  If a session was 
> recvonly, the multicast participants who received the SDP 
> description must not transmit data.
> Obviously someone else will transmit data or the session will 
> be rather quiet.
> 
> In a unicast world, recvonly would typically indicate that 
> the recipient of the SDP description should not send data. 

Whoa, don't you have that backwards?  If the SDP composer sends
"a=recvonly", that means the SDP composer wants to only receive,
therefore the SDP recipient SHOULD send and SHOULD NOT receive.  Right?

Wayne

> Thus it would apply to the RTSP client, as the SDP is sent 
> from the server to the client.
> 
>  - Mark

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: lazzaro <[email-masked]>
Date: Thu, 30 Nov 2006 07:30:48 -0800

On Nov 30, 2006, at 1:11 AM, Mark Handley wrote:

> For RTSP with unicast streams, I guess the main issue is not so much
> what I intended when I wrote the SDP spec, but rather how current RTSP
> implementations interpret this for unicast.

If we were to revisit RTSP with an eye towards defining it
to set up sendonly, recvonly, and sendrecv sessons in
a precisely-defined way, it would be a good thing for network
attached media breakout boxes.

Right now RTSP is used for products that stream audio out
(example: Apple's Airport Express receiving streaming audio
from iTunes, if I can believe hobbyist websites), but RTSP
in its current state isn't quite up to controlling breakout boxes
that can either source or sink audio, especially if one wants to
configure properties of audio input and audio output on the
breakout box during stream setup.

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---