Subject: [MMUSIC] SIP re-INVITE in accordance to rfc4240

From: Christian Riede <[email-masked]>
Date: Thu, 23 Nov 2006 14:20:14 +0100 (MET)

Hi,

the rfc4240 suggests a way to deliver self defined paramters within the 
To-Header of a Sip message:
e.g. To: <sip:[email-masked];myParameter=whatever>;tag=123456

According rfc3261:
The To, From, Call-ID, CSeq, and Request-URI of a re-INVITE are set
following the same rules as for regular requests within an existing
dialog, described in Section 12.

Does this mean that the self defined parameter (here 
'myParamter') must not be changed when sending a re-INVITE message?
Or does the rfc3261 only aim at the sip uri and the tag value?

Cheers, 
Christian

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 27 Nov 2006 13:16:42 +0100

Hi,

According to RFC3261 the whole header (including myParameter) must be
identical - eventhough the tag parameter is the only part of the To/From
header which is actually used for identifying the dialog.

Regards,

Christer 

> -----Original Message-----
> From: Christian Riede [mailto:[email-masked]] 
> Sent: 23. marraskuuta 2006 15:20
> To: [email-masked]
> Subject: [MMUSIC] SIP re-INVITE in accordance to rfc4240
> 
> Hi,
> 
> the rfc4240 suggests a way to deliver self defined paramters 
> within the To-Header of a Sip message:
> The To, From, Call-ID, CSeq, and Request-URI of a re-INVITE 
> are set following the same rules as for regular requests 
> within an existing dialog, described in Section 12.
>