Subject: RE: [MMUSIC] some comments on ice-12, part one

From: "Jean-Francois Mule" <[email-masked]>
Date: Tue, 14 Nov 2006 13:50:15 -0700

Dan Wing wrote:
> It is anticipated that BEHAVE's "application" milestone will describe
> how
> ICE's techniques can be used by non-SDP applications.  As of now,
>
> draft-ford-behave-app-04.txt is the most likely candidate document to
> meet
> BEHAVE's "application" milestone, but it hasn't yet been adopted as a
> working group document.

I was not aware of this work item, thanks, this works for me.
Just a minor note:
 - Scanning through draft-ford-behave-app-04.txt, it takes the following
approach: "if you build an app, here are the things you should be aware
of and some techniques that can be used."
  - My comment was targeted more specifically at protocol designers: if
you build a protocol that intends to use ICE, here are some of the
properties the protocol should have and here is the vocabulary that
should be added to convey the ICE semantics.

Jean-Francois.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 14 Nov 2006 13:17:34 -0800

(Adding BEHAVE to this discussion.)

> Dan Wing wrote:
> > It is anticipated that BEHAVE's "application" milestone 
> > will describe how ICE's techniques can be used by non-SDP 
> > applications.  As of now, draft-ford-behave-app-04.txt is 
> > the most likely candidate document to meet
> > BEHAVE's "application" milestone, but it hasn't yet been 
> > adopted as a working group document.
> 
>  - Scanning through draft-ford-behave-app-04.txt, it takes 
> the following approach: "if you build an app, here are the 
> things you should be aware of and some techniques that can 
> be used."

That is an accurate summary.

>   - My comment was targeted more specifically at protocol 
> designers: if you build a protocol that intends to use ICE, 
> here are some of the properties the protocol should have 
> and here is the vocabulary that should be added to convey 
> the ICE semantics.

This sounds different from a 'design rationale', which is
what I thought you were asking about.  (For everyone
else's reference, we're all referring to
http://www1.ietf.org/mail-archive/web/mmusic/current/msg04935.html)

I wonder if such a document is necessary.  For example, from 
what I have seen of XMPP/Jingle's adoption of ICE maybe they
did everything right, and even in a way that can allow 
signaling-only box to do SIP/XMPP interworking.

-d