Subject: [MMUSIC] Question on Pair Priority in ICE-17

From: "Shan Lu" <[email-masked]>
Date: Thu, 2 Aug 2007 16:10:42 -0400

Hi All,

>From 5.7.2/ICE-17:

    pair priority = 2^32*MIN(G,D) + 2*MAX(G,D) + (G>D?1:0).

Yet B.5 stated that the objective is to sort on the MAX/MIN property (as
opposed to MIN/MAX). So shouldn't pair priority be defined as:

    pair priority = 2^32*MAX(G,D) + 2*MIN(G,D) + (G>D?1:0)

Regards,

Shan Lu

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 03 Aug 2007 11:24:48 -0400

The formula is correct as written. The term "max/min" sorting refers to 
the property that, pairs with the largest prioritites come first.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: "Shan Lu" <[email-masked]>
Date: Fri, 3 Aug 2007 16:35:55 -0400

In that case, the two sentences at top of Page 106 should have "maximum"
and "minimum" swapped to read as:

   ... the pairs are first sorted based on decreasing value of the
   minimum of the two priorities.  For pairs that have the same
   value of the minimum priority, the maximum priority is
   used to sort amongst them.

Also "priority" should replace "sequence number" in this section.

Regards,

Shan Lu 

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: Friday, August 03, 2007 11:25 AM
> To: Shan Lu
> Cc: [email-masked]
> Subject: Re: [MMUSIC] Question on Pair Priority in ICE-17
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 04 Aug 2007 08:46:33 -0400

Fixed, thanks for catching it.

-Jonathan R.

---

From: "Adam Fisk" <[email-masked]>
Date: Mon, 6 Aug 2007 16:44:41 -0400

Related nit in the same section:

"the offerers priority is used as the tie breaker"

should be:

"the offerer's priority is used as the tie breaker"

-Adam

---

From: "Adam Fisk" <[email-masked]>
Date: Mon, 6 Aug 2007 16:50:45 -0400

Looking more closely at this, it appears this section is slightly
inconsistent with section 5.7.2.

I believe that instead of:

it should be:

"the controlling agent's priority is used as the tie breaker"

-Adam

On 8/6/07, Adam Fisk <[email-masked]> wrote:
> > >> From: Jonathan Rosenberg [mailto: [email-masked]]

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 07 Aug 2007 09:38:22 -0400

Yup, another bug. I haven't kept the appendix up to date here, 
obviously. Fixed.

-Jonathan R.

Adam Fisk wrote:
> On 8/6/07, *Adam Fisk* <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     On 8/4/07, *Jonathan Rosenberg* < [email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         > > From: Jonathan Rosenberg [mailto: [email-masked]
>         <mailto:[email-masked]>]
>         > > Cc: [email-masked] <mailto:[email-masked]>
>         > >> [email-masked] <mailto:[email-masked]>
>         > > [email-masked]
>         <mailto:[email-masked]>                              FAX:  
>         (973) 952-5050
>         [email-masked]
>         <mailto:[email-masked]>                              FAX:  
>         (973) 952-5050
>         [email-masked] <mailto:[email-masked]>
>         <https://www1.ietf.org/mailman/listinfo/mmusic>
> 
> 
>