Subject: [MMUSIC] Updated ICE-tcp

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 25 Feb 2008 12:33:07 -0500

I've submitted an updated ICE-tcp:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-ice-tcp-06.txt

There are two changes:

* added usage of comedia instead of defining an ice-lite for tcp; allow 
for an offer or answer to have ICE for UDP and just comedia for TCP, in 
which case ICE proceeds. Defined some rules around selection of 
direction attributes needed for interop. This turned out to be 
relatively easy to incorporate compared to the other approaches we 
discussed last meeting.

* generalized the discussion on secure media a bit so it wasn't specific 
to DTLS-SRTP.

The other big issue that came up at the last IETF was around the success 
rates of ICE-tcp being too low, and that we might need to look at port 
prediction or some of the other techniques defined in Saikat's papers to 
make this better. I have spent some time researching this, and will post 
other notes with the open issues here. This is a complex topic, and 
there is some real experimentation work needed before we can conclude on 
this.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
mmusic mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/mmusic

---

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 25 Feb 2008 22:10:07 +0100

Hi Jonathan,
 
I think the draft looks good.
 
One question, though: in chapter 3, what is the reason for mandating "actpass"? Why won't "passive" work?
 
Regards,
 
Christer

________________________________

From: [email-masked] on behalf of Jonathan Rosenberg
Sent: Mon 25/02/2008 18:33
To: IETF MMUSIC WG
Subject: [MMUSIC] Updated ICE-tcp

There are two changes:

-Jonathan R.
--
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net <http://www.jdrosen.net/>                          PHONE: (408) 902-3084
http://www.cisco.com <http://www.cisco.com/> 
_______________________________________________
mmusic mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 25 Feb 2008 16:47:10 -0500

When communicating with another comedia-only implementation, I wanted 
the full flexibility of rfc4145.

-Jonathan R.

Christer Holmberg wrote:
> From: [email-masked] on behalf of Jonathan Rosenberg Sent:
> Mon 25/02/2008 18:33 To: IETF MMUSIC WG Subject: [MMUSIC] Updated
> ICE-tcp
> 
> 
> 
> * added usage of comedia instead of defining an ice-lite for tcp;
> allow for an offer or answer to have ICE for UDP and just comedia for
> TCP, in which case ICE proceeds. Defined some rules around selection
> of direction attributes needed for interop. This turned out to be 
> * generalized the discussion on secure media a bit so it wasn't
> specific to DTLS-SRTP.
> 
> 
> The other big issue that came up at the last IETF was around the
> success rates of ICE-tcp being too low, and that we might need to
> look at port prediction or some of the other techniques defined in
> Saikat's papers to make this better. I have spent some time
> researching this, and will post other notes with the open issues
> here. This is a complex topic, and there is some real experimentation
> work needed before we can conclude on this.
> 
> -Jonathan R. -- Jonathan D. Rosenberg, Ph.D.                   499
> Thornall St. Cisco Fellow                                   Edison,
> NJ 08837 Cisco, Voice Technology Group [email-masked] 
> http://www.jdrosen.net <http://www.jdrosen.net/>
> PHONE: (408) 902-3084 http://www.cisco.com <http://www.cisco.com/> 
> _______________________________________________ mmusic mailing list 
> [email-masked] http://www.ietf.org/mailman/listinfo/mmusic
> 
> 
>

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 26 Feb 2008 07:04:43 +0100

Hi,

>When communicating with another comedia-only implementation, I wanted the full flexibility of rfc4145.

Correct. Maybe it would be good idea to add a few clarification words about that?

Regards,

Christer

Christer Holmberg wrote:
> http://www.jdrosen.net <http://www.jdrosen.net/>  <http://www.jdrosen.net/>
> PHONE: (408) 902-3084 http://www.cisco.com <http://www.cisco.com/>  <http://www.cisco.com/>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 28 Feb 2008 08:34:14 +0000

Jonathan,

> relatively easy to incorporate compared to the other approaches we 
[JRE] So where does this leave us with IPv6 transition and the need to
provide IPv4 and IPv6 candidates?

John
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 28 Feb 2008 11:13:47 -0500

Good question.

If you want to do v6 transition for a tcp session, you'd need full ICE.

-Jonathan R.

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 28 Feb 2008 17:18:30 +0000

Fine, but perhaps worth mentioning.

John 

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: 28 February 2008 16:14
> To: Elwell, John
> Cc: IETF MMUSIC WG
> Subject: Re: [MMUSIC] Updated ICE-tcp
> 
> Good question.
>