Subject: [MMUSIC] vad and cng

From: Richard Lee <[email-masked]>
Date: Sun, 09 Mar 2008 14:18:10 -0400

Can somebody please point me to right place where it talks about vad and 
cng in g711?

My understanding was that VAD cannot be speicfied in g711.
But according to RFCs for RTP, there still should be a way to recognize 
to see if RTP trace contains VAD and CNG.

I put up my findings on below wiki.
http://en.wikipedia.org/wiki/User:Rich.japh

Can someone please comment to see if my 
method(assumption/interpretation) is correct ?

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: <[email-masked]>
Date: Sun, 9 Mar 2008 21:05:13 +0100

Hi

There is no G.711-specific mechanism. Usual RTP mechanism applies. 

Silence suppression is detected by a gap in received timestamps, and the first packet after a silence period should have the marker (M) bit set to 1 in its RTP header.

Aurelien

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] 
> De la part de Richard Lee
> Envoyé : dimanche 9 mars 2008 14:18
> À : [email-masked]
> Objet : [MMUSIC] vad and cng
> 
> Can somebody please point me to right place where it talks 
> about vad and cng in g711?
> 
> But according to RFCs for RTP, there still should be a way to 
> recognize to see if RTP trace contains VAD and CNG.
>

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 11 Mar 2008 16:56:11 +0100

you may also have a look in ITU-T Recommendations

G.711 Appendix I (09/99)
  	A high quality low-complexity algorithm for packet loss concealment with G.711
	
G.711 Appendix II (02/00)
  	A comfort noise payload definition for ITU-T G.711 use in packet-based multimedia communication systems 

-Albrecht

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Sonntag, 9. März 2008 21:05
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [MMUSIC] vad and cng
> 
> Hi
> 
> Silence suppression is detected by a gap in received 
> timestamps, and the first packet after a silence period 
> should have the marker (M) bit set to 1 in its RTP header.
> 
> Aurelien
> 
> > De : [email-masked] [mailto:[email-masked]] De la 
> > part de Richard Lee Envoyé : dimanche 9 mars 2008 14:18 À : 
> > [email-masked] Objet : [MMUSIC] vad and cng
> >