Subject: [MMUSIC] SDPCapNeg : 2nd o/a via UPDATE?

From: "Zhengrong Yao" <[email-masked]>
Date: Thu, 3 Apr 2008 12:26:59 +0200

Hi:
 
Maybe an obsolete question but I did not manage to find hint in the MMUSIC email threads...
 
Although nothing preventing this but is it good to suggest in application to send 2nd round o/a exchange within UPDATE message, meaning that Alice and Bob can start session already after 1st round o/a exchange, and dont need to wait until the 2nd round (unless it has to be done in another INVITE SIP message). Of course issues in 3.12 remains the same.
 
In draft now the text for 2nd round read as:  "Alice's updated offer..." Is this an indication for usiing UPDATE to do 2nd o/a exchage or?  it makes "2nd delay" less scary.

Thanks a lot for tips
 
BR
 
Zhengrong Yao

Zhengrong Yao  Ph.D. 
Standardization Manager 
Ericsson AB 
Business Unit Multimedia                          Office: +46 46 194584
Scheelevägen 17                                       Fax: +46 76 130 3945
SE22370, Lund, Sweden                        Mobile: +46 703 674584
www.ericsson.com <http://www.ericsson.com/>                 Email: [email-masked] <mailto:[email-masked]>  

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interception, unauthorized amendment, tampering and viruses, and we only send and receive emails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 09 Apr 2008 17:38:29 -0400

The normal SIP and offer/answer rules apply here and hence use of UPDATE 
for the second O/A exchange is indeed an option. Note however, that the 
initial O/A exchange must always complete first, and hence you either 
need to receive a 200 OK, or use reliable provisional responses.

-- Flemming

Zhengrong Yao wrote:
> Although nothing preventing this but is it good to suggest in 
> application to send 2nd round o/a exchange within UPDATE message, 
> meaning that Alice and Bob can start session already after 1st round 
> o/a exchange, and dont need to wait until the 2nd round (unless it has 
> to be done in another INVITE SIP message). Of course issues in 3.12 
> remains the same.
>  
> In draft now the text for 2nd round read as:  "Alice's updated 
> offer..." Is this an indication for usiing UPDATE to do 2nd o/a 
> exchage or?  it makes "2nd delay" less scary.
>  
>  
> Thanks a lot for tips
>  
> BR
>  
> Zhengrong Yao
>
>
>
> *Zhengrong Yao*  Ph.D.
> Standardization Manager
> *Ericsson AB*
> _www.ericsson.com_ <http://www.ericsson.com/>                Email: 
> [email-masked] <mailto:[email-masked]>
>
> This communication is confidential and intended solely for the 
> addressee(s). Any unauthorized review, use, disclosure or distribution 
> is prohibited. If you believe this message has been sent to you in 
> error, please notify the sender by replying to this transmission and 
> delete the message without disclosing it. Thank you.
>
> E-mail including attachments is susceptible to data corruption, 
> interception, unauthorized amendment, tampering and viruses, and we 
> only send and receive emails on the basis that we are not liable for 
> any such corruption, interception, amendment, tampering or viruses or 
> any consequences thereof.
>

---

From: Bob Gilman <[email-masked]>
Date: Wed, 09 Apr 2008 17:55:46 -0600

I think it's always possible, using media capabilities, to frame
an offer such that there is no need for a second O/A exchange.
I'd be interested in seeing counterexamples.
-Bob
-------------------------------------------------------------
Bob Gilman        [email-masked]      +1 303 898 9780

Flemming Andreasen wrote:
>> In draft now the text for 2nd round read as:  "Alice’s updated 
> ------------------------------------------------------------------------
>

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 10 Apr 2008 13:15:31 -0400

The second O/A exchange is technically speaking never needed; it's done 
as a courtesy to any potential middle-boxes that may not understand the 
SDP capability negotiations.

-- Flemming

Bob Gilman wrote:
>> The normal SIP and offer/answer rules apply here and hence use of 
>> UPDATE for the second O/A exchange is indeed an option. Note however, 
>> that the initial O/A exchange must always complete first, and hence 
>> you either need to receive a 200 OK, or use reliable provisional 
>> responses.
>>
>> -- Flemming
>>
>> Zhengrong Yao wrote:
>>> Hi:
>>>  
>>> o/a exchange, and dont need to wait until the 2nd round (unless it 
>>> has to be done in another INVITE SIP message). Of course issues in 
>>> 3.12 remains the same.
>>>  
>>> addressee(s). Any unauthorized review, use, disclosure or 
>>> distribution is prohibited. If you believe this message has been 
>>> sent to you in error, please notify the sender by replying to this 
>>> transmission and delete the message without disclosing it. Thank you.
>>>
>>> any such corruption, interception, amendment, tampering or viruses 
>>> or any consequences thereof.
>>>
>>

---

From: Bob Gilman <[email-masked]>
Date: Thu, 10 Apr 2008 14:10:25 -0600

Flemming-
Thanks for reminding me of the problem of old middleboxes.
I was thinking of the 1 of N codec selection problem in section
10.2 of RFC 3264.
-Bob
-------------------------------------------------------------
Bob Gilman        [email-masked]      +1 303 898 9780

---

From: "Zhengrong Yao" <[email-masked]>
Date: Fri, 18 Apr 2008 15:23:18 +0200

Hi Bob:

That's a new interesting point for me, but I'm not sure I follow it:
How could you avoid second O/A exchang when precondition is needed.

Alice need to signal to you (Bob) the "a=inactive" to "a=sendrecv"
change isn't it? could this really be fixed by media capabilities
extention without second O/A?  

pls treat this only as one question instead of a counterexample.

BR
Zhengrong

-----Original Message-----
From: Bob Gilman [mailto:[email-masked]] 
Sent: den 10 april 2008 22:10
To: Flemming Andreasen
Cc: Zhengrong Yao; [email-masked]
Subject: Re: [MMUSIC] SDPCapNeg : 2nd o/a via UPDATE?

Flemming-

Flemming Andreasen wrote:
> The second O/A exchange is technically speaking never needed; it's 
> done as a courtesy to any potential middle-boxes that may not 
> understand the SDP capability negotiations.
> 
> -- Flemming
> 
> Bob Gilman wrote:
>> I think it's always possible, using media capabilities, to frame an 
>> offer such that there is no need for a second O/A exchange.

---

From: Bob Gilman <[email-masked]>
Date: Fri, 18 Apr 2008 10:13:52 -0600

Zhengrong-
The media capabilities extensions can't be used to avoid a second
exchange in the case where a media stream is reconfigured, e.g., from
inactive to sendrecv, or when confirmation of requested conditions
is required in both directions.
I apologize for not qualifying my earlier statement.
-Bob
-------------------------------------------------------------
Bob Gilman        [email-masked]      +1 303 898 9780