Subject: Re: [MMUSIC] non-SIP ICE: useful or not?

From: Darren <[email-masked]>
Date: Sat, 13 Sep 2008 17:26:28 -0600

My interest for non-sip ICE is for P2P video streaming.  We use RTSP
today and ICE conceptually sounds like a good idea.

However, as Magnus said one still needs the equivalent of a TURN/proxy
server for RTSP to use ICE.  This is probably not unique to ICE as
conceivably any other form of guaranteed P2P NAT traversal for RTSP
seems to need a proxy server as a last resort.

-Darren Loher
Chief Architect
Envysion, Inc.
http://envysion.com

> Jonathan Rosenberg wrote:
>>
>> I'd like to get some discussion going around this question prior to the
>> meeting. Please take a look at:
>>
>>
>> http://www.ietf.org/internet-drafts/draft-rosenberg-mmusic-ice-nonsip-01.txt
>>
>> The main question: is a draft like this sufficiently useful to produce or
>> not? Given its main audience are the (relatively few) protocol designers of
>> things using ICE, there is an argument to be made we don't really need this.
>> I'd especially welcome comments from Miika, Magnus, Hannes and other folks
>> actually producing documents that would use the contents here.
>>
>> Comments on details welcome too, though secondary I think to the main
>> question.
>>
>> Thanks,
>> Jonathan R.
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Dan Wing" <[email-masked]>
Date: Sat, 13 Sep 2008 21:14:14 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Darren
> Sent: Saturday, September 13, 2008 4:26 PM
> To: IETF MMUSIC WG
> Subject: Re: [MMUSIC] non-SIP ICE: useful or not?
> 

If you can ensure the RTSP server has a publicly-routable IP address 
-- which is oftentimes the situation with many of today's RTSP 
architectures -- you won't need a media relay (TURN) server.

-d

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Sun, 14 Sep 2008 09:18:41 +0300

> today and ICE conceptually sounds like a good idea.

Non-SIP ICE will NOT solve your problem, because it only works for UDP.

The RTSP server needs to have a public IP address, so that the RTSP control 
TCP-based connection can be established.

-- 
Rémi Denis-Courmont
http://git.remlab.net/cgi-bin/gitweb.cgi?p=vlc-courmisch.git;a=summary
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic