Subject: [MMUSIC] Comments on imageiddr

From: "Jonathan Lennox" <[email-masked]>
Date: Mon, 17 Nov 2008 11:17:52 -0500

I was asked to repeat on the list my comments at the mic on the
imageaddr draft, so here we are.

First of all, the current draft does an offer/answer exchange whereby
the offerer lists a set of possibilities for send and receive image
attributes, and then the answerer responds with some subset of these.

My question was what each side should do if something changes (e.g.
available bandwidth) such that the requested image size isn't easily
achievable.  MUST (or SHOULD) there be a new offer/answer exchange, or
can one side just start sending something that doesn't conform to what
was negotiated?

It sounds like the consensus at the mic was that they could, since the
resolutions negotiated are advisory.

My second question was what you should do if you have several sources in
a session, e.g. coming from an MCU, which might have different preferred
natural resolutions or aspect ratios.

One suggestion would be to define the imageaddr attribute as a source
attribute as well as a session attribute.

There was some suggestion at the mic that this didn't really matter so
much, again since the resolutions are advisory.

-- 
Jonathan Lennox
Vidyo, Inc
[email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 17 Nov 2008 20:44:00 +0100

Hi

Thanks for the comments, they highlight some issues that need to be
clarified. Also it likely needs to be clarified to what extent the
attribute is only advisory (if it an be ignored at any time there is
probably no reason to use it)

Regards
Ingemar

> -----Original Message-----
> From: Jonathan Lennox [mailto:[email-masked]] 
> Sent: den 17 november 2008 17:18
> To: [email-masked]
> Cc: Ingemar Johansson S
> Subject: Comments on imageiddr
> 
> I was asked to repeat on the list my comments at the mic on 
> the imageaddr draft, so here we are.
> 
> First of all, the current draft does an offer/answer exchange 
> whereby the offerer lists a set of possibilities for send and 
> receive image attributes, and then the answerer responds with 
> some subset of these.
> 
> available bandwidth) such that the requested image size isn't 
> easily achievable.  MUST (or SHOULD) there be a new 
> offer/answer exchange, or can one side just start sending 
> something that doesn't conform to what was negotiated?
This is a good question and there is probably no simple answer to that
currently the draft says nothing about this. One alternative is to issue
a new offer/asnwer exchange (possible more limited)  

> 
> It sounds like the consensus at the mic was that they could, 
> since the resolutions negotiated are advisory.
> 
> 
> My second question was what you should do if you have several 
> sources in a session, e.g. coming from an MCU, which might 
> have different preferred natural resolutions or aspect ratios.
Scary though, sofar I have tried to _not_ think about this 

> 
> One suggestion would be to define the imageaddr attribute as 
> a source attribute as well as a session attribute.
> 
> There was some suggestion at the mic that this didn't really 
> matter so much, again since the resolutions are advisory.
> 
> 
> --
> Jonathan Lennox
> Vidyo, Inc
> [email-masked]
> 
> 
>