Subject: [MMUSIC] Problem with example in draft-ietf-mmusic-rfc2326bis-19

From: "Patrick Hoffmann" <[email-masked]>
Date: Fri, 28 Nov 2008 14:34:33 +0100

Hello everybody,

I'm currently working on a boost::spirit based implementation that parses RTSP and SDP. I'm orienting myself to your "draft-ietf-mmusic-rfc2326bis-19" and I have found this issue:

On page 216 you wrote:

--
1: C->M: SETUP rtsp://example.com/twister.3gp/trackID=1 RTSP/2.0
2:       CSeq: 2
3:       User-Agent: PhonyClient/1.2
4:       Require: play.basic
5:       Transport: RTP/AVP/TCP;unicast;dest_addr=":9"/":9"
6:                  setup=active;connection=new
--

I couldn't parse this because there is a ";" missing at the end of line 5. Or am I wrong?

-- 
Mit freundlichen Grüßen (best regards),

Patrick Hoffmann

PGP Public Key: www.patsite.de/ph.asc

"Was wirklich wichtig ist, ist was man noch dazulernt, wenn man meint schon alles zu können." 
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Patrick Hoffmann" <[email-masked]>
Date: Fri, 28 Nov 2008 15:07:11 +0100

Hi again.
 
Same problem in the following example.
 
And more, at page 220:
 
--
  C->S: PLAY rtsp://example.com/fizzle RTSP/2.0
        CSeq: 4
        Session: abcdefg
        Range: npt=10-15;npt=18-20
        User-Agent: PhonyClient/1.2
--
 
Should'nt this be a comma between the ranges in "npt=10-15;npt=18-20"?
 
All other examples in your document seem to be right - my parser says 

Patrick Hoffmann

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 28 Nov 2008 15:50:58 +0100

Hi Patrick,

Thanks for the report. This have now been fixed in the source.

> Same problem in the following example.

Yes.

>> I'm currently working on a boost::spirit based implementation that parses RTSP and SDP. I'm orienting myself to your "draft-ietf-mmusic-rfc2326bis-19" and I have found this issue:

Correct, missing ";".

Thanks

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic