Subject: Re: [MMUSIC] CapNeg aware intermediate which does not support specificalternatives

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 17 Nov 2008 18:15:03 +0100

Hi

As a late followup on this thread

http://www.ietf.org/mail-archive/web/mmusic/current/msg07287.html

One possible middlebox behavior may for instance be to modify the offer SDP based on allowed option tags (extensions to SDPCapNeg framework).
Suppose for instance that an SDP offer includes potential configurations that exploits the ccap attribute as well as the SDPMedCapNeg extension. An offer SDP may look like

m=audio 54320 RTP/AVP 0
a=mcap:1 ...
a=ccap:1 ...
a=tcap:1 ...
a=pcfg:1 t=1 m=1 c=1 +ccap-v0 +med-v0
a=pcfg:2 t=1 m=1 +med-v0
a=pcfg:3 t=1 

If the intemediary supports SDP media capabilities exchange (med-v0 option tag) but does not support the ccap-v0 option tag for one reason or another then it is safe for the intermediary to remove the pcfg:1 line. 
Likewise.. if med-v0 is  not supported then the a=pcfg:2 line can be removed as well. 

Regards
Ingemar    

******************************************* 
Ingemar Johansson 
Senior Research Engineer, IETF "nethead" 
EAB/TVP - Multimedia Technologies 
Ericsson Research Ericsson AB 
Box 920 S-971 28 Luleå, Sweden 
Tel: +46 (0)8 4043042 
ECN: 850-43042 
Mobile: +46 (0)730 783289 
******************************************* 
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 17 Nov 2008 18:15:03 +0100

Hi

m=audio 54320 RTP/AVP 0
a=mcap:1 ...
a=ccap:1 ...
a=tcap:1 ...

Regards
Ingemar