Subject: [MMUSIC] SDP CapNeg and forking

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 10 Nov 2008 05:09:59 +0100

Hi,

Assume a UA sends a SIP INVITE, with an SDP offer that contains a number
of different alternatives/configuratoins, using CapNeg mechanism(s).

Now, the INVITE is forked to a number of terminating UAs.

The terminating UEs send back 18x responses with SDP answers, where
there different terminating UAs chooses DIFFERENT
alternatives/configurations.

Now, what does the originating UA do?

Does the originatin UA have to simulatnously reserve resources for, and
be able to support, ALL of the chosen alternatives/configurations, until
it knows from which of the terminating UAs it will receive 200 (at that
point it can release all resources associted with the other terminating
UAs)?  

And, of course intermediates will have the same problem: even if they
support CapNeg, they may end up having to support multiple
alternatives/configurations simultanously.

Of course, and could say that we can have the same problem even without
CapNeg, if the terminating UAs indicate different codecs etc in the SDP
answers. But, with CapNeg one can give much "broader" alternatives, so
it may be much more difficult to deal with SDP answers indicating
different alternatives.

So, do we need to say something about it?

I know MMUSIC doesn't deal with SIP, but I think we all agree that SIP
will be the main (only?) "customer" of CapNeg.

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 11 Nov 2008 16:57:05 +0000

Christer,

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 10 November 2008 04:10
> To: [email-masked]
> Subject: [MMUSIC] SDP CapNeg and forking
> 
> 
> Hi, 
> 
> Assume a UA sends a SIP INVITE, with an SDP offer that 
> contains a number of different alternatives/configuratoins, 
> using CapNeg mechanism(s).
> 
> The terminating UEs send back 18x responses with SDP answers, 
> where there different terminating UAs chooses DIFFERENT 
> Does the originatin UA have to simulatnously reserve 
> resources for, and be able to support, ALL of the chosen 
> alternatives/configurations, until it knows from which of the 
> terminating UAs it will receive 200 (at that point it can 
> release all resources associted with the other terminating UAs)?  
[JRE] I don't see any alternative, do you?

John

> 
> And, of course intermediates will have the same problem: even 
> if they support CapNeg, they may end up having to support 
> multiple alternatives/configurations simultanously.
> 
> Of course, and could say that we can have the same problem 
> even without CapNeg, if the terminating UAs indicate 
> different codecs etc in the SDP answers. But, with CapNeg one 
> can give much "broader" alternatives, so it may be much more 
> difficult to deal with SDP answers indicating different alternatives.
> 
> I know MMUSIC doesn't deal with SIP, but I think we all agree 
> that SIP will be the main (only?) "customer" of CapNeg. 
> 
> Regards, 
> 
> Christer 
> 
>

---

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 12 Nov 2008 01:18:42 +0100

Hi, 

> Assume a UA sends a SIP INVITE, with an SDP offer that contains a 
> number of different alternatives/configuratoins, using CapNeg 
> mechanism(s).
> 
> Does the originatin UA have to simulatnously reserve resources for, 
> and be able to support, ALL of the chosen alternatives/configurations,

> until it knows from which of the terminating UAs it will receive 200 
> (at that point it can release all resources associted with the other 
> terminating UAs)?

[Christer] No. But, do we need to say somehing about it in the document?

Regards,

Christer