Subject: [MMUSIC] New draft on "SIP/SDP Overlap with RTSP"

From: "Jan Lindquist" <[email-masked]>
Date: Wed, 10 Jun 2009 16:32:52 +0200

Hello,

A new draft has been uploaded titled "SIP/SDP Overlap with RTSP" (draft-lindquist-mmusic-sip-rtsp-00). The draft is co-signed by Jan Lindquist, Jouni Maenpaa, Priya Rajagopal and Xavier Marjou. A slot is requested in MMUSIC for the July Stockholm meeting to present the draft.

http://www3.ietf.org/proceedings/staging/draft-lindquist-mmusic-sip-rtsp-00.txt

For your convenience here is the abstract taken from the draft.

   The Session Initiation Protocol (SIP) is widely used for establishing
   multimedia sessions, whereas the Real Time Streaming Protocol (RTSP)
   is a protocol for use in streaming media systems.  RTSP has a dual
   role: it establishes a media session for the delivery of streaming
   media as well as controls the streaming session once it has been set
   up.  Since RTSP is also used for session establishment, there exists
   an overlap between the functionality provided by SIP and RTSP.  In
   this document, we analyze a model in which SIP and the SDP offer/
   answer model are used to set up a streaming session with an RTSP
   control channel and one or more media delivery streams.  Such a model
   is beneficial since it allows the reuse of current architecture and
   functionality (e.g., authentication, charging, and QoS) established
   around SIP also for RTSP-based streaming.

If there are any questions or comments on the new draft we will be glad to answer them.

Best Regards,
Jan Lindquist

---

From: Alex Giladi <[email-masked]>
Date: Wed, 10 Jun 2009 11:03:16 -0600

Jan,
A couple of comments:
In 7, you have an additional method of reserving / releasing resources
on the media server. However, after a TEARDOWN session is most
probably already invalid (see 10.7 in RFC2326), its resources invalid,
and issuing a TEARDOWN with a non-existent session id may actually
break an unsuspecting RTSP server.
Resource allocation at the VoD server side regularly happens as a part
of SETUP. It is AFAIK perfectly legal to issue SETUP with a Session
header, so you can easily generate session ID at the controller.
Also, you only consider the case of orderly session termination.
However you may have to drop the session at the server (e.g. you have
reached the end of your VoD content).
Regards,
Alex.

On Wed, Jun 10, 2009 at 8:32 AM, Jan
Lindquist<[email-masked]> wrote:
> Hello,
>
> A new draft has been uploaded titled "SIP/SDP Overlap with RTSP"
> (draft-lindquist-mmusic-sip-rtsp-00). The draft is co-signed by Jan
> Lindquist, Jouni Maenpaa, Priya Rajagopal and Xavier Marjou. A slot is
> requested in MMUSIC for the July Stockholm meeting to present the draft.
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: "Jan Lindquist" <[email-masked]>
Date: Thu, 11 Jun 2009 09:30:38 +0200

Hello Alex,

Thanks for the comments.

On the question of resource release I agree that a Media Server would release the resources at Teardown. We tried to generalize the actions on the Media Server. There might be a proxy for all communicaton to the Media Server so neither the Controller or UE signal directly to the Media Server but through a proxy component. On the other hand there could be a seperation of signalling where the controller wants to have control of preparing the resource and the release. This is what the signal flows show.

As for the Media Server dropping the session due to end of stream I would refer to the usage of ANNOUNCE or RTSPv2 PLAY_NOTIFY. Sessions are not simply dropped but in my view should be triggered by the UE after getting the notification. The UE may want to rewind or start from the initial position

Best regards,
JanL

> -----Original Message-----
> From: Alex Giladi [mailto:[email-masked]] 
> Sent: den 10 juni 2009 19:03
> To: Jan Lindquist
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Re: [MMUSIC] New draft on "SIP/SDP Overlap with RTSP"
> 
> Jan,
> A couple of comments:
> In 7, you have an additional method of reserving / releasing 
> resources on the media server. However, after a TEARDOWN 
> session is most probably already invalid (see 10.7 in 
> RFC2326), its resources invalid, and issuing a TEARDOWN with 
> a non-existent session id may actually break an unsuspecting 
> RTSP server.
> Resource allocation at the VoD server side regularly happens 
> as a part of SETUP. It is AFAIK perfectly legal to issue 
> SETUP with a Session header, so you can easily generate 
> session ID at the controller.
> However you may have to drop the session at the server (e.g. 
> you have reached the end of your VoD content).
> Regards,
> Alex.
> 
>