Subject: [MMUSIC] SDP offer/answer question from SIPit

From: Robert Sparks <[email-masked]>
Date: Thu, 17 Sep 2009 14:33:31 -0400

Can somebody point quickly to some existing text that answers this  
question?
(If none exists, perhaps we should think about creating some)

When you reject an m-line that has something in it you've never heard  
of before,
(say someone sent you m=application 50000 TCP/TLS/BFCP *) you return a
corresponding m-line with a port of 0 as below, the question is, as  
you are building
that response:

m=application 0 ????what goes here????

One sane answer is to just copy the bits from the offer without trying  
to attribute any
meaning to them:

m=application 0 TCP/TLS/BFCP *

But remember that the rejector probably doesn't know TCP/TLS/BFCP
from NEVER/USE/THIS. Section 6 of 3264 has this language:
"To reject an offered
    stream, the port number in the corresponding stream in the answer
    MUST be set to zero.  Any media formats listed are ignored.  At  
least
    one MUST be present, as specified by SDP."

Now, media-field is this in SDP:
    media-field =         %x6d "=" media SP port ["/" integer]
                          SP proto 1*(SP fmt) CRLF

So the text from 3264 could be read to be talking only the fmt field.
Should the proto field also be ignored at this point?

Would it be ok to return

m=application 0 RTP/AVP 0

for example?

If not, what text makes it clear?
(It might exist, but the testing is furious today and I'm not spotting  
it quickly).

RjS

---

From: "Christer Holmberg" <[email-masked]>
Date: Sun, 20 Sep 2009 19:23:09 +0200

Hi,
 
Since the port is zero, does it really matter?
 
As long as the transport types etc match for the non-zero port m- lines, the offerer should be ok.
 
Regards,
 
Christer

________________________________

From: [email-masked] on behalf of Robert Sparks
Sent: Thu 17/09/2009 20:33
To: [email-masked]
Subject: [MMUSIC] SDP offer/answer question from SIPit

Would it be ok to return

for example?

RjS
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 21 Sep 2009 12:13:25 -0400

Robert,

I don't know of anything that is definitive about this.
My inclination is that the line needs to be syntactically correct, but 
that the values of parameters beyond the port can be anything. So not only

but also

m=application 0 none 0

But probably the choice with the highest probability of interop is to 
copy the proto from the offer.

	Thanks,
	Paul

Robert Sparks wrote:
> When you reject an m-line that has something in it you've never heard of 
> before,
> corresponding m-line with a port of 0 as below, the question is, as you 
> are building
> that response:
> 
>    MUST be set to zero.  Any media formats listed are ignored.  At least