Subject: [MMUSIC] WGLC on draft-ietf-mmusic-rfc4756bis-03

From: "Jean-Francois Mule" <[email-masked]>
Date: Wed, 14 Oct 2009 10:10:10 -0600

This is to start a 2-week working group last call on draft
draft-ietf-mmusic-rfc4756bis-03,
http://tools.ietf.org/html/draft-ietf-mmusic-rfc4756bis-03.  The comment
period will end on Wednesday October 28.

Please send your comments to the mmusic list and the authors.

Thank you,
Jean-Francois.

---

From: Thomas Schierl <[email-masked]>
Date: Mon, 19 Oct 2009 14:16:29 +0200

Dear Ali,

I am not sure if the SDP signaling is covering all cases. What is about 
the case of having a SVC or any other layered media, where one session 
SB contains the base layer and another session SE contains the 
enhancement layer. Let us assume session SB is protected by  repair flow 
RB. Furthermore, session SB and SE are jointly protected by repair flow 
RB+E. Additionally, RB+E is additive to RB. The only way expressing this 
with the current draft seems to be:

        a=group:FEC-XR SB RB
        a=group:FEC-XR SB SE RB RB+E

I would expect that the grouping can signal that RB can be used 
separately for SB, but RB and RB+E can be also jointly used for the 
combination of SB and SE. Would the above grouping be in line with the 
current draft? I wonder if this may be somehow contrary to definition in 
section 4.1:

"Repair flows that are in different FEC groups are non-
   additive.".

If the signaling in the example above is in line with the intention of 
the draft, I would make the following modifications:

- You may add an "...exclusively in different FEC groups..." to the 
sentence of section 4.1 above.
- Further, I would add the following text to section 4.1 to make it clearer:

"In order to express multiple relations between source and repair flows, 
source and repair flows may appear in more than one FEC group."

I think the same should be valid for the FEC-SSRC grouping.

Best regards,
Thomas

-- 
Thomas Schierl
--------------
Fraunhofer HHI

Jean-Francois Mule wrote:
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 19 Oct 2009 07:20:31 -0700

Hi Thomas,

> -----Original Message-----
> From: Thomas Schierl [mailto:[email-masked]]
> Sent: Monday, October 19, 2009 8:16 AM
> To: Jean-Francois Mule
> Cc: [email-masked]; Joerg Ott; [email-masked]
> Subject: Re: [MMUSIC] WGLC on draft-ietf-mmusic-rfc4756bis-03
> 
> Dear Ali,
> 

If RB+E and RB were not additive, we would have:

a=group:FEC-XR SB RB
a=group:FEC-XR SB SE RB+E

But, now you are saying that they are additive, I believe we should have:
 
a=group:FEC-XR SB RB RB+E
a=group:FEC-XR SB SE RB+E

Because RB+E is additive to RB, that means it is protecting SB as well. Here I assumed RB exclusively protected SB. If this assumption does not hold, see below.

> current draft? I wonder if this may be somehow contrary to definition in

Now, this sounds different than the first scenario you described above, IMO. And, this leads to the original SDP you gave:

a=group:FEC-XR SB RB

> "Repair flows that are in different FEC groups are non-

Why would it be contrary? Here, RB and RB+E are in the same line and that is enough to state their additivity. But, in this scenario, their joint decoding helps the group of SB+SE. The above SDP says if the source consists of SB only, then just use RB only since RB+E would not help with decoding.
 
> sentence of section 4.1 above.

We can add this to make it stronger. But, I believe if two repair flows are additive in a group, it does not mean that they will also be additive in any other group where one of the source flows they protect is listed.

Agree?

> source and repair flows may appear in more than one FEC group."

I believe this was clear, but it is a good suggestion.
 
> I think the same should be valid for the FEC-SSRC grouping.

Sure.

Thanks for the review. Let me know if you agree with the above.

Cheers, acbegen.

---

From: Thomas Schierl <[email-masked]>
Date: Mon, 19 Oct 2009 17:33:43 +0200

Hi  Ali,

Ali C. Begen (abegen) wrote:

a=group:FEC-XR SB RB

You are right, RB and RB+E are meant to be additive with respect to
SB+SE.

section 4.1:

I think this makes the text clearer, at least to me.

Agree?

Good

Sure.

Thanks for the clarifications. I am ok with the changes and the
resulting draft.

Thomas

Cheers, acbegen.

Best regards,
Thomas

--
Thomas Schierl
--------------
Fraunhofer HHI

Thank you,
Jean-Francois.

--
Thomas Schierl
--------------
Fraunhofer HHI

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 19 Oct 2009 09:15:50 -0700

Cool, here is the new version addressing all remaining comments received so far.
http://www.ietf.org/id/draft-ietf-mmusic-rfc4756bis-05.txt

Cheers,
-acbegen

> Sent: Monday, October 19, 2009 11:34 AM
> To: Ali C. Begen (abegen)
> Cc: Jean-Francois Mule; [email-masked]; Joerg Ott; draft-ietf-mmusic-
> [email-masked]
> You are right, RB and RB+E are meant to be additive with respect to SB+SE.
> 
> 
> 
> 
> 
> 		section 4.1:
> 
> 	Why would it be contrary? Here, RB and RB+E are in the same line and that is enough
> to state their additivity. But, in this scenario, their joint decoding helps the group of
> SB+SE. The above SDP says if the source consists of SB only, then just use RB only since
> RB+E would not help with decoding.
> 
> 
> 
> 	We can add this to make it stronger. But, I believe if two repair flows are additive
> in a group, it does not mean that they will also be additive in any other group where one
> of the source flows they protect is listed.
> 
> 
> 
> Thanks for the clarifications. I am ok with the changes and the resulting draft.
> 
> Thomas
> 
> 
> 
> 
> 	Cheers, acbegen.
> 
> 
> 
> 
> 		Best regards,
> 		Thomas
> 
> 
> 		--
> 		Thomas Schierl
> 		--------------
> 		Fraunhofer HHI
> 
> 
>