Subject: Re: [MMUSIC] ABNF syntax in 3388bis

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 04 Nov 2009 13:36:37 +0200

Hi,

it needs to be optional so that an implementation can use a group line 
with no identification tags to express its capabilities (i.e., the 
values for grouping semantics it supports). For example, an 
implementation may only support LS and FID but none of the semantics 
extensions defined later.

Cheers,

Gonzalo

Ali C. Begen (abegen) wrote:
> I have a question about http://www.ietf.org/id/draft-ietf-mmusic-rfc3388bis-03.txt
> 
> Section 5 of -03 version says:
> 
>            group-attribute     = "a=group:" semantics
>                                  *(space identification-tag)
>            semantics           = "LS" / "FID" / semantics-extension
>            semantics-extension = token
> 
> I don't know every detail of the ABNF syntax, but here the identification tags seem to be totally optional, whereas we at least need two of them to be able to use the 'group' attribute, right?
> 
> So, should not we rather have:
> 
>            group-attribute     = "a=group:" semantics
>                                  2*(space identification-tag)
>            semantics           = "LS" / "FID" / semantics-extension
>            semantics-extension = token
> 
> -acbegen
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 4 Nov 2009 09:18:47 -0800

So, if an SDP from entity X says "a=group:FID" without any specific mid values, would that mean entity X can support group:FID semantics on any media streams? Is this for something like capability negotiation because that line does not mean anything specific (at least to me)?

Thanks,
-acbegen

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Wednesday, November 04, 2009 6:37 AM
> To: Ali C. Begen (abegen)
> Cc: [email-masked]
> Subject: Re: ABNF syntax in 3388bis
> 
> Hi,
> 
> > I don't know every detail of the ABNF syntax, but here the identification tags seem to
> be totally optional, whereas we at least need two of them to be able to use the 'group'
> attribute, right?
> >

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 04 Nov 2009 19:27:35 +0200

Hi,

Ali C. Begen (abegen) wrote:
> So, if an SDP from entity X says "a=group:FID" without any specific
> mid values, would that mean entity X can support group:FID semantics
> on any media streams? Is this for something like capability
> negotiation because that line does not mean anything specific (at
> least to me)?

yes, the section is indeed call Capability Negotiation and was already 
in RFC3388:

http://tools.ietf.org/html/rfc3388#section-8.3

8.3 Capability Negotiation

    A client that understands "group" and "mid" but does not want to make
    use of them in a particular session MAY want to indicate that it
    supports them.  If a client decides to do that, it SHOULD add an
    "a=group" line with no identification-tags for every semantics it
    understands.

    If a server receives an offer that contains empty "a=group" lines, it
    SHOULD add its capabilities also in the form of empty "a=group" lines
    to its answer.

Cheers,

Gonzalo