Subject: [MMUSIC] Asymmetric media with SDPCapNeg + extensions

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 17 Feb 2010 13:46:39 +0100

Hi

Nice to see an update of SDPCapNeg.

I raised the issue of asymmetric media ~1 year ago. The effort fell flat for various reasons.
I drafted a doc that proposed an extension to SDPCapNeg
http://tools.ietf.org/html/draft-johansson-mmusic-asymmetric-media-00
Bob Gilman reviewed  it (thanks Bob) and found a bunch of issues. Looking at it again I am prepared to say that it would probably not fly (have not given up completely though). Anyway the text in the draft gives a a few usecases where asymmetry is an issue.

So I started to look again at what one can do with the excisting (and to become) standards. 

Asymmetry in the two directions is probably the most difficult nut to crack. The state of the 
art solution is to just setup two media descriptions and use the sendonly, recvonly attributes. And perhaps this is the only good choice?, there is some potential waste with ports (unless one can use the same port for the two directions ?)
As I understand it grouping does not allow using the same port numbers but what if one group two media that run in different directions ?

The other part of the problem, namely to negotiate the number of streams in one direction can I believe be solved with the SDPCapNeg framework. For instance if one wish to offer the alternatives
1) 3 mono streams + 1 stereo stream
2) 2 mono streams + 1 stereo stream
3) 1 mono stream  + 1 stereo stream
4) 1 stereo stream
5) 1 mono stream

The offer SDP for (one direction) may look something like 

a=tcap:1 RTP/AVPF RTCP/AVP
a=creq:med-v0
m=audio 5000 RTP/AVP 98
a=sendonly
a=rtpmap:98 AMR-WB/16000/1
m=mcap:1,2,3 AMR-WB/16000/1
m=mcap:4 AMR-WB/16000/2
b=AS:40
a=bcap:1 AS:200
a=bcap:2 AS:160
a=bcap:3 AS:120
a=bcap:4 AS:80
a=bcap:5 AS:40
a=pcfg:1 t=1|2 m=1,2,3,4 b=1 pt=1:97,2:98,3:99;4,100
a=pcfg:2 t=1|2 m=1,2,4 b=2 pt=1:97,2:98,4,100
a=pcfg:3 t=1|2 m=1,4 b=3 pt=1:97,4:100
a=pcfg:4 t=1|2 m=4 b=4 pt=4:100
a=pcfg:5 t=1|2 m=1 b=5 pt=1:97

An answer SDP may look like

a=csup:med-v0
m=audio 5000 RTP/AVP 97 98 99 100
a=recvonly
a=rtpmap:97 AMR-WB/16000/1
a=rtpmap:98 AMR-WB/16000/1
a=rtpmap:99 AMR-WB/16000/1
a=rtpmap:100 AMR-WB/16000/2
b=AS:200
a=acfg:1 t=1 m=1,2,3,4 b=1 pt=1:97,2:98,3:99;4,100

My question then, would this do the job?, what have I missed ?

/Ingemar

=================================
INGEMAR JOHANSSON  M.Sc. 
Senior Research Engineer 

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com 
Visit http://labs.ericsson.com !
=================================

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 18 Feb 2010 08:43:40 +0100

Hi

My undesrtanding is that what you can do with legacy SDP, you can do with SDPCapNeg + a little more.
An SDPCapNeg* offer is in my viewpoint just a "smart encoding" of a lot of different "orthogonal" entities such as transport and media codecs*.
The SDPCapNeg* offer has some limited backwards compatibility for SDP parsers that don't understand SDPCapNeg. The SDPCapNeg answer is however fully backwards compatible.
As I see it SDPCapNeg* should be able to handle all the scenarios below.
I have focused mostly on 1) atleast the "A and B from completely different sources", the other scenarios, I believe needs support from the PL format (e.g SVC)
Scenario 2) less sure for the very reason that it is rarely talked about.
Scenario 3) may be handled by the grouping framework or by means forward error correction, SDPCapNeg* should not impose any additional issue here though.

Regards
Ingemar

* = SDPCapNeg + SPD Media capabilities negotiation

________________________________
From: Kyunghun Jung [mailto:[email-masked]]
Sent: den 18 februari 2010 03:25
To: Ingemar Johansson S; Bob Gilman; Roni Even; Flemming Andreasen
Subject: Re: [MMUSIC] Asymmetric media with SDPCapNeg + extensions

Dear all:

Our opinion is that wasting ports will not be a significant issue since there will be enough of them

in most cases, ranging from PCs to 3G handsets.

On the bundling of media streams, I expect that proper usage of SDPCapNeg might depend on the

relationship of the streams. There can be several possibilities.

(1) Completely independent

- Audio A and audio B are from completely different sources.

- Audio A is from the baseline mode of multi-resolution audio codec while audio B is from a higher layer

  of the same codec and same contents. (Audio A and B are not related at all.)

  Wavelet or subband audio/video codecs belong to this category.

(2) Partially correlated

- Audio A and B share some common information but each contains its own unshared by the other.

- Multiple Description Coding (MDC), introduced previously by video coding community, belongs to this category.

  (MDC was not successful and no standard exists for this kind of compression technology.)

(3) Redundant

- Audio A and B are identical but from different sources or via different routers.

Which case does the SDP offer/answer below correspond to? In general, the decision on the bundling methods

might depend on the media codec, transportation mechanisms (even they are above IP), and decoding capability of the receiver.

SDPCapNeg can be effective for some cases and might not in other cases, under current status.

Kyunghun Jung

------- Original Message -------
Sender : Ingemar Johansson S<[email-masked]>
Date : 2010-02-17 21:46 (GMT+09:00)
Title : [MMUSIC] Asymmetric media with SDPCapNeg + extensions

Hi

a=csup:med-v0

/Ingemar

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com
Visit http://labs.ericsson.com !
=================================
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic