Subject: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-misc-cap-00.txt

From: [email-masked]
Date: Tue, 16 Mar 2010 15:15:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title		: Miscellaneous Capabilities Negotiation in the Session Description Protocol (SDP)
	Author(s)	: M. Garcia-Martin, S. Veikkolainen, R. Gilman
	Filename	: draft-ietf-mmusic-sdp-misc-cap-00.txt
	Pages		: 17
	Date		: 2010-3-1
	
   SDP has been extended with a capability negotiation mechanism
   framework that allows the endpoints to negotiate transport protocols
   and attributes.  This framework has been extended with a Media
   capabilities negotiation mechanism that allows endpoints to negotiate
   additional media-related capabilities.  This negotiation is embedded
   into the widely-used SDP offer/answer procedures.

   This memo extends the SDP capability negotiation framework to allow
   endpoints to negotiate a number of miscellaneous SDP capabilities.
   In particular, this memo provides a mechanism to negotiate media
   titles ("i=" line for each media), connection data ("c=" line), and
   media bandwidth ("b=" line).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-misc-cap-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 17 Mar 2010 09:40:02 +0100

Can somebody please point me at the email thread that led to adoption of this as a work item?

Thanks,

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: 16 March 2010 22:15
> To: [email-masked]
> Cc: [email-masked]
> Subject: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-misc-cap-00.txt
> 
> This draft is a work item of the Multiparty Multimedia 
> Session Control Working Group of the IETF.
> 
> 	Title		: Miscellaneous Capabilities 
> Negotiation in the Session Description Protocol (SDP)

---

From: <[email-masked]>
Date: Wed, 17 Mar 2010 12:58:32 +0100

>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of ext Elwell, John
>Sent: 17 March, 2010 10:40
>To: [email-masked]
>Subject: Re: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-misc-cap-00.txt
>

Hello,
This was discussed and adopted as WG item already in Stockholm meeting. We had a long discussion with the authors of draft-boucadair-mmusic-ccap to align our work which is why the submission as WG item comes so late.

Regards,
Simo

>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 17 Mar 2010 13:17:26 +0100

Simo,

Thanks. However, there is no mention in the minutes about making it a work item. Furthermore, looking at the minutes for draft-boucadair-mmusic-ccap it clearly states there was no consensus. In particular the minutes state some unanswered questions, including comparison of the ccap solution with re-using ICE. So I am interested in how we got from this very inconclusive situation to adoption of the present work item. I have been unable to find anything in the post-Stockholm mailing list archives or the Hiroshima minutes.

John

> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: 17 March 2010 11:59
> To: Elwell, John; [email-masked]
> Subject: RE: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-misc-cap-00.txt
> 
> 
> 
> [mailto:[email-masked]] On Behalf
> >Of ext Elwell, John
> >Subject: Re: [MMUSIC] I-D 
> ACTION:draft-ietf-mmusic-sdp-misc-cap-00.txt
> >
> >Can somebody please point me at the email thread that led to 
> adoption of
> >this as a work item?
> 
> Hello,
> This was discussed and adopted as WG item already in 
> Stockholm meeting. We had a long discussion with the authors 
> of draft-boucadair-mmusic-ccap to align our work which is why 
> the submission as WG item comes so late.
> 
> Regards,
> Simo
> 
> >Thanks,
> >
> >John
> >

---

From: <[email-masked]>
Date: Wed, 17 Mar 2010 13:22:39 +0100

>From: ext Elwell, John [mailto:[email-masked]]
>Sent: 17 March, 2010 14:17
>To: Veikkolainen Simo (Nokia-D/Helsinki); [email-masked]
>Thanks. However, there is no mention in the minutes about making it a
>work item. Furthermore, looking at the minutes for draft-boucadair-
>mmusic-ccap it clearly states there was no consensus. In particular the
>minutes state some unanswered questions, including comparison of the
>ccap solution with re-using ICE. So I am interested in how we got from
>this very inconclusive situation to adoption of the present work item. I
>have been unable to find anything in the post-Stockholm mailing list
>archives or the Hiroshima minutes.

It indeed seems that the Stockholm minutes do not say anything about the adoption as WG item. However, I double-checked right after the meeting with the chairs whether my understanding about adoption was correct, and got a confirmation. Maybe Jean-Francois could comment on this.

Simo

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 17 Mar 2010 14:56:01 +0100

The reason I query this is because of the c-line negotiation mechanism, which introduces a new way of negotiation between IPv4 and IPv6, in contradiction to the outcome of IETF#68, when there was consensus to use ICE as the basis, rather than ANAT or SDP capability negotiation (and leading to the deprecation of ANAT in the approved ICE draft). Although I was not present in Stockholm, it is clear from the minutes that this issue was opened up again, but with no consensus. Therefore, after 8 months silence on the subject, it was a complete surprise to me to see a WG draft with a cap-neg-based mechanism for IPv4/IPv6 negotiation.

So I would indeed appreciate a comment from the chairs on this.

John 

> Sent: 17 March 2010 12:23
> To: Elwell, John; [email-masked]; [email-masked]
> >Subject: RE: [MMUSIC] I-D 
> It indeed seems that the Stockholm minutes do not say 
> anything about the adoption as WG item. However, I 
> double-checked right after the meeting with the chairs 
> whether my understanding about adoption was correct, and got 
> a confirmation. Maybe Jean-Francois could comment on this.
> 
> Simo
> 
> >John
> >
> >> Subject: RE: [MMUSIC] I-D 
> >> >> Subject: [MMUSIC] I-D

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 17 Mar 2010 16:09:51 +0100

I cannot point you at a thread, but if you are looking for examples of its use, then it is applied in 3GPP TS 24.292 which you can find at:

http://www.3gpp.org/ftp/Specs/html-info/24292.htm

regards

Keith

> [mailto:[email-masked]] On Behalf Of Elwell, John
> Sent: Wednesday, March 17, 2010 8:40 AM
> To: [email-masked]
> adoption of this as a work item?
> 
> Thanks,
> 
> John
>

---

From: <[email-masked]>
Date: Thu, 18 Mar 2010 07:42:36 +0100

>The reason I query this is because of the c-line negotiation mechanism,
>which introduces a new way of negotiation between IPv4 and IPv6, in
>contradiction to the outcome of IETF#68, when there was consensus to use
>ICE as the basis, rather than ANAT or SDP capability negotiation (and
>leading to the deprecation of ANAT in the approved ICE draft). Although
>I was not present in Stockholm, it is clear from the minutes that this
>issue was opened up again, but with no consensus. Therefore, after 8
>months silence on the subject, it was a complete surprise to me to see a
>WG draft with a cap-neg-based mechanism for IPv4/IPv6 negotiation.

Although the ccap attribute could be also used for IPv4/v6 negotiation, that was not the use case we developed the draft for (we targeted for alternative IP/PSTN addresses using draft-mmusic-sdp-cs).

There are other drafts (http://tools.ietf.org/html/draft-boucadair-mmusic-altc and http://tools.ietf.org/html/draft-hutton-mmusic-icemicrolite-01) which specifically target IPv4/v6 negotiation.

Simo

---

From: Jean-Francois Mule <[email-masked]>
Date: Mon, 22 Mar 2010 15:06:32 -0600

John,

  I cannot find an email to the mmusic list indicating that the chairs intended to make draft-garcia-mmusic-sdp-misc-cap-01 a working group item and asking for any objections or comments.  Like Simo, I was convinced we had agreed to make this a wg item and did not check before approving the request when the ID was proposed in early March 2010.  This is of course contradictory to our process.

  Mea culpa - we will discuss at the meeting how to proceed on that.

  I will provide more comments on the rest of this email in a separate note as an individual contributor.

Jean-Francois
MMUSIC co-chair

John wrote:
> The reason I query this is because of the c-line negotiation
> mechanism, which introduces a new way of negotiation between IPv4
> and IPv6, in contradiction to the outcome of IETF#68, when there
> was consensus to use ICE as the basis, rather than ANAT or SDP
> capability negotiation (and leading to the deprecation of ANAT in
> the approved ICE draft). 
> Although I was not present in Stockholm,
> it is clear from the minutes that this issue was opened up again,
> but with no consensus. Therefore, after 8 months silence on the
> subject, it was a complete surprise to me to see a WG draft with a
> cap-neg-based mechanism for IPv4/IPv6 negotiation.
> 
> > >> >>    framework that allows the endpoints to negotiate
> transport
> > >> >> protocols
> > >> >> http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-
> misc
> > >> >> -cap-00.txt
> > >> >>

---

From: Jean-Francois Mule <[email-masked]>
Date: Mon, 22 Mar 2010 16:44:56 -0600

I wanted to come back to John's note and zoom in on the scope and areas of applicability of draft-ietf-mmusic-sdp-misc-cap.
	
> capability negotiation (and leading to the deprecation of ANAT in

This ID (draft-ietf-mmusic-sdp-misc-cap-00.txt) introduces additional capability negotiation semantics into the general SDP capneg framework (i, c and b lines in SDP can now ). For the record, this ID was previously http://tools.ietf.org/html/draft-garcia-mmusic-sdp-misc-cap-01 and has been discussed in several MMUSIC meetings and on the list.

a) About the bcap:
I believe no objections have been raised on the capability attribute for bandwith (bcap).

b) icap:
There were some comments during an IETF meeting from Ted and others about the icap.

c) About the connection capability (ccap): 
draft-ietf-mmusic-sdp-misc-cap allows the negotiation of capabilities related to the c line.
If you recall, draft-garcia-mmusic-sdp-misc-cap-01 was introduced shortly after http://tools.ietf.org/html/draft-garcia-mmusic-sdp-cs-02 (now draft-ietf-mmusic-sdp-cs-03).
For folks that do want to use sdp capneg for proposing SDP configurations with CS bearers (c=pstn, see draft-ietf-mmusic-sdp-cs-03) as alternative to media connections (e.g., c=IN IP4), ccap as defined in misc-cap can do that.  It was noted in IETF#72 that using ICE for proposing CS bearers as ICE candidates may not be a good idea because the connectivity check requirements associated with ICE http://www.ietf.org/proceedings/72/minutes/mmusic.html). 
As for proposing IPv4/IPv6 alternatives, ICE deprecates ANAT and is the preferred solution the WG has chosen so far per IETF#68.

In summary, and this is a personal comment, I believe misc-cap is a draft that complements the sdp cap neg framework.

Thoughts and comments appreciated.

Jean-Francois.