Subject: [MMUSIC] Clarification on PLAY_NOTIFY end-of-stream

From: Jan Lindquist <[email-masked]>
Date: Tue, 13 Apr 2010 14:43:47 +0200

Hello,

The section 13.5.1 on End-of-Stream indicates that the PLAY_NOTIFY with end-of-stream means that the fastforward PLAY request is concluded. I would like to get a clarification if that means that a new PLAY request is not allowed in the forward direction.

Even if the range header may indicate that the end-of-stream is nearing (like in the example npt=-15 if the stream is currently at 14.2) can a new PLAY request be performed in the forward direction? There is no explicit statement and it would be a good idea to clarify. Either the behaviour is restrictive based on previous scale value or it is independent of the previous scale value. At this stage I suggest to be less restritive.

Clarification could be added in section 13.5.1 after the second paragraph.

"The end-of-stream notification shall not prevent the client from sending a new PLAY request."

Regards,
JanL

---

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 20 Apr 2010 14:29:55 +0200

Hi Jan,

The client is allowed to issue a new PLAY request even though the server has indicated end-of-stream.

I have added your text suggestion to the 2nd para of 13.5.1.

Thanks,

  Martin

> -----Original Message-----
> From: Jan Lindquist [mailto:[email-masked]]
> Sent: Tuesday, April 13, 2010 2:44 PM
> To: Martin Stiemerling; [email-masked]
> Subject: Clarification on PLAY_NOTIFY end-of-stream
> 
> Hello,
> 
> The section 13.5.1 on End-of-Stream indicates that the PLAY_NOTIFY with
> end-of-stream means that the fastforward PLAY request is concluded. I
> would like to get a clarification if that means that a new PLAY request
> is not allowed in the forward direction.
> 
> Even if the range header may indicate that the end-of-stream is nearing
> (like in the example npt=-15 if the stream is currently at 14.2) can a
> new PLAY request be performed in the forward direction? There is no
> explicit statement and it would be a good idea to clarify. Either the
> behaviour is restrictive based on previous scale value or it is
> independent of the previous scale value. At this stage I suggest to be
> less restritive.
> 

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014