Subject: [MMUSIC] Header Syntax: User-Agent/Server, etc

From: "Martin Stiemerling" <[email-masked]>
Date: Wed, 19 May 2010 14:36:25 +0200

Hi all,

Christian Haas raise the below issue in his email of Saturday, April 03, 2010 7:16 PM:

> 
> 
> 2. Header syntax:
> User-Agent is still only a request-header and Server only a
> response-header. What may the respective agents send for the
> PLAY_NOTIFY
> and REDIRECT exchanges? I don't think the server should send User-Agent
> and the client Server.
> I would even go as far as to drop the ABNF separation of request-header
> and response-header and put them all into general-header. Tables 10-12
> already list in detail which header may appear in which message.
> Note: All the examples with PLAY_NOTIFY and REDIRECT have the client
> send User-Agent in the response, violating the current classification
> of
> response-header - a pedantic parser would treat them as extension-
> header
> now.
> 
> (One step even further would be too drastic I guess and not desired:
> unify User-Agent and Server and simply call the header "Agent")

I would opt for relaxing the User-Agent and Server headers from their response vs. reply property.

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: "Martin Stiemerling" <[email-masked]>
Date: Thu, 27 May 2010 10:28:09 +0200

Hi all,

Any objection to the proposal of 
> response vs. reply property.
(see below).

I will apply this, unless there is any objection send to the mmusic mailing list by May 28th 3pm CEST.

Thanks,

  Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Martin Stiemerling
> Sent: Wednesday, May 19, 2010 2:36 PM
> To: [email-masked]
> Subject: [MMUSIC] Header Syntax: User-Agent/Server, etc
> 
> Hi all,
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic