Subject: Re: [MMUSIC] Header Syntax: User-Agent/Server, etc

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 29 Jun 2010 13:54:21 +0200

Hi, 

After checking the draft again, I see no need to change the semantics for User-Agent and Server. However, I can see the reason for the confusion in this case:

There are two tables where User-Agent and Server are described, Table 10 and  Table 12. Table 10 lists the values for "DESCRIBE, OPTIONS, SETUP, PLAY, PAUSE, and TEARDOWN" while Table 12 lists the values for "GET_PARAMETER, SET_PARAMETER, REDIRECT, and PLAY_NOTIFY". 

The entries for User-Agent and Server are fine, considering both tables.

Sorry for the confusion and this seems to be fixed :)
(close ticket in the tracker: ID: 3004036
https://sourceforge.net/tracker/?func=detail&aid=3004036&group_id=23194&atid=377744)

Best regards

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Martin Stiemerling
> Sent: Wednesday, May 19, 2010 2:36 PM
> To: [email-masked]
> Subject: [MMUSIC] Header Syntax: User-Agent/Server, etc
> 
> Hi all,
> 
> Christian Haas raise the below issue in his email of Saturday, April
> 03, 2010 7:16 PM:
> 
> >
> >
> > 2. Header syntax:
> > User-Agent is still only a request-header and Server only a
> > response-header. What may the respective agents send for the
> > PLAY_NOTIFY
> > and REDIRECT exchanges? I don't think the server should send User-
> Agent
> > and the client Server.
> > I would even go as far as to drop the ABNF separation of request-
> header
> > and response-header and put them all into general-header. Tables 10-
> 12
> > already list in detail which header may appear in which message.
> > Note: All the examples with PLAY_NOTIFY and REDIRECT have the client
> > send User-Agent in the response, violating the current classification
> > of
> > response-header - a pedantic parser would treat them as extension-
> > header
> > now.
> >
> > (One step even further would be too drastic I guess and not desired:
> > unify User-Agent and Server and simply call the header "Agent")
> 
> 
> I would opt for relaxing the User-Agent and Server headers from their
> response vs. reply property.
> 
>   Martin
> 
> 
> [email-masked]
> 
> NEC Laboratories Europe - Network Research Division
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: "HAAS Christian" <[email-masked]>
Date: Tue, 29 Jun 2010 14:24:05 +0200

Hello!

From: Martin Stiemerling [mailto:[email-masked]] 
> The entries for User-Agent and Server are fine, considering both tables.

I think we have a misunderstanding here; I was referring to the syntax in
chapter 20, which I as following in "pedantic-parser" mode: (Copying relevant
syntax lines)

Request = Request-Line *((general-header / request-header / message-header)
CRLF) ...
Response = Status-Line *((general-header / response-header / message-header)
CRLF) ...

request-header = ... User-Agent ...
response-header = ... Server ...

Following these rules, only a request may contain an User-Agent header and
only a response a Server header.
Of course they can be included in the respective other message type (as
needed by the two server initiated requests), but as I wrote, a /very/
pedantic parser would resolve these header lines to the generic
"extension-header" definition.

My proposal is to change the syntax definitions and move the User-Agent and
Server lines to the general-header definition.
Sorry I wasn't that clear initially.

Regards,
ch

NEC Laboratories Europe - Network Research Division NEC Europe Limited |
Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in
England 2832014 

> > PLAY_NOTIFY and REDIRECT exchanges? I don't think the server should 
> > send User-
> Agent
> > and the client Server.
> > send User-Agent in the response, violating the current 
> > classification of response-header - a pedantic parser would treat 
> > them as extension- header now.
> >
> NEC Laboratories Europe - Network Research Division NEC Europe Limited 
> | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | 
> Registered in England 2832014
> 
>

---

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 29 Jun 2010 14:48:21 +0200

ah - I got it now! Sorry for the misunderstanding. 

Moving "User-Agent" and "Server" to the general-header is fine with me.

Any objections from the WG?

  Martin

> Behalf Of HAAS Christian
> Sent: Tuesday, June 29, 2010 2:24 PM
> To: Martin Stiemerling; [email-masked]
> Subject: Re: [MMUSIC] Header Syntax: User-Agent/Server, etc
> 
> Hello!
> 
> |