Subject: Re: [MMUSIC] draft-ietf-mmusic-image-attributes, question regarding frame rate

From: Kyunghun Jung <[email-masked]>
Date: Thu, 03 Jun 2010 06:53:25 +0000 (GMT)

Dear MMUSIC experts:

In fact, the primary application of "a=imageattr" considered then was point-to-point 3/4G mobile multimedia telephony

and in the typical cases of bit-rate fluctuation, quantizer or framerate would be controlled, rather than reducing the image size

since in most cases video decoder might not be able to handle such changes.

Kyunghun Jung

Samsung Electronics Co., Ltd.

------- Original Message-------
Sender: Ingemar Johansson S<[email-masked]>
Date: 2010-06-03 15:39 (GMT+09:00)
Title: Re: [MMUSIC] draft-ietf-mmusic-image-attributes, question regarding frame rate

Hi

Thanks for the reply
The frame rate was in the first individual submissions, but I later removed it after some discussion. But I am inclined to agree, I don't believe that frame rate really fits here so I will not include frame rate in the draft.

Regards
Ingemar

> -----Original Message-----
> From: Roni Even [mailto:[email-masked]]
> Sent: den 2 juni 2010 17:53
> To: Ingemar Johansson S; 'mmusic'
> Subject: RE: draft-ietf-mmusic-image-attributes, question
> regarding frame rate
>
> Hi,
> I am not sure that frame rate was in this draft. There is an
> SDP attribute for frame rate see RFC 4566 section 6 a=framerate.
>
> As for this draft, the motivation is to allow a receiver not
> to scale the image and frame rate is not related to scaling
> just the image size.
>
> Roni Even
>
> > -----Original Message-----
> > From: Ingemar Johansson S [mailto:[email-masked]]
> > Sent: Wednesday, June 02, 2010 4:27 PM
> > To: mmusic
> > Cc: Roni Even; Ingemar Johansson S
> > Subject: draft-ietf-mmusic-image-attributes, question
> regarding frame
> > rate
> >
> > Hi
> >
> > First of all, thanks for all the comments on the image
> attribute draft.
> > I will submit a new version at the end of the week or early
> next week.
> >
> > I received a question regarding frame rate . In an early version it
> > was possible to specify a frame rate range. See
> >
> http://tools.ietf.org/id/draft-johansson-mmusic-image-attributes-01.tx
> > t
> >
> > For some reason this was removed but I don't anymore
> remember why. I
> > recall that the reason was that, while frame rate may have
> a meaning
> > in older codecs such as H.261, it has less meaning for e.g H.264.
> > Moreover the "framerate" in H.264 is given by the level. But it is
> > possible that my memory is totally off.
> > Any comments around this are welcome
> >
> > Regards
> > /Ingemar
> > =================================
> > INGEMAR JOHANSSON  M.Sc.
> > Senior Research Engineer
> >
> > Ericsson AB
> > Multimedia Technologies
> > Labratoriegränd 11
> > 971 28, Luleå, Sweden
> > Phone +46-1071 43042
> > SMS/MMS +46-73 078 3289
> > [email-masked]
> > www.ericsson.com
> > Visit http://labs.ericsson.com !
> > =================================
>
>
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Roni Even" <[email-masked]>
Date: Thu, 3 Jun 2010 18:07:00 +0300

Hi,

There are SDP parameters for this.

A= framerate

B= for bandwidth

A=quality for image quality

Roni Even

From: Kyunghun Jung [mailto:[email-masked]] 
Sent: Thursday, June 03, 2010 9:53 AM
To: Ingemar Johansson S; Roni Even; 'mmusic'
Subject: Re: Re: [MMUSIC] draft-ietf-mmusic-image-attributes, question
regarding frame rate

Dear MMUSIC experts:

In fact, the primary application of "a=imageattr" considered then was
point-to-point 3/4G mobile multimedia telephony

and in the typical cases of bit-rate fluctuation, quantizer or framerate
would be controlled, rather than reducing the image size

Kyunghun Jung

------- Original Message-------
Sender: Ingemar Johansson S<[email-masked]>
Date: 2010-06-03 15:39 (GMT+09:00)
Title: Re: [MMUSIC] draft-ietf-mmusic-image-attributes, question regarding
frame rate

Hi 

Thanks for the reply 
The frame rate was in the first individual submissions, but I later removed
it after some discussion. But I am inclined to agree, I don't believe that
frame rate really fits here so I will not include frame rate in the draft. 

Regards 
Ingemar  

> > From: Ingemar Johansson S [mailto:[email-masked]] 
> > Sent: Wednesday, June 02, 2010 4:27 PM 
> > To: mmusic 
> > Cc: Roni Even; Ingemar Johansson S 
> > Subject: draft-ietf-mmusic-image-attributes, question  
> regarding frame  
> > rate 
> >  
> > Hi 
> >  
> > First of all, thanks for all the comments on the image  
> attribute draft. 
> > I will submit a new version at the end of the week or early  
> next week. 
> >  
> > I received a question regarding frame rate . In an early version it  
> > was possible to specify a frame rate range. See  
> >  
> > t 
> > For some reason this was removed but I don't anymore  
> remember why. I  
> > recall that the reason was that, while frame rate may have  
> a meaning  
> > in older codecs such as H.261, it has less meaning for e.g H.264.  
> > Moreover the "framerate" in H.264 is given by the level. But it is  
> > possible that my memory is totally off. 
> > Any comments around this are welcome 
> >  
> > Regards 
> > /Ingemar 
> > ================================= 
> > INGEMAR JOHANSSON  M.Sc. 
> > Senior Research Engineer 
> >  
> > Ericsson AB 
> > Multimedia Technologies 
> > Labratoriegränd 11 
> > 971 28, Luleå, Sweden 
> > Phone +46-1071 43042 
> > SMS/MMS +46-73 078 3289 
> > [email-masked] 
> > www.ericsson.com 
> > Visit http://labs.ericsson.com ! 
> > ================================= 
>  
>