Subject: [MMUSIC] RTSPv2 bandwidth indication

From: Jan Lindquist <[email-masked]>
Date: Fri, 11 Jun 2010 10:21:40 +0200

Hello,

The response to the RTSP DESCRIBE includes an SDP which is according to RFC4566. The bandwidth information is populated as follows (section 5.8):

   The <bandwidth> is interpreted as kilobits per second by default.

Additionally the bandwidth is the maximum bandwidth of the stream to be setup.

The bandwidth header in the RTSP SETUP is populated as follows (section 16.8):

   The Bandwidth request-header field describes the estimated bandwidth
   available to the client, expressed as a positive integer and measured
   in bits per second.  The bandwidth available to the client may change
   during an RTSP session, e.g., due to mobility, congestion, etc.

The two text have a mismatch and should be clarified.

1. The values used are different which is an unfortunate oversight. Possibly could use the same format as the SDP bandwidth format with bandwidth type.

2. Not clear what is meant by estimated bandwidth available to the client. How can a client estimate it the bandwidth. If the client has a gigabit ethernet connection does it estimate based on interface. The client can't either be sure what type of access line is in the home if fiber or DSL. I would instead thought it is the maximum bandwidth that the client expects to use for the session which is retrieved from the DESCRIBE or other means.

Regards,
JanL

---

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 29 Jun 2010 14:42:40 +0200

Hi, 

> -----Original Message-----
> From: Jan Lindquist [mailto:[email-masked]]
> Sent: Friday, June 11, 2010 10:22 AM
> To: Martin Stiemerling; mmusic (E-mail)
> Subject: RTSPv2 bandwidth indication
> 
> Hello,
> 
> The response to the RTSP DESCRIBE includes an SDP which is according to
> RFC4566. The bandwidth information is populated as follows (section
> 5.8):
> 
> 1. The values used are different which is an unfortunate oversight.
> Possibly could use the same format as the SDP bandwidth format with
> bandwidth type.

This sounds reasonable to me. 

> 
> 2. Not clear what is meant by estimated bandwidth available to the
> client. How can a client estimate it the bandwidth. If the client has a
> gigabit ethernet connection does it estimate based on interface. The
> client can't either be sure what type of access line is in the home if
> fiber or DSL. I would instead thought it is the maximum bandwidth that
> the client expects to use for the session which is retrieved from the
> DESCRIBE or other means.

The Bandwidth header is originally defined in RTSP 1.0 (RFC 2326), Section 12.6. I'm probably not long enough in business with RTSP to tell the actual reasons for this. 

Anybody else who help out here?

  Martin