Subject: [MMUSIC] Redirection related to RTSP DESCRIBE

From: Jan Lindquist <[email-masked]>
Date: Fri, 11 Jun 2010 10:21:42 +0200

Hi,

The section 13.2 states that the RTSP DESCRIBE must contain a description as stated below.

   The server MUST respond with a description of the requested resource and return the
   description in the message body of the response.

Then there is a statement that it should contain all media initialization information and that a 3rr response is recommended to retrieve the information.

   The DESCRIBE response SHOULD contain all media initialization
   information for the resource(s) that it describes.  Servers SHOULD
   NOT use the DESCRIBE response as a means of media indirection by
   having the description point at another server, instead usage of 3rr
   responses are recommended.

There is a conflict in the text. The server MAY respond with a description and not MUST. I would  also suggest adding a text clarifying the second text above. If 3rr is used then the media initilization is in the response to the RTSP DESCRIBE after redirection according to the 3rr response.

To support the above change section 15.3 states:

   A 3rr code MAY be used to respond to any request.  It is RECOMMENDED
   that they are used if necessary before a session is established,
   i.e., in response to DESCRIBE or SETUP.

Regards,
JanL

---

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 29 Jun 2010 14:35:09 +0200

Hi Jan,

Indeed confusing. 

> -----Original Message-----
> From: Jan Lindquist [mailto:[email-masked]]
> Sent: Friday, June 11, 2010 10:22 AM
> To: Martin Stiemerling; mmusic (E-mail)
> Subject: Redirection related to RTSP DESCRIBE
> 
> Hi,
> 

This part does not make sense in an error case either. The server cannot response with a description of the resource if there is an error...

Changed the text to:
" The server MUST respond with a description of the requested resource and return the description in the message body of the response, if the DESCRIBE method request can be successfully fulfilled".

and logically also
 The DESCRIBE response MUST contain all media initialization
 information for the resource(s) that it describes.

The two text parts are now also back-to-back, i.e., moved the example a bit down in the text flow.

Thanks,

  Martin

> 
> Then there is a statement that it should contain all media
> initialization information and that a 3rr response is recommended to
> retrieve the information.
> 
> There is a conflict in the text. The server MAY respond with a
> description and not MUST. I would  also suggest adding a text
> clarifying the second text above. If 3rr is used then the media
> initilization is in the response to the RTSP DESCRIBE after redirection
> according to the 3rr response.
> 

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Jan Lindquist <[email-masked]>
Date: Tue, 29 Jun 2010 14:52:12 +0200

Hi Martin,

My only concern with the proposed change is that indirection may occur after DESCRIBE and at SETUP. So the DESCRIBE may not have all the media initialization information. As currently stated the initialization information SHOULD be present. So changing to "MUST" is more than an editorial change.

So I would suggest to keep the "SHOULD" and not change it to "MUST".

Regards,
JanL

> From: Martin Stiemerling [mailto:[email-masked]] 
> Sent: Tuesday, June 29, 2010 2:35 PM
> To: Jan Lindquist; mmusic (E-mail)
> Subject: RE: Redirection related to RTSP DESCRIBE
> 
> Hi Jan,
> 
> Indeed confusing. 
> 
> 
> 
> This part does not make sense in an error case either. The 
> server cannot response with a description of the resource if 
> there is an error...
> 
> Changed the text to:
> " The server MUST respond with a description of the requested 
> resource and return the description in the message body of 
> the response, if the DESCRIBE method request can be 
> successfully fulfilled".
> 
> and logically also
> Servers SHOULD
> > initilization is in the response to the RTSP DESCRIBE after 
> > redirection according to the 3rr response.
> > 
> NEC Laboratories Europe - Network Research Division NEC 
> Europe Limited | Registered Office: NEC House, 1 Victoria 
> Road, London W3 6BL | Registered in England 2832014
>

---

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 29 Jun 2010 14:59:28 +0200

True, kept SHOULD.

> Sent: Tuesday, June 29, 2010 2:52 PM
> My only concern with the proposed change is that indirection may occur
> after DESCRIBE and at SETUP. So the DESCRIBE may not have all the media
> initialization information. As currently stated the initialization
> information SHOULD be present. So changing to "MUST" is more than an
> editorial change.
>