Subject: Re: [MMUSIC] [Sip-implementors] dynamic payload negotiation

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Mon, 29 Nov 2010 14:48:11 +0100

Asymmetric media configurations are in general possible.
See SDP Offer/Answer, RFC 3264.
Both directions are independent.
Thus, different media configurations may be negotiated for the two Offerer-to-Answerer directions.

To the folks responsible for these RFCs:
this is a FAQ since years and years, it would be really beneficial to make such conceptual things more explicit in the RFC texts. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On 
> Behalf Of Saúl Ibarra Corretgé
> Sent: Montag, 29. November 2010 14:13
> To: varun
> Cc: [email-masked]
> Subject: Re: [Sip-implementors] dynamic payload negotiation
> 
> > Also I believe that even static paylaod types can be used 
> as dynamic ones.
> > So lets say party A sends G711 a-law with payload type 0 
> but party B sends G711 a-law with dynamic payload 100 so what 
> should happen in this case.
> >
> 
> Can you provide a reference to this? Is it really allowed?
> 
> 
> Regards,
> 
> --
> /Saúl
> http://saghul.net | http://sipdoc.net
> 
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 29 Nov 2010 17:20:08 +0100

> this is a FAQ since years and years, it would be really beneficial to make such conceptual things more explicit in the RFC texts.

I strongly agree.

-- 
Iñaki Baz Castillo
<[email-masked]>