Subject: [MMUSIC] Flaw in traffic class ID regarding payload type

From: "James M. Polk" <[email-masked]>
Date: Fri, 06 Jan 2012 17:55:28 -0600

WG

It's been pointed out to me that I omitted distinguishing traffic 
class labels by payload type. I remember thinking that was necessary, 
but somehow lost the thought a while ago.

Because more than one payload type can be in each m= line, ISTM it is 
reasonable to have cases in which one/some/each payload type has a 
different traffic class label.

Is this concept agreeable within the WG?

If so, I propose I change the draft to reflect that by simply adding 
a "pt=x" to the ABNF after "trafficclass" and before the label 
itself. For example (one that's in the draft now), change

   a=trafficclass Conversational.video.immersive._foo._bar

to

   a=trafficclass pt=112 Conversational.video.immersive._foo._bar

(or whatever payload type(s) are in the m= line).

I could add an example that shows - within the same m= line - more 
than one payload type each having their own respective traffic class label.

The ABNF is easily (even for me) corrected.

Comments please?

James

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 09 Jan 2012 18:10:10 -0500

On 1/6/12 6:55 PM, James M. Polk wrote:
> WG
>
> It's been pointed out to me that I omitted distinguishing traffic class
> labels by payload type. I remember thinking that was necessary, but
> somehow lost the thought a while ago.
>
> If so, I propose I change the draft to reflect that by simply adding a
> "pt=x" to the ABNF after "trafficclass" and before the label itself. For
> example (one that's in the draft now), change
>
> I could add an example that shows - within the same m= line - more than
> one payload type each having their own respective traffic class label.
>
Can you clarify the intended semantics?

- Is the pt= optional?
- If so, when absent does it imply all payload types?
- Is it possible to specify a default for all payload types and then
   a specific value for certain payload types?

	Thanks,
	Paul