Subject: Re: [MMUSIC] Question about the various "range-spec"s defined for RTSP 2.0 (and RTSP 1.0)

From: Joe Pallas <[email-masked]>
Date: Mon, 23 Jan 2012 13:47:20 -0800

On Jan 23, 2012, at 12:00 PM, [email-masked] wrote:

> On 2011-11-26 20:53, Ross Finlayson wrote:
>> In "draft-ietf-mmusic-rfc2326bis-28" (and preceding), a "npt-range-spec"
>> is defined as
>> npt-range-spec = ( npt-time "-" [ npt-time ] ) / ( "-" npt-time )
>> (ditto for "smtp-range-spec" and "utc-range-spec").
>> 
>> This suggests that the following are valid:
>> npt = -now
>> npt = -12.34
>> 
>> What are these supposed to mean (especially given that - in section 4.5
>> - you say that "Negative values are not defined")?
> 
> 
> It means play from "now" or stored playout point _until_ the given
> value. I agree that npt=-now does not make sense, so that should be made
> clear is not valid. Please also remember that the timescale can go
> backwards.

Whoops.  Don’t say "now" when you mean the current pause point, it will confuse everyone.

I disagree and would say that “npt = -now” makes sense.  How else would I express “fast forward from the pause point to the current time” (that is, fast forward to live after pause) in a DVR-like system if not by a scale > 1 and a range of (implicit) pause-point to now?

joe

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 24 Jan 2012 08:57:17 +0100

On 2012-01-23 22:47, Joe Pallas wrote:
>>> In "draft-ietf-mmusic-rfc2326bis-28" (and preceding), a
>>> "npt-range-spec" is defined as npt-range-spec = ( npt-time "-" [
>>> npt-time ] ) / ( "-" npt-time ) (ditto for "smtp-range-spec" and
>>> "utc-range-spec").
>>> 
>>> This suggests that the following are valid: npt = -now npt =
>>> -12.34
>>> 
>>> What are these supposed to mean (especially given that - in
>>> section 4.5 - you say that "Negative values are not defined")?
>> 
>> 
>> value. I agree that npt=-now does not make sense, so that should be
>> made clear is not valid. Please also remember that the timescale
>> can go backwards.
> 

The "now" in my above text do apply for live streams that aren't
recorded, where there is no other point then what is currently being
transmitted.

> 
> I disagree and would say that “npt = -now” makes sense.  How else
> would I express “fast forward from the pause point to the current
> time” (that is, fast forward to live after pause) in a DVR-like
> system if not by a scale > 1 and a range of (implicit) pause-point to
> now?

Yes, in that context is makes sense. It doesn't make sense if you are in
a live context without recording where you can't play anything else than
now. Then it completes immediately.

But, there is obviously some expansion on what can occur under different
media properties.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------